Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

On firefox I'm not able to compose a message in my yahoo email. Works on safari

  • 3 replies
  • 1 has this problem
  • 1 view
  • Last reply by cor-el

more options

When I'm on my yahoo email and I go to compose a new email it will not open that compose window. Therefore I can't make or send any new emails. Also, the area on the side where all the files are shown is messed up, half of the titles are cut off. The window also has a jerky look, like a glitch. My email works normally in Safari. It's been like this for 2 days now. I tried to add a screenshot to this question but the browse function isn't letting me do that.

All Replies (3)

more options

Hello,

Does the error occur in private mode (Menu > Private Window)?

Could you upload the screenshot using Safari? We'll probably need it.

more options

Hi mina.kosar, your Firefox identified itself as version 48, which I guess was the last release for MacOS X 10.6.x. It's possible Yahoo has updated their code to make it incompatible, but we nevertheless can suggest troubleshooting steps.


To supplement the first suggestion:

If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first).

In older versions of Firefox, one way to access a filtered cookie list was through the Page Info dialog. Either:

  • Tools > Page Info
  • right-click (Ctrl+click) a blank area of the page > View Page Info

On the Security tab, click the button to view cookies. This list should be filtered to the site you're on so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Note that the Firefox 45.9.0 ESR was released later (April 19, 2017) than the Firefox 48 release and has more security fixes.


You probably need these instructions for your older Firefox version:

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy -> Firefox will: "Use custom settings for history" -> Cookies: "Show Cookies"

"Clear the Cache":

  • Options/Preferences -> Advanced -> Network
    Cached Web Content: "Clear Now"