Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox won’t launch after running selenium tests

  • 1 reply
  • 1 has this problem
  • Last reply by cor-el

more options

Bit of a niche question hope someone can help.

I’m running some website testing and have a script set up to open Firefox at regular intervals using Selenium in python, run tests and exit. Running it in a MacBook using Catalina and have the latest versions of Firefox. I tried a different MacBook as well.

Randomly, after running enough tests, it will fail to launch, throwing and error code “can’t quit and exited process”.

Once this happens, I can’t open Firefox at all, even manually. The icon just bounces and fails to launch. Oddly enough, I can’t launch Chrome either, even if I haven’t launched it since restart. Restarting my computer will fix the problem always.

I’ve tried running in headless mode to, no avail. Any ideas here?

All Replies (1)

more options

Did you check the activity monitor ?