X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

My addons doesn't show up in the top right bar

Posted

Basically i noticed that whenever i installed adblock or any other addons they don't show up in the top right bar as icon and even if i have them enabled they do not work, i searched a bit and it seems to be an old issue that was present with some older version of firefox, is somebody currently experiecing this?

Basically i noticed that whenever i installed adblock or any other addons they don't show up in the top right bar as icon and even if i have them enabled they do not work, i searched a bit and it seems to be an old issue that was present with some older version of firefox, is somebody currently experiecing this?
Attached screenshots

Chosen solution

Thank you very much for your help Fred and Cor-el. I noticed that if you do put in the option of firefox never remember history, this might be the cause of what might not let the addon work at all and be displayed in the top right bar, as silly at it may sounds, i'll do a quick restart to be sure of it, i'll edit this message if possible

Edit, indeed it was that option of firefox that caused the problem it seems

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

Default plugins installed by mozilla Open H264 Video Codec and Widevine Content Decryption Module

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

More Information

FredMcD
  • Top 10 Contributor
4385 solutions 61561 answers

First: Customize Firefox controls, buttons and toolbars {web link}

Type about:customizing<enter> in the address bar.

Note: about:customizing is no longer present in Firefox 47+ releases.

  • Press Alt or F10 to bring up the Menu Bar.
    Then View > Toolbars > Customize.
  • Right-click on a blank spot in the toolbar and
    select Customize.

In the new window, look for the icon. When you find it, hold down the left button on it, and move it to where you want it to be. You can move any of the icons you want from here, but; some icons are locked in place.

There is also a Restore Defaults button at the bottom middle.

First: [https://support.mozilla.org/en-US/kb/customize-firefox-controls-buttons-and-toolbars Customize Firefox controls, buttons and toolbars] {web link} Type '''about:customizing'''<enter> in the address bar. Note: '''about:customizing''' is no longer present in Firefox 47+ releases. * Press '''Alt''' or '''F10''' to bring up the Menu Bar.<br>Then '''View > Toolbars > Customize. ''' * Right-click on a blank spot in the toolbar and<br>select '''Customize. ''' In the new window, look for the icon. When you find it, hold down the left button on it, and move it to where you want it to be. You can move any of the icons you want from here, but; '''some icons are locked in place. ''' There is also a '''Restore Defaults''' button at the bottom middle.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4385 solutions 61561 answers

After: It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":

+++++++++++++++++++++++++++ You will have to approve the updating one last time.

After: It’s possible that there is a problem with the file(s) that store the extensions registry. Type '''about:support''' in the address bar and press enter. Under the page logo on the left side, you will see '''Application Basics. ''' Under this find '''Profile Folder. ''' To its right press the button '''Show Folder. ''' This will open your file browser to the current Firefox profile. Now '''Close Firefox. ''' Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder '''Linux: ''' Under the page logo on the left side, you will see '''Application Basics.''' Under this find '''Profile Directory. ''' To its right press the button '''Open Directory. ''' Delete all '''extensions*''' files and '''compatibility.ini''' in the Firefox profile folder to reset the extensions registry. *https://support.mozilla.org/kb/Profiles New files will be created when required. After, restart Firefox. See "Corrupt extension files": *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions *https://support.mozilla.org/kb/Unable+to+install+add-ons +++++++++++++++++++++++++++ You will have to approve the updating one last time.
Was this helpful to you?
Quote

Question owner

Thank you for your detailed answer, i did already check the customize setting but the icon of adblock is not present sadly, i did reinstall again my firefox (even though it was a clear installation to begin with as i got my pc fixed some days ago) and i did manage to get addblock and another addon to show up in the top right bar and work, but after i turned on the pc again the day after it was back where i started. I redid another clean installation of firefox but still having this issue, do you think addblock is not supported anymore? Not sure what could cause this weird behaviour

Thank you for your detailed answer, i did already check the customize setting but the icon of adblock is not present sadly, i did reinstall again my firefox (even though it was a clear installation to begin with as i got my pc fixed some days ago) and i did manage to get addblock and another addon to show up in the top right bar and work, but after i turned on the pc again the day after it was back where i started. I redid another clean installation of firefox but still having this issue, do you think addblock is not supported anymore? Not sure what could cause this weird behaviour
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4385 solutions 61561 answers

Did you check out my second post?

Did you check out my second post?
Was this helpful to you?
Quote

Question owner

Yes ofcourse, but it didn't quite work out sadly

Yes ofcourse, but it didn't quite work out sadly
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17846 solutions 161524 answers
Did you try <u>Restore Defaults</u> in Customize mode ? *https://support.mozilla.org/en-US/kb/customize-firefox-controls-buttons-and-toolbars
Was this helpful to you?
Quote

Question owner

Yes i tried this as well but no luck so far

Yes i tried this as well but no luck so far
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17846 solutions 161524 answers

Try to uninstall adblock and close and restart Firefox and reinstall the extension or possibly try another ad-blocker.

Try to uninstall adblock and close and restart Firefox and reinstall the extension or possibly try another ad-blocker. *https://addons.mozilla.org/firefox/addon/ublock-origin/
Was this helpful to you?
Quote

Question owner

I tried but same result as adblock, the addon doesn't display the icon on the top right and i still see adds like it's not working

I tried but same result as adblock, the addon doesn't display the icon on the top right and i still see adds like it's not working
Was this helpful to you?
Quote

Question owner

I'll rebump to say that now firefox somehow manage to disinstall my plugin, i reinstalled a plugin yesterday to see if i would be able to fix the issue, and now the plugin is not found at all (still having the problem mentioned at the start)

I'll rebump to say that now firefox somehow manage to disinstall my plugin, i reinstalled a plugin yesterday to see if i would be able to fix the issue, and now the plugin is not found at all (still having the problem mentioned at the start)
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4385 solutions 61561 answers

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save '''Note:''' Some software, '''like''' Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.
Was this helpful to you?
Quote

Chosen Solution

Thank you very much for your help Fred and Cor-el. I noticed that if you do put in the option of firefox never remember history, this might be the cause of what might not let the addon work at all and be displayed in the top right bar, as silly at it may sounds, i'll do a quick restart to be sure of it, i'll edit this message if possible

Edit, indeed it was that option of firefox that caused the problem it seems

Thank you very much for your help Fred and Cor-el. I noticed that if you do put in the option of firefox never remember history, this might be the cause of what might not let the addon work at all and be displayed in the top right bar, as silly at it may sounds, i'll do a quick restart to be sure of it, i'll edit this message if possible Edit, indeed it was that option of firefox that caused the problem it seems

Modified by dddcod5

Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4385 solutions 61561 answers

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems.

That was very good work. Well Done. Please flag your last post as '''Solved Problem''' as this can help others with similar problems.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.