Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Problems with playing videos in Firefox. (Videos on twitter dont work. Missing options in youtube)

  • 4 replies
  • 4 have this problem
  • 24 views
  • Last reply by FRANC€$CO

more options

As the title says I cannot play any videos on Twitter and have problems when I try to play videos on other websites. I cannot get Firefox to play videos in 60fps anywhere. Youtube won't even give me the option. 60fps doesnt work on Twitch.tv either. Playing videos on Twitch on Firefox is a nightmare in general. Super slow and laggy.

Neither of the above problems are there for me on Chrome. Videos work properly and in 60fps on Chrome.

I have already tried disabling hardware acceleration and have tried running Firefox in safe mode. Neither option worked. I'm getting kinda sick and tired of having to switch over to Chrome every time I wanna watch a video. Some help would be greatly appreciated.

Attached screenshots

Chosen solution

Alright so I figured it out. Apparently Firefox didn't automatically enable all video codecs for some reason. God knows why. I had to go into the configuration screen (type about:config in the address bar without the quotation marks), then filter on media.me and set all the things that were set to 'false' to 'true'.

Read this answer in context 👍 0

All Replies (4)

more options
more options

cor-el said

Is there any more specific detail in the Web Console about playing media ?

There appears to be something there when I try to play a video on Twitter.

Cannot play media. No decoders for requested formats: application/x-mpegURL

On youtube I dont think it says anything about the media.

more options

Chosen Solution

Alright so I figured it out. Apparently Firefox didn't automatically enable all video codecs for some reason. God knows why. I had to go into the configuration screen (type about:config in the address bar without the quotation marks), then filter on media.me and set all the things that were set to 'false' to 'true'.

more options

slomesjakie said

Alright so I figured it out. Apparently Firefox didn't automatically enable all video codecs for some reason. God knows why. I had to go into the configuration screen (type about:config in the address bar without the quotation marks), then filter on media.me and set all the things that were set to 'false' to 'true'.

Hey man, I tried this way but still Twitter videos won't load. It's a bit annoying, have I did things as u explained? https://imgur.com/a/OpPQVE3