X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

Firefox browser moves me off the page I am on to another

Posted

I am a new apple user. I have the Catalina OS. Most current version. I have talked to apple...they tell me to use safari. I like firefox. Now, my issue. When I am on a web pags (this occurs randomly) I am bounced from the web page I am on to a previous web site I was on. I do nothing nor click on anything to cause this. It just happens. When I am on facebook, this will happen and bounce me off facebook and put me on a web page i had been on during the same session. This was not happening until I just got the latest Catalina update a week ago. I do not know how to fix this issue. Are there settings needing to be changed in the apple IOS? If so what are they? Is there something I can change in my facebook account? Is there something I can change in my Firefox browser account? Or should I just sit tight, grin and bare it until firefox makes changes via an update and fixes this issue. I am beginning to think, I should have stuck with my windows 10 system instead of moving to apple. I am just frustrated that I can not fix this issue. Any ideas out there? Thanks, Jim

I am a new apple user. I have the Catalina OS. Most current version. I have talked to apple...they tell me to use safari. I like firefox. Now, my issue. When I am on a web pags (this occurs randomly) I am bounced from the web page I am on to a previous web site I was on. I do nothing nor click on anything to cause this. It just happens. When I am on facebook, this will happen and bounce me off facebook and put me on a web page i had been on during the same session. This was not happening until I just got the latest Catalina update a week ago. I do not know how to fix this issue. Are there settings needing to be changed in the apple IOS? If so what are they? Is there something I can change in my facebook account? Is there something I can change in my Firefox browser account? Or should I just sit tight, grin and bare it until firefox makes changes via an update and fixes this issue. I am beginning to think, I should have stuck with my windows 10 system instead of moving to apple. I am just frustrated that I can not fix this issue. Any ideas out there? Thanks, Jim

Chosen solution

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

I am not smart enough to figure out plugins; I have some apps but not many.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:71.0) Gecko/20100101 Firefox/71.0

More Information

FredMcD
  • Top 10 Contributor
4392 solutions 61623 answers

Is this with all websites/pages, some, a few?

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Is this with all websites/pages, some, a few? [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
Was this helpful to you?
Quote

Question owner

This happens in facebook, as well as other web pages I am on. Just never know when...I am reading something and am bounced to another web page.

This happens in facebook, as well as other web pages I am on. Just never know when...I am reading something and am bounced to another web page.
Was this helpful to you?
Quote

Question owner

I did a refresh as suggested. I will see what happens tomorrow...my mind is mush right now. Thx for the suggestion.

I did a refresh as suggested. I will see what happens tomorrow...my mind is mush right now. Thx for the suggestion.
Was this helpful to you?
Quote

Question owner

FRED McD: Thank you for your suggestion...It appears to have worked. I was on Facebook for about an hour this AM...did not get bounced up...Much appreciated. Merry Christmas.

FRED McD: Thank you for your suggestion...It appears to have worked. I was on Facebook for about an hour this AM...did not get bounced up...Much appreciated. Merry Christmas.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4392 solutions 61623 answers

Chosen Solution

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

It could be the work of one of your add-ons, or it could be '''Hardware Acceleration. ''' ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link} Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Disable a few add-ons, then '''Restart Firefox. ''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All Of them. ''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.