X
Tap here to go to the mobile version of the site.

Support Forum

WebGL Very Slow - *ubuntu 18.04.3 LTS 64Bit Linux OS?

Posted

Hi,

WebGL on Mozilla Firefox is very slow compared to Google Chrome on same desktop?

Desktop specs: - Kubuntu 18.04.3 LTS 64Bit Linux OS - 500 Watt Power Supply - ASRock Q1900M Motherboard - Intel Celeron 2GHz 4-Core CPU - 16GB DDR3 RAM Memory - nVidia GeForce GTX 750 Ti 2GB GDDR5 GPU (Ubuntu nVidia proprietary display driver version 435.21)

Using the same WebGL demo, I get 10 Frames Per Second on Firefox and 45 Frames Per Second on Chrome? Any ideas what the issue is with WebGL and Ubuntu Firefox and how to fix it? Let me know, thanks!

Jesse

Hi, WebGL on Mozilla Firefox is very slow compared to Google Chrome on same desktop? Desktop specs: - Kubuntu 18.04.3 LTS 64Bit Linux OS - 500 Watt Power Supply - ASRock Q1900M Motherboard - Intel Celeron 2GHz 4-Core CPU - 16GB DDR3 RAM Memory - nVidia GeForce GTX 750 Ti 2GB GDDR5 GPU (Ubuntu nVidia proprietary display driver version 435.21) Using the same WebGL demo, I get 10 Frames Per Second on Firefox and 45 Frames Per Second on Chrome? Any ideas what the issue is with WebGL and Ubuntu Firefox and how to fix it? Let me know, thanks! Jesse
Attached screenshots
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:71.0) Gecko/20100101 Firefox/71.0

More Information

Dinushi Dhananjani
  • Top 25 Contributor
5 solutions 216 answers

Hi dr.... I think this will be help for you,


Firefox comes with hardware acceleration disabled on all Linux distributions

Pop open your browser, type about:config in the address bar, and hit enter/return.

Using the search box to find the layers. acceleration.force-enabled setting. Double-click on the

‘false’ listed under the ‘value’ column to set it to ‘true’.

Be sure to quit the browser completely before relaunching it.

Now, with layer acceleration turned,

carry on your web browsing as normal. 

Do things feel fractionally faster? Is switching between multiple tabs more fluid?

And 596544,1010527 bug https://bugzilla.mozilla.org/show_bug.cgi?id=596544 https://bugzilla.mozilla.org/show_bug.cgi?id=1010527

Hi dr.... I think this will be help for you, Firefox comes with hardware acceleration disabled on all Linux distributions Pop open your browser, type about:config in the address bar, and hit enter/return. Using the search box to find the layers. acceleration.force-enabled setting. Double-click on the ‘false’ listed under the ‘value’ column to set it to ‘true’. Be sure to quit the browser completely before relaunching it. Now, with layer acceleration turned, carry on your web browsing as normal. Do things feel fractionally faster? Is switching between multiple tabs more fluid? And 596544,1010527 bug https://bugzilla.mozilla.org/show_bug.cgi?id=596544 https://bugzilla.mozilla.org/show_bug.cgi?id=1010527
Was this helpful to you? 0
Quote

Question owner

Hi,

Thanks for the response. I tried above and no difference - WebGL still very slow on Ubuntu Firefox? Any other ideas? Thanks!

Jesse

Hi, Thanks for the response. I tried above and no difference - WebGL still very slow on Ubuntu Firefox? Any other ideas? Thanks! Jesse
Was this helpful to you?
Quote

Question owner

Still have above issue... Not sure how to proceed, let me know, thanks!

Jesse

Still have above issue... Not sure how to proceed, let me know, thanks! Jesse
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.