X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 70: Completely disable Enhanced Tracking Protection

Posted

I've selected Custom Enhanced Tracking Protection and deselect all the check-boxes. Still, the protection icon is displayed in the url-bar and on clicking it I see "Protection is on for this site". Any idea?

(I know I can hide the icon with CSS).

I've selected Custom Enhanced Tracking Protection and deselect all the check-boxes. Still, the protection icon is displayed in the url-bar and on clicking it I see "Protection is on for this site". Any idea? (I know I can hide the icon with CSS).
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:70.0) Gecko/20100101 Firefox/70.0

More Information

Wesley Branton
  • Top 10 Contributor
637 solutions 5218 answers

Helpful Reply

If you select the custom settings and uncheck all items, you've disabled Enhanced Tracking Protection. See Enhanced Tracking Protection in Firefox for desktop.

The shield icon will not be removed. If you wish to hide that icon, you will need to do so using CSS.

If you select the custom settings and uncheck all items, you've disabled Enhanced Tracking Protection. See [[Enhanced Tracking Protection in Firefox for desktop]]. The shield icon will not be removed. If you wish to hide that icon, you will need to do so using CSS.
Was this helpful to you? 2
Quote
jscher2000
  • Top 10 Contributor
8783 solutions 71835 answers

Helpful Reply

Hi Yaron, I think "Enhanced Tracking Protection is on for this site" simply means there is no site-specific exception that turns it off. But if all the different types of protection are individually disabled, then ETP isn't actually doing anything on the page. The drop-down would be providing information only.

Hi Yaron, I think "Enhanced Tracking Protection is on for this site" simply means there is no site-specific exception that turns it off. But if all the different types of protection are individually disabled, then ETP isn't actually doing anything on the page. The drop-down would be providing information only.
Was this helpful to you? 2
Quote

Question owner

Hello Wesley and jscher2000,

Thank you both for replying. I appreciate it.

Well, in previous versions the icon was not displayed. The current behavior is more than slightly confusing, isn't it?

Hello Wesley and jscher2000, Thank you both for replying. I appreciate it. Well, in previous versions the icon was not displayed. The current behavior is more than slightly confusing, isn't it?
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8783 solutions 71835 answers

I think the display in Firefox 69 was very variable. It would be gray if there was something that could be blocked, and it would flash purple if there was something that was blocked, and it would not appear at all on many sites. It will probably change again as the feature evolves...

I think the display in Firefox 69 was very variable. It would be gray if there was something that ''could'' be blocked, and it would flash purple if there was something that ''was'' blocked, and it would not appear at all on many sites. It will probably change again as the feature evolves...
Was this helpful to you? 2
Quote

Question owner

In FF 69 it would not appear at all if you disabled TP. IMO that makes more sense.

Anyway, thanks again.

In FF 69 it would not appear at all if you disabled TP. IMO that makes more sense. Anyway, thanks again.
Was this helpful to you?
Quote
anev942 2 solutions 9 answers

Yaron said

... (I know I can hide the icon with CSS).

Is there some where this is described, using CSS as mentioned?

''Yaron [[#question-1271340|said]]'' <blockquote> ... (I know I can hide the icon with CSS). </blockquote> Is there some where this is described, using CSS as mentioned?
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17567 solutions 158879 answers

In older Firefox version the shield icon was part on the identity container and you could click any of the buttons in this container. In Firefox 70 the Control Center 'i' icon has been removed (i.e. there is only the padlock) and the shield icon became a separate button with its own doorhanger showing only Tracking Protection related info. There is also a special about:protections page.


about:config

privacy.trackingprotection.enabled privacy.trackingprotection.pbmode.enabled privacy.trackingprotection.cryptomining.enabled privacy.trackingprotection.fingerprinting.enabled

In older Firefox version the shield icon was part on the identity container and you could click any of the buttons in this container. In Firefox 70 the Control Center 'i' icon has been removed (i.e. there is only the padlock) and the shield icon became a separate button with its own doorhanger showing only Tracking Protection related info. There is also a special about:protections page. *https://blog.mozilla.org/blog/2019/10/22/latest-firefox-brings-privacy-protections-front-and-center-letting-you-track-the-trackers/ ----- about:config privacy.trackingprotection.enabled privacy.trackingprotection.pbmode.enabled privacy.trackingprotection.cryptomining.enabled privacy.trackingprotection.fingerprinting.enabled

Modified by cor-el

Was this helpful to you? 1
Quote

Question owner

cor-el,

Thanks for the info.

https://bugzilla.mozilla.org/show_bug.cgi?id=1593857

anev942,

Create a folder named chrome in your profile folder.

Create a text file named userChrome.css and paste the following line there (without the quotes).

"#tracking-protection-icon-container { display: none !important; }"

Place the file in the chrome folder.

Type about:config in Firefox address bar and press Enter.

In the search field paste toolkit.legacyUserProfileCustomizations.stylesheets.

Double click it so it changes to true.

Restart FF.


Let me know if you need further help.

cor-el, Thanks for the info. https://bugzilla.mozilla.org/show_bug.cgi?id=1593857 anev942, Create a folder named chrome in your profile folder. Create a text file named userChrome.css and paste the following line there (without the quotes). "#tracking-protection-icon-container { display: none !important; }" Place the file in the chrome folder. Type about:config in Firefox address bar and press Enter. In the search field paste toolkit.legacyUserProfileCustomizations.stylesheets. Double click it so it changes to true. Restart FF. Let me know if you need further help.

Modified by Yaron

Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8783 solutions 71835 answers

If you want a hint about Content Blocking, you could make the icon accessible via a narrow strip at the edge and manipulate its color along the same lines as the icon.

/* Minimize Tracking Protection Icon to a Strip 
   Hover to access the button */

/* Reduce icon box to 8-pixel strip */
#tracking-protection-icon-container {
  max-width: 8px !important;
  min-width: 0 !important;
  border-right-width: 0 !important;
  /* Re-hiding: 1/4 sec. transition, 1/2 sec. delay */
  transition: all 250ms ease-in-out 500ms;
}
/* Hide the icon box contents */
#tracking-protection-icon-container box {
  max-width: 0 !important;
  min-width: 0 !important;
  /* Re-hiding: 1/4 sec. transition, 1/2 sec. delay */
  transition: max-width 250ms ease-in-out 500ms;
}

/* Set default strip background color  */
#tracking-protection-icon-container {
  background-color: #eee !important;
}
/* Light purple background when blocking (English only?) */
#tracking-protection-icon-container[aria-label^="Blocking"] {
  background-color: #dcf !important;
}

/* Show icon on hover (animated) */
#tracking-protection-icon-container:hover {
  max-width: 100px !important;
  background-color: transparent !important;
  border-right-width: 1px !important;
  transition: all 250ms ease-in-out 250ms;
}
/* Show contents */
#tracking-protection-icon-container:hover box {
  max-width: 100px !important;
  transition: max-width 250ms ease-in-out 250ms;
}

The coloring keys off of the word "Blocking" in the first position of the tooltip. If yours uses a different word, you'll need to edit the bolded term above.

If you want a hint about Content Blocking, you could make the icon accessible via a narrow strip at the edge and manipulate its color along the same lines as the icon. <center><img src="https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-11-20-16-24-03-ace079.png" width="450"></center> <pre>/* Minimize Tracking Protection Icon to a Strip Hover to access the button */ /* Reduce icon box to 8-pixel strip */ #tracking-protection-icon-container { max-width: 8px !important; min-width: 0 !important; border-right-width: 0 !important; /* Re-hiding: 1/4 sec. transition, 1/2 sec. delay */ transition: all 250ms ease-in-out 500ms; } /* Hide the icon box contents */ #tracking-protection-icon-container box { max-width: 0 !important; min-width: 0 !important; /* Re-hiding: 1/4 sec. transition, 1/2 sec. delay */ transition: max-width 250ms ease-in-out 500ms; } /* Set default strip background color */ #tracking-protection-icon-container { background-color: #eee !important; } /* Light purple background when blocking (English only?) */ #tracking-protection-icon-container[aria-label^='''"Blocking"'''] { background-color: #dcf !important; } /* Show icon on hover (animated) */ #tracking-protection-icon-container:hover { max-width: 100px !important; background-color: transparent !important; border-right-width: 1px !important; transition: all 250ms ease-in-out 250ms; } /* Show contents */ #tracking-protection-icon-container:hover box { max-width: 100px !important; transition: max-width 250ms ease-in-out 250ms; } </pre> The coloring keys off of the word "Blocking" in the first position of the tooltip. If yours uses a different word, you'll need to edit the bolded term above.
Was this helpful to you? 1
Quote

Question owner

Hello jscher2000,

That's indeed very nice. I appreciate it.

Hello jscher2000, That's indeed very nice. I appreciate it.
Was this helpful to you?
Quote
anev942 2 solutions 9 answers

Thanks Yaron Added the text to CSS file, about:config line already set to true. results, small unchanging space before url box, nice. Which can still be clicked on, all protections settings are default so it still works, I just don't have to see it or feel the need to interact with - which I don't. Doesn't address your original question but appreciate the response...

Thanks Yaron Added the text to CSS file, about:config line already set to true. results, small unchanging space before url box, nice. Which can still be clicked on, all protections settings are default so it still works, I just don't have to see it or feel the need to interact with - which I don't. Doesn't address your original question but appreciate the response...
Was this helpful to you?
Quote

Question owner

anev942,

You're welcome.

anev942, You're welcome.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.