Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox used all of my memory and CPU for some time when manually delete entries from browsing history sidebar

  • 7 replies
  • 1 has this problem
  • 40 views
  • Last reply by irapths

more options

Hello,

When I tried to manually delete lot of entries (>2000) from browsing history (sidebar->search->select all->R.click->delete) Firefox used all of my memory and CPU for more than 10 minutes. As a result there where lot of writings to swap file and my PC was freeze until I was able to terminate Firefox.

I tried to reproduce the behavior with smaller set and the same happen on all tries. As an example I selected ~300 pages in history sidebar and delete them. The memory usage (for the process that used the most) went from 250MB to 800MB and CPU usage to 100% for ~2.5 minutes. During this time Firefox was almost unusable and the PC very slow.

All tests, including the initial problem, performed as first task after Firefox complete its load and without any network/web traffic by me.

I don't have the fastest PC or lot of GB of memory, but what I have should be far from enough in order to delete some entries with any additional "re-configuration" on the back, without "melt" it. CPU: Intel Core 2 Duo 2.66GHz MEM: 4GB OS: Windows 7 (64 bit) Firefox: 69.0.3 (64-bit)

Do you think I have to report it a a bug?

All Replies (7)

more options

irapths said

Do you think I have to report it a a bug?

Hi irapths,

I think that you don't have to report it. This is a known bug. See for instance:

more options

I don't have a problem with deleting 1000 to 2000 pages at the same time. 500 to about thousand goes fairly quick, but deleting a lot more in one go takes a lot time. I delete such a small set of bookmarks and then continue with the next chunk. In the Library you can easily see how many bookmarks are selected.

more options

Hello cor-el and sorry for the really late reply.

I think my problem is more related to TyDraniu reply about the bug https://bugzilla.mozilla.org/show_bug.cgi?id=734643.

I didn't try to delete bookmarks, but history entries. Maybe the same algorithm is used, but I didn't try this. As I wrote for about 300 pages my PC was unusable for more than 2 minutes. Somewhere, I don't remember where, maybe in one of the bug reports, there is a workaround to this. De-select everything after the press of "delete", but didn't try either since I did my job during my replication tries.

more options

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

From the History menu, select Clear Recent History.

   If the menu bar is hidden, press Alt to make it visible.
   From the Time range to clear: drop-down menu,
select the desired range; to clear your entire cache, select Everything.
   Next to "Details", click the down arrow to

choose which elements of the history to clear; to clear your entire cache, select all items.

   Click Clear Now.
   Exit/quit all browser windows and re-open the browser.
more options

To reduce the amount of cached memory used in Firefox, go to about:memory and press "Minimize Memory Usage" button. To be honest with you 8GB of RAM is the minimum standard nowadays. Firefox makes sure people with more RAM can utilize them.

more options

Hello all and thank you for the answers.

I'm really sorry for the late reply.

@Dinushi Dhananjani My problem was to delete some filtered pages of the history , not everything or for a period.

@Senali Madawala Generally, I don't have problem with Firefox footprint.

As I wrote before, my problem is seems to be related to TyDraniu reply about the bug https://bugzilla.mozilla.org/show_bug.cgi?id=734643. It's not something I do often, so it is not a big problem. But now I will know next time... (the bug continues to be open).

Never the less, thank you for the effort to answer.