Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox on macOS 10.15 stops loading webpages

more options

Recently updated my 2012 MacBook Pro to macOS 10.15. After Firefox has been open for a while, it stops loading webpages. The title of the page loads, the browser window goes white and never displays anything; the page attempts to load continuously and navigation buttons don't respond. Other than that, Firefox operates and responds as though nothing's wrong. Meanwhile all other browsers can navigate the web just fine. Quitting Firefox (from the menu bar) causes the windows to close but an entry remains in "Force Quit" for an extended period. It can be forced closed from here, but doing so causes further attempts to open Firefox to have no windows appear; the only way to reopen Firefox appears to be to restart the whole computer. If allowed to close the rest of the way on its own- which can take up to 10 minutes- the crash dialog appears and Firefox can be restarted.

This has continued to happen despite repairing the drive, refreshing Firefox, removing and reinstalling Firefox, disabling hardware acceleration, running in safe mode, etc. There are no extensions installed and I have not synced my Firefox account.

All Replies (4)

more options

Thank you very much for your report Michael! Looks like you did some serious troubleshooting already & I appreciate your dedication & tenacity in getting Firefox to work normally again. :)

I'm going to try to search thru currently filed Mozilla bugs to see if a issue for this has already been filed. It seems very familiar.

I also wonder if you'd be willing to test Firefox Nightly? Sometimes the devs are so quick to fix these kinds of issues that it might already be resolved in the nightly builds. Download it from here: https://www.mozilla.org/en-US/firefox/channel/desktop/#nightly

If it's still busted there, we can always file a new bug for your issue to get a dev to investigate even more. And we can get much better results in a dev fixing it, if we can find the first build where this bug occurred for you. I'll dive into that later after you report back about your Nightly experience.

more options

Thanks, I'll give the nightly a try this evening. I was running a version of Firefox 68 when I updated my operating system. I then downloaded the latest beta (as of 10/14) to see if the issue was still present, and it was.

more options

Started using the Nightly. Left the browser open overnight, no issue loading pages this afternoon. I figured I'd try syncing my account. As soon as I did, the issue recurred.

I restarted my computer, then reopened the Nightly. My extensions synced to this profile, so I disabled all of them. I'm going to keep testing the browser, but as of now I have: -Latest Nightly (as of 15:48 CDT 10/18); -Firefox account sync ON; -Extensions manually disabled

more options

Still having problems. At this point, it's looking more like an issue of my computer's age finally catching up to it than anything else. I'll keep plucking this chicken but there may not be anything decisive I can do. Thanks for your help.