X
Tap here to go to the mobile version of the site.

Support Forum

URL can't be removed from address bar, site is not in history

Posted

I found many similar issues here and over the net, but none seem to work for my case.

I have this URL in my address bar suggestions, that is not in history. I used "Forget about this site" to remove it from history. I've also cleared my cached data from Privacy options (https://support.mozilla.org/en-US/kb/how-clear-firefox-cache)

I don't think killing "places.sqlite" will help, since it's not contained in `moz_places` table:


sqlite> SELECT * FROM moz_places WHERE url LIKE '%xkcd.org%';

sqlite>


So this website is actually a typo for xkcd.com web-comics.

I've tried https://support.mozilla.org/en-US/kb/remove-websites-address-bar-suggestions. This does not work since the suggestion is not on first page. I have to type in 'x' to see this wrong suggestion. Shitf-Delete does not work, since it only deletes the autocompleted string from suggested URL.

I use Mozilla account to sync, so maybe that may cause it -- other profile connected to account?

I found many similar issues here and over the net, but none seem to work for my case. I have this URL in my address bar suggestions, that is not in history. I used "Forget about this site" to remove it from history. I've also cleared my cached data from Privacy options (https://support.mozilla.org/en-US/kb/how-clear-firefox-cache) I don't think killing "places.sqlite" will help, since it's not contained in `moz_places` table: ------ sqlite> SELECT * FROM moz_places WHERE url LIKE '%xkcd.org%'; sqlite> ---- So this website is actually a typo for xkcd.com web-comics. I've tried https://support.mozilla.org/en-US/kb/remove-websites-address-bar-suggestions. This does not work since the suggestion is not on first page. I have to type in 'x' to see this wrong suggestion. Shitf-Delete does not work, since it only deletes the autocompleted string from suggested URL. I use Mozilla account to sync, so maybe that may cause it -- other profile connected to account?
Attached screenshots

Modified by ilvez

Chosen solution

Hi ilvez, I assume it's not caused by an erroneous bookmark.

Since you are familiar with SQLite browsing tools, would you mind checking another table -- this one stores frecency scores for top level host names:

SELECT * FROM 'moz_origins' WHERE host like '%xkcd%'

I'm not sure how a host name gets into that table if it doesn't load. ??

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:69.0) Gecko/20100101 Firefox/69.0

More Information

FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

That could be the form filler built into Firefox. Click in the field, enter a character or two and STOP ! Using the arrow keys, highlight an unwanted entry. Then press Delete (Mac=Shift Delete). Repeat as needed.

Do any of these links help you? https://support.mozilla.org/en-US/kb/control-whether-firefox-automatically-fills-forms

https://support.mozilla.org/en-US/search?w=1&q=autofill

That could be the form filler built into Firefox. Click in the field, enter a character or two and STOP ! Using the arrow keys, highlight an unwanted entry. Then press '''Delete ''(Mac=Shift Delete). ''''' Repeat as needed. Do any of these links help you? https://support.mozilla.org/en-US/kb/control-whether-firefox-automatically-fills-forms https://support.mozilla.org/en-US/search?w=1&q=autofill
Was this helpful to you? 0
Quote

Question owner

FredMcD said

That could be the form filler built into Firefox. Click in the field, enter a character or two and STOP ! Using the arrow keys, highlight an unwanted entry. Then press Delete (Mac=Shift Delete). Repeat as needed. Do any of these links help you? https://support.mozilla.org/en-US/kb/control-whether-firefox-automatically-fills-forms https://support.mozilla.org/en-US/search?w=1&q=autofill

I tried your solution, but it's not obviously it. It's address bar, not HTML form. When I use Delete in this case, it acts like delete -- deletes selected text (which is the leftover part of suggestion).

''FredMcD [[#answer-1253826|said]]'' <blockquote> That could be the form filler built into Firefox. Click in the field, enter a character or two and STOP ! Using the arrow keys, highlight an unwanted entry. Then press '''Delete ''(Mac=Shift Delete). ''''' Repeat as needed. Do any of these links help you? https://support.mozilla.org/en-US/kb/control-whether-firefox-automatically-fills-forms https://support.mozilla.org/en-US/search?w=1&q=autofill </blockquote> I tried your solution, but it's not obviously it. It's address bar, not HTML form. When I use Delete in this case, it acts like delete -- deletes selected text (which is the leftover part of suggestion).
Was this helpful to you?
Quote
the pc guy 0 solutions 2 answers

If you have a windows pc-

1) Click in the field, enter a character or two and STOP !

2)Using the arrow keys, highlight an unwanted entry (FredMcD was right until this point).

3) Then press SHIFT+ DELETE, not only the delete key.

4)Repeat as needed.

If you have a windows pc- 1) Click in the field, enter a character or two and STOP ! 2)Using the arrow keys, highlight an unwanted entry (FredMcD was right until this point). 3) Then press SHIFT+ DELETE, not only the delete key. 4)Repeat as needed.

Modified by the pc guy

Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8690 solutions 71037 answers

Chosen Solution

Hi ilvez, I assume it's not caused by an erroneous bookmark.

Since you are familiar with SQLite browsing tools, would you mind checking another table -- this one stores frecency scores for top level host names:

SELECT * FROM 'moz_origins' WHERE host like '%xkcd%'

I'm not sure how a host name gets into that table if it doesn't load. ??

Hi ilvez, I assume it's not caused by an erroneous bookmark. Since you are familiar with SQLite browsing tools, would you mind checking another table -- this one stores frecency scores for top level host names: SELECT * FROM 'moz_origins' WHERE host like '%xkcd%' I'm not sure how a host name gets into that table if it doesn't load. ??
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17470 solutions 157890 answers

What do you get if you disable auto-fill for the location bar via the about:config page?

  • browser.urlbar.autoFill = false
What do you get if you disable auto-fill for the location bar via the about:config page? *browser.urlbar.autoFill = false
Was this helpful to you?
Quote

Question owner

jscher2000 said

Hi ilvez, I assume it's not caused by an erroneous bookmark. Since you are familiar with SQLite browsing tools, would you mind checking another table -- this one stores frecency scores for top level host names: SELECT * FROM 'moz_origins' WHERE host like '%xkcd%' I'm not sure how a host name gets into that table if it doesn't load. ??

Yes. That was it. Thank you very much jscher2000. I should have taken deeper look into schema myself.

Commands that I launched (for whomever needs solution, do not blindly copypaste these, since you have to know your faulty entry ID before you launch `delete from` command): sqlite> select * from moz_origins where host like '%xkcd%'; 12|http://|xkcd.org|855789 429|https://|xkcd.com|138281 756|https://|www.xkcd.com|240 3928|https://|imgs.xkcd.com|100 4120|https://|blog.xkcd.com|200 sqlite> delete from moz_origins where id = 12;

''jscher2000 [[#answer-1253959|said]]'' <blockquote> Hi ilvez, I assume it's not caused by an erroneous bookmark. Since you are familiar with SQLite browsing tools, would you mind checking another table -- this one stores frecency scores for top level host names: SELECT * FROM 'moz_origins' WHERE host like '%xkcd%' I'm not sure how a host name gets into that table if it doesn't load. ?? </blockquote> Yes. That was it. Thank you very much jscher2000. I should have taken deeper look into schema myself. Commands that I launched (for whomever needs solution, do not blindly copypaste these, since you have to know your faulty entry ID before you launch `delete from` command): sqlite> select * from moz_origins where host like '%xkcd%'; 12|http://|xkcd.org|855789 429|https://|xkcd.com|138281 756|https://|www.xkcd.com|240 3928|https://|imgs.xkcd.com|100 4120|https://|blog.xkcd.com|200 sqlite> delete from moz_origins where id = 12;
Was this helpful to you?
Quote

Question owner

Thanks for all other suggestions as well. I didn't try them, since jscher2000 answer solved it for me.

Thanks for all other suggestions as well. I didn't try them, since jscher2000 answer solved it for me.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.