Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox sync won't save imported passwords, but will save passwords manually entered

  • 2 replies
  • 2 have this problem
  • 12 views
  • Last reply by mwp.main

more options

I exported my passwords from Chrome and used FFPass to import into Firefox.

The passwords are visible by inspecting:

Machine 1: Settings->Preferences->Privacy and Security->Saved Logins Machine 2: Settings->Logins and Passwords

But when I set-up my third machine and sync, everything gets installed correctly (bookmarks, tabs, preferences, etc) except logins. I don't see any logins; however, if I manually browse to a website, enter my login, Firefox will ask if I want to save. If I click yes, then that login is saved, but none of my imported logins are.

Can someone help? I have over 150+ logins... manually adding them one-by-one is not an option.

Machine 1: RHEL 7.7 / Firefox 60.8.0esr Machine 2: F29 / Firefox 68.0.2 Machine 3: F30 Firefox 68.0.2

Chosen solution

I resolved this issue with the following steps:

  • Browsing to: https://accounts.firefox.com/settings
  • Clicking on 'Show' for 'Devices and apps'
  • Clicking disconnect next to all devices
  • Clicking Done
  • Closing Firefox
  • Re-adding just the machine with the passwords

It immediately auto-synced all passwords and then I reconnected the other machines, they synced as well.

I guess maybe there were some hiccups between devices... I don't know.

Read this answer in context 👍 0

All Replies (2)

more options

It seems I have the same problem: on my desktop computer I still have all my logins and passwords, but on my laptop, everything syncs but the logins and paswword. It still saves new passwords and login too. Linuxmint 18.3, firefox 69.0

more options

Chosen Solution

I resolved this issue with the following steps:

  • Browsing to: https://accounts.firefox.com/settings
  • Clicking on 'Show' for 'Devices and apps'
  • Clicking disconnect next to all devices
  • Clicking Done
  • Closing Firefox
  • Re-adding just the machine with the passwords

It immediately auto-synced all passwords and then I reconnected the other machines, they synced as well.

I guess maybe there were some hiccups between devices... I don't know.