X
Tap here to go to the mobile version of the site.

Support Forum

Netflix doesn't work, no error messages, just the dark grey Netflix background.

Posted

All add-ons disabled

DRM enabled (re-checked box and restarted)

Widevine plugin up to date and always active

Firefox tells me: "Firefox is installing components needed to play the audio or video on this page". Waited for hours. Nothing happens.

Problem persists consistently through browser and system restarts.

Problem began 3 days ago.

All add-ons disabled DRM enabled (re-checked box and restarted) Widevine plugin up to date and always active Firefox tells me: "Firefox is installing components needed to play the audio or video on this page". Waited for hours. Nothing happens. Problem persists consistently through browser and system restarts. Problem began 3 days ago.

Chosen solution

At the end I did a clean re-install of firefox and any add-ons I had. It works fine now.

Read this answer in context 0
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

More Information

FredMcD
  • Top 10 Contributor
4274 solutions 59943 answers

The newest version disables the flash player. Check its settings.

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A

On the left side of the page, select Plugins.

The newest version disables the flash player. Check its settings. Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A''' On the left side of the page, select '''Plugins. '''
Was this helpful to you?
Quote

Question owner

I haven't had flash installed for ages. It's not in my plugins.

I haven't had flash installed for ages. It's not in my plugins.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4274 solutions 59943 answers
Then check out; https://support.mozilla.org/en-US/kb/fix-problems-images-not-show https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues https://support.mozilla.org/en-US/kb/html5-audio-and-video-firefox https://support.mozilla.org/en-US/kb/troubleshoot-issues-with-plugins-fix-problems https://support.mozilla.org/en-US/kb/warning-unresponsive-plugin
Was this helpful to you?
Quote
My_Cheese_Is_Slippin'
  • Top 10 Contributor
93 solutions 1024 answers

Hi Ornlu, Many people have posted about Amazon/Netflix/Widevine recently. Apparently, they have been bad bedfellows for over three years. This is not a new issue.

When you see the "Firefox is installing components needed to play the audio or video on this page" message you need to jump start that download from Google/Widevine by restarting Firefox and checking for updates to the plug-in.

Another method which seems to work, at least for a little while, is:

Type or paste about:support in the address bar Press Enter Under Application Basics Next to Profile Folder click the Open Folder button Close Firefox

In your Profile Folder find the folder gmp-widevinecdm Delete the folder

Start Firefox A new WidevineDRM module will install Go to Add-ons/Plugins and Check For Updates

Hi Ornlu, Many people have posted about Amazon/Netflix/Widevine recently. Apparently, they have been bad bedfellows for over three years. This is not a new issue. When you see the "Firefox is installing components needed to play the audio or video on this page" message you need to jump start that download from Google/Widevine by restarting Firefox and checking for updates to the plug-in. Another method which seems to work, at least for a little while, is: Type or paste about:support in the address bar Press Enter Under Application Basics Next to Profile Folder click the Open Folder button Close Firefox In your Profile Folder find the folder gmp-widevinecdm Delete the folder Start Firefox A new WidevineDRM module will install Go to Add-ons/Plugins and Check For Updates
Was this helpful to you?
Quote

Question owner

Thank you, I've tried all the above fixes, however none worked.

Thank you, I've tried all the above fixes, however none worked.
Was this helpful to you?
Quote

Chosen Solution

At the end I did a clean re-install of firefox and any add-ons I had. It works fine now.

At the end I did a clean re-install of firefox and any add-ons I had. It works fine now.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4274 solutions 59943 answers

That was very good work. Well done.

That was very good work. Well done.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.