X
Tap here to go to the mobile version of the site.

Support Forum

How do I stop Firefox from auto adding websites to Bookmarks even if that page isn't open?

Posted

I have 6 websites that automatically add the sites to my bookmarks, even when I am not on the site. I went there once and somehow they are populating my bookmarks with 100s of each site. Also, my folders are being duplicated. The attached image shows a sample of my bookmarks. When I set my mouse on the down arrow to scroll to the end, it takes 115 seconds to roll to the end at about 3 seconds per 40-line page scrolled. Current rough estimate is over 1600 bookmark/folder items. I went thru the editing 2 weeks ago, removing all unwanted bookmarks & folders.

I have 6 websites that automatically add the sites to my bookmarks, even when I am not on the site. I went there once and somehow they are populating my bookmarks with 100s of each site. Also, my folders are being duplicated. The attached image shows a sample of my bookmarks. When I set my mouse on the down arrow to scroll to the end, it takes 115 seconds to roll to the end at about 3 seconds per 40-line page scrolled. Current rough estimate is over 1600 bookmark/folder items. I went thru the editing 2 weeks ago, removing all unwanted bookmarks & folders.
Attached screenshots

Chosen solution

Firstly, this is not normal behaviour. There are a few reasons I can think of that could cause this to happen:

The most likely answer is that your computer is infected with malware. The best course of action is to scan your computer (there are some great free scanners in the linked article). They can usually fix the issue on their own.

Another likely answer could be that you have an illegitimate add-on installed on Firefox, which is adding bookmarks. Running in Safe Mode will help to determine whether or not this is the issue. You can also check the permission tab of each add-on on the about:addons page to see which ones have permissions to access your bookmarks.

NOTE: There are tons of legitimate reasons why a add-on would need permission to access your bookmarks. Just because an add-on has that permission, does not mean it's automatically the culprit. The best way to test is to disable the add-on for a while and see if the issue goes away.

Finally, the issue could be caused if you are visiting a website and it's using some code to simulate the keyboard shortcut for adding a bookmark. This is less likely than the other two causes, but it's still technically possible. If you find that the issue happens only after you have visited a certain website, avoid it. Websites that exhibit this behaviour are usually untrustworthy and could lead to other issues.

Hope this helps.

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

More Information

Wesley Branton
  • Top 10 Contributor
594 solutions 5017 answers

Chosen Solution

Firstly, this is not normal behaviour. There are a few reasons I can think of that could cause this to happen:

The most likely answer is that your computer is infected with malware. The best course of action is to scan your computer (there are some great free scanners in the linked article). They can usually fix the issue on their own.

Another likely answer could be that you have an illegitimate add-on installed on Firefox, which is adding bookmarks. Running in Safe Mode will help to determine whether or not this is the issue. You can also check the permission tab of each add-on on the about:addons page to see which ones have permissions to access your bookmarks.

NOTE: There are tons of legitimate reasons why a add-on would need permission to access your bookmarks. Just because an add-on has that permission, does not mean it's automatically the culprit. The best way to test is to disable the add-on for a while and see if the issue goes away.

Finally, the issue could be caused if you are visiting a website and it's using some code to simulate the keyboard shortcut for adding a bookmark. This is less likely than the other two causes, but it's still technically possible. If you find that the issue happens only after you have visited a certain website, avoid it. Websites that exhibit this behaviour are usually untrustworthy and could lead to other issues.

Hope this helps.

Firstly, this is not normal behaviour. There are a few reasons I can think of that could cause this to happen: The most likely answer is that your computer is [[Troubleshoot Firefox issues caused by malware|infected with malware]]. The best course of action is to scan your computer (there are some great free scanners in the linked article). They can usually fix the issue on their own. Another likely answer could be that you have an illegitimate add-on installed on Firefox, which is adding bookmarks. [[Troubleshoot Firefox issues using Safe Mode|Running in Safe Mode]] will help to determine whether or not this is the issue. You can also check the permission tab of each add-on on the <code>about:addons</code> page to see which ones have permissions to access your bookmarks. <blockquote>'''NOTE:''' There are tons of legitimate reasons why a add-on would need permission to access your bookmarks. Just because an add-on has that permission, does not mean it's automatically the culprit. The best way to test is to disable the add-on for a while and see if the issue goes away.</blockquote> Finally, the issue could be caused if you are visiting a website and it's using some code to simulate the keyboard shortcut for adding a bookmark. This is less likely than the other two causes, but it's still technically possible. If you find that the issue happens only after you have visited a certain website, avoid it. Websites that exhibit this behaviour are usually untrustworthy and could lead to other issues. Hope this helps.
Was this helpful to you?
Quote

Question owner

This was helpful and I will be working on your suggestions and let you know about my success/failure. Thanks for the suggestions.

This was helpful and I will be working on your suggestions and let you know about my success/failure. Thanks for the suggestions.
Was this helpful to you?
Quote

Question owner

I took your advise and went one step further. I believe it was my add-ons that caused the problem but I went nuclear.

I backed up the bookmarks and removed all aspects of Firefox. Rebooted and installed the latest version then imported my backed up bookmarks. I then edited bookmarks to take out unwanted bookmarks. I have don't have the same on my laptop and when I get time, I'll delete all my laptop bookmarks and turn on synchronizing bookmarks.

Thanks again for your help.

I took your advise and went one step further. I believe it was my add-ons that caused the problem but I went nuclear. I backed up the bookmarks and removed all aspects of Firefox. Rebooted and installed the latest version then imported my backed up bookmarks. I then edited bookmarks to take out unwanted bookmarks. I have don't have the same on my laptop and when I get time, I'll delete all my laptop bookmarks and turn on synchronizing bookmarks. Thanks again for your help.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17477 solutions 157949 answers

Are you using Sync to sync the bookmarks with a mobile device as this is usually the main cause of such an issue?

If you use Sync then best is to disconnect Sync temporarily during troubleshooting.

You can check for problems with the places.sqlite and favicons.sqlite files in the Firefox profile folder.

  • use "Verify Integrity" button on the "Help -> Troubleshooting Information" (about:support) page

In case errors are reported with "Verify Integrity" close and restart Firefox and retry.

If "Verify Integrity" cannot repair places.sqlite, rename/remove all places.sqlite and favicons.sqlite files in the Firefox profile folder. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder.

  • keep a backup copy of places.sqlite in case a new places.sqlite database has to be created

See also:

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Are you using Sync to sync the bookmarks with a mobile device as this is usually the main cause of such an issue? If you use Sync then best is to disconnect Sync temporarily during troubleshooting. You can check for problems with the <b>places.sqlite</b> and <b>favicons.sqlite</b> files in the Firefox profile folder. *use "Verify Integrity" button on the "Help -> Troubleshooting Information" (about:support) page In case errors are reported with "Verify Integrity" close and restart Firefox and retry. If "Verify Integrity" cannot repair places.sqlite, rename/remove all <b>places.sqlite</b> and <b>favicons.sqlite</b> files in the Firefox profile folder. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder. *keep a backup copy of places.sqlite in case a new places.sqlite database has to be created See also: *https://support.mozilla.org/en-US/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file *https://support.mozilla.org/en-US/kb/fix-bookmarks-and-history-will-not-be-functional You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.