Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

why can't i no longer drag and drop urls to my desktop!

  • 43 replies
  • 3 have this problem
  • 4960 views
  • Last reply by cor-el

more options

If I use Chrome I can drag and drop but NOT FIREFOX QUANTUM!

Chosen solution

hi, this can happen when particular settings are in place in your windows environment - please see this article for an explanation and workarounds: Drag and Drop errors with Firefox Launcher Process enabled and Windows UAC disabled - How to Fix

Read this answer in context 👍 1

All Replies (20)

more options

Chosen Solution

hi, this can happen when particular settings are in place in your windows environment - please see this article for an explanation and workarounds: Drag and Drop errors with Firefox Launcher Process enabled and Windows UAC disabled - How to Fix

more options

Solved my problem...thank you!

more options

philipp said

hi, this can happen when particular settings are in place in your windows environment - please see this article for an explanation and workarounds: Drag and Drop errors with Firefox Launcher Process enabled and Windows UAC disabled - How to Fix

Yes, thanks a million. Option 1 - re-enable UAC - worked like a charm. I had to restart my computer first, though.

more options

rreply said

philipp said
hi, this can happen when particular settings are in place in your windows environment - please see this article for an explanation and workarounds: Drag and Drop errors with Firefox Launcher Process enabled and Windows UAC disabled - How to Fix

Yes, thanks a million. Option 1 - re-enable UAC - worked like a charm. I had to restart my computer first, though.

It turns out that changing the permissions in UAC now prevents Acrobat Distiller from working properly, i.e., I cannot print to Adobe. I had to restore the previous UAC setting in order to restore functionality to Acrobat Distiller. Now, once again, Firefox drag and drop to the desktop no longer functions. I'll try to find a non-UAC workaround. Any suggestions?

more options

Hello, I tried to run firefox with no-deelevate option but do not solve. from cmd : C:\Program Files\Mozilla Firefox>firefox -no-deelevate Firefox is open and about:support tell me Launcher Process is still Enabled... in about:config there is this line: browser.launcherProcess.enabled;false Any Idea ? Is the UAC the last choice? thanks all . Roby

Modified by roby198

more options

Hi Roby, I tried -no-deelevate with no success either. Changing the UAC permissions level worked, but then Acrobat XI Distiller wouldn't work. I sure hope Firefox comes up with a patch or workaround that doesn't require changing the UAC level. Copying and pasting URLs and descriptions to the desktop works but is a real inconvenience. Rob

Modified by rreply

more options

Try to reinstall Acrobat XI Distiller and Firefox as a normal user and not as administrator if that is what you are doing. It shouldn't be necessary to run such user programs as administrator and this is unsafe in most cases, especially for an internet browser.

more options

Got it working!

more options

i hope for a Firefox patch to enable this simple action to save a link dragging and drop an URL . Don't know if this is in charge to Firefox support contribution... do someone know it?

more options

Hi roby198, are you not able to re-enable UAC on your system?

For the second workaround -- forcing Firefox to run with full user privileges -- try modifying your Firefox shortcut. Either:

  • Right-click a Firefox desktop shortcut, then click Properties
  • Right-click a Firefox icon pinned to the Taskbar then right-click Mozilla Firefox, then click Properties

Windows should show the Shortcut tab and select the Target field. The Target usually is along the following lines:

  • "C:\Program Files\Mozilla Firefox\firefox.exe"
  • "C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

You would add a space and then the new switch, either:

  • "C:\Program Files\Mozilla Firefox\firefox.exe" -no-deelevate
  • "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -no-deelevate

Success?

more options

Also, I'm not sure what you are usually dragging and dropping, but for images, you can use:

  • in Firefox: right-click > Copy Image
  • in Windows: right-click > Paste
more options

I can no longer drag and drop a URL on desktop to create a shortcut with my default Firefox browser, IE works OK. I have spent hours trying the various fixes (changing UAC Setting, Refresh Browser, etc, etc,...). I do prefer Firefox over IE, but I just don't have the time nor the patience continue. it just should not be that hard and time consuming.

more options

Hi Opahujo, refreshing Firefox will not help. If Windows shows you the "prohibited" icon on the file as you are dragging, then it is a problem with privileges.

To recap:

If you are logged into Windows as a user with administrative privileges, then Firefox will start with reduced (standard user / medium integrity) privileges to help protect against zero day vulnerabilities.

If UAC is enabled normally, you should be able to drag-and-drop to the desktop or other folders/applications. Note that you do have to shut down and restart Windows after changing UAC levels before that change takes effect.

If that doesn't work, there is a command-line option to keep running Firefox with the usual high level of privileges (administrator / high integrity). If you look at the post two above yours, the steps are there: https://support.mozilla.org/questions/1264413#answer-1239116

More info: Drag and Drop errors with Firefox Launcher Process enabled and Windows UAC disabled - How to Fix.

Modified by jscher2000

more options

I have tried all the different UAC Settings already . Now in the one shown in the image. Is that the preferred one?

more options

yes, this screenshot shows the recommend default state - changing the setting might also require a reboot of the system to take effect.

more options

Dear contributors, I asked my IT guy about Philipp's reply on 7/16/19, 6:57 AM, and he wrote me the following:

His suggestion isn’t really something we can do as your account is the administrator so we’d have to create a whole new account and redo all of your settings, Outlook, etc.

You can roll back to the previous Firefox, or wait for a patch, or the option I would recommend is to try out Opera. It has built in mouse gestures (really useful for navigation) and an ad blocker that work really well, and is by far the most usable browser in my opinion.

Let me know which option you want to go with and I’ll get it taken care of!

Best regards, Rob in Austin

more options

rreply said

I asked my IT guy about Philipp's reply on 7/16/19, 6:57 AM, and he wrote me the following:

His suggestion isn’t really something we can do as your account is the administrator so we’d have to create a whole new account and redo all of your settings, Outlook, etc.

I'm pretty sure the Administrator account can run with the default UAC setting. ???

Did you try modifying the command line of your Firefox shortcut:

  • Right-click a Firefox desktop shortcut, then click Properties
  • Right-click a Firefox icon pinned to the Taskbar then right-click Mozilla Firefox, then click Properties

Windows should show the Shortcut tab and select the Target field. The Target usually is along the following lines:

  • "C:\Program Files\Mozilla Firefox\firefox.exe"
  • "C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

You would add a space and then the new switch, either:

  • "C:\Program Files\Mozilla Firefox\firefox.exe" -no-deelevate
  • "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -no-deelevate

Success?

more options

Thank you, thank you, JScher! Success indeed! Thank you for giving me such a clear roadmap. With much appreciation, Rob in Austin P.S. I'll let my IT guy know.

more options

]

Hi roby198, are you not able to re-enable UAC on your system? For the second workaround -- forcing Firefox to run with full user privileges -- try modifying your Firefox shortcut. Either:
  • Right-click a Firefox desktop shortcut, then click Properties
  • Right-click a Firefox icon pinned to the Taskbar then right-click Mozilla Firefox, then click Properties
Windows should show the Shortcut tab and select the Target field. The Target usually is along the following lines:
  • "C:\Program Files\Mozilla Firefox\firefox.exe"
  • "C:\Program Files (x86)\Mozilla Firefox\firefox.exe"
You would add a space and then the new switch, either:
  • "C:\Program Files\Mozilla Firefox\firefox.exe" -no-deelevate
  • "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -no-deelevate
Success?

Hi JScher , I test with success enabling the UAC but no success passing the option "C:\Program Files\Mozilla Firefox\firefox.exe" -no-deelevate both for 32 and 64 firefox . FF start but problem still remain . Syntax is correct but no differences. thanks Roby

Modified by roby198

more options

roby198 said

Hi JScher , I test with success enabling the UAC but no success passing the option "C:\Program Files\Mozilla Firefox\firefox.exe" -no-deelevate both for 32 and 64 firefox . FF start but problem still remain . Syntax is correct but no differences. thanks Roby

Hi Roby, I don't think I can test it myself because I have the default setting for UAC.

  1. 1
  2. 2
  3. 3