X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

"firefox prevented this page from automatically redirecting to another page" per site exceptions

Posted

Hi all,

I realise I can disable the Automatically Redirecting/Refreshing globally, which is the default setting that I wish to have. However I have a number of sites that I use on an almost daily use where I want to have exceptions and allow redirecting/refreshing.

Is it possible to have per site exceptions? Even if through an addon?

Thanks

Hi all, I realise I can disable the Automatically Redirecting/Refreshing globally, which is the default setting that I wish to have. However I have a number of sites that I use on an almost daily use where I want to have exceptions and allow redirecting/refreshing. Is it possible to have per site exceptions? Even if through an addon? Thanks

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17857 solutions 161589 answers

Helpful Reply

It is not possible to set an exception.

This is meant as an accessibility feature and not as a way to prevent redirecting as a security feature, so this is all or nothing. It also does only work in a few cases and not in other cases and that is why this setting is no longer available in the user interface, but has to be modified directly on the about:config page.

It is not possible to set an exception. This is meant as an accessibility feature and not as a way to prevent redirecting as a security feature, so this is all or nothing. It also does only work in a few cases and not in other cases and that is why this setting is no longer available in the user interface, but has to be modified directly on the <b>about:config</b> page.
Joelee42 0 solutions 4 answers

Which setting to change?

Which setting to change?
McCoy
  • Top 10 Contributor
628 solutions 6017 answers

Helpful Reply

Joelee42 said

Which setting to change?

Hello Joelee42,

Type in the address bar about:config (press Enter) (promise to be careful, if asked)

Type in the search bar and look for the preference :

accessibility.blockautorefresh :

its value needs to be set to false to turn it OFF

its value needs to be set to true to turn it ON

(after a value has been changed : close and restart Firefox)

''Joelee42 [[#answer-1245178|said]]'' <blockquote> Which setting to change? </blockquote> Hello Joelee42, Type in the address bar '''about:config''' (press Enter) (promise to be careful, if asked) Type in the search bar and look for the preference : '''accessibility.blockautorefresh''' : its value needs to be set to '''false''' to turn it OFF its value needs to be set to '''true''' to turn it ON (after a value has been changed : close and restart Firefox)
Joelee42 0 solutions 4 answers

Thank you

Thank you
Doug 0 solutions 1 answers

2 years ago I left Firefox for Google because I could not figure out how to disable this option! Now I can go back Firefox being my default browser. I dislike Google Chrome. The only thing worse is Edge. Microsoft ruined it in their typical behavior of trying to hijack everything you do.

2 years ago I left Firefox for Google because I could not figure out how to disable this option! Now I can go back Firefox being my default browser. I dislike Google Chrome. The only thing worse is Edge. Microsoft ruined it in their typical behavior of trying to hijack everything you do.