Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

how to disable keyboard shortcuts using user profiles in firefox

  • 8 replies
  • 2 have this problem
  • 20 views
  • Last reply by s_aditham

more options

I would like to disable the keyborad short cuts using the profile (user.js) . Eg: Ctrl+f,Ctrl+d etc all the keyboard short cuts Should be disabled...

Similat to the below example..

Eg: user_pref("browser.tabs.autoHide", true); user_pref("browser.tabs.forceHide", false); user_pref("browser.tabs.warnOnClose", false);

All Replies (8)

more options

Hi RanShop, Firefox only has preferences for a tiny number of keyboard shortcuts, such as caret browsing (accessibility.browsewithcaret_shortcut.enabled => false prevents F7 from toggling this feature).

Why do you want to disable all the keyboard shortcuts?

more options

jscher2000 said

Hi RanShop, Firefox only has preferences for a tiny number of keyboard shortcuts, such as caret browsing (accessibility.browsewithcaret_shortcut.enabled => false prevents F7 from toggling this feature). Why do you want to disable all the keyboard shortcuts?

Hi jscher2000, thanks for your quick reply. we are displaying the video streaming on the browser where we should not perform any operations other than specified with the buttons on the broeser. So that is the reason need to disable the keyboard short cuts like ctrl+F, Ctrl+D, functional keys and etc...

Thanks in advance.

more options

Hi RanShop, do you control the web page containing the media player? Web pages can intercept and cancel many keyboard shortcuts. You can see an example here:

https://www.jeffersonscher.com/res/keyvents.html

If you don't control the page but you can install an add-on, the add-on can inject a script into the page to modify keyboard shortcuts. For example:

https://addons.mozilla.org/firefox/addon/shortkeys/

more options

I have same issue. I am bringing up a Linux VM in a Firefox browser and trying to use emacs editor for editing. However emacs keys like ctrl+n are getting redirected to open a new browser window. I really do not use keyboard shortcuts for anything in browsers. But important that I be able to confidently edit files (do not want to relearn a new editor now, even vim has same issue).

I am using Windows 10 platform and latest Firefox (v69)

Thanks Shiva

more options

Hi Shiva, I am not familiar with how a Linux VM works in a Firefox tab. Is it a web app? Do they have a support site with information on browser compatibility?

more options

Thanks very much.

I am using VMware ESXi 6.7 and login via web client. Then I select my VM and launch a web console. That is where I do the editing. It appears the VM itself has no compatibility issue as far as I can tell. However when I open an emacs window and say do ctrl+n to go one line down, it opens a new browser window. (by the fyi, it appears Chrome does the same). Hence my desire to disable all key shortcuts.

Going by another reply you gave it looks like Firefox has no in-built mechanism to do this. Rather unfortunate. I downloaded extensions shortkeys and saka and installed. But I do not even know how to invoke them (they are enabled when I look at add-ons tab) and do not see them on my toolbar (unlike Lastpass which is visible and configurable).

Thanks, Shiva

more options

Hi Shiva, keys are assigned through the undersized Options panel for the extension on the Add-ons page. Click its tile, then click Options.

However, judging from my test page, the keydown and keypress events for Ctrl+n are not detected by content scripts, so the method used by Shortkeys can't work with Ctrl+n.

Unfortunately, it seems like a dead end for this one.

more options

thanks again for looking into it. Rather unfortunate. However I am able to download VmWare remote console (laptop based) and use it without these issues. So I am OK. But I hope browser vendors do consider a way to enable/disable them though.

Regards Shiva