X
Tap here to go to the mobile version of the site.

Support Forum

Unable to open one particular website only in firefox

Posted

Link : https://login.gazt.gov.sa/irj/portal?ume.logon.locale=en&login=X

 This above webpage just blinks and then landing on a blank white page. This happens only in firefox for this particular webpage. I tried in Firefox Nightly, firefox in mobile, all older versions of firefox too but still the same result.

Troubleshooting tried so far are below - Tried firefox safe mode, disabled addons, refreshed firefox - Tried in different internet connections, created another profile in firefox - Tried disabling hardware acceleration Nothing is working so far. Can someone assist in this. Thanks Ahamz

Link : https://login.gazt.gov.sa/irj/portal?ume.logon.locale=en&login=X This above webpage just blinks and then landing on a blank white page. This happens only in firefox for this particular webpage. I tried in Firefox Nightly, firefox in mobile, all older versions of firefox too but still the same result. Troubleshooting tried so far are below - Tried firefox safe mode, disabled addons, refreshed firefox - Tried in different internet connections, created another profile in firefox - Tried disabling hardware acceleration Nothing is working so far. Can someone assist in this. Thanks Ahamz

Chosen solution

I disabled Javascript on the "about:config" page, and : Yay  ! Page loads .....

(re-enabling Javascript now)

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:68.0) Gecko/20100101 Firefox/68.0

More Information

McCoy
  • Top 10 Contributor
464 solutions 4227 answers

Hello regahamz,

The same thing happens when I try, but not just in Firefox - in Edge as well.

Would you try to login using this link :

https://www.gazt.gov.sa/en

Clicking the login button on the left results in the same blank page - try the "login" button at the upper right.

Any luck  ?

Hello regahamz, The same thing happens when I try, but not just in Firefox - in Edge as well. Would you try to login using this link : https://www.gazt.gov.sa/en Clicking the login button on the left results in the same blank page - try the "login" button at the upper right. Any luck ?

Modified by McCoy

Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
464 solutions 4227 answers

McCoy said

Clicking the login button on the left results in the same blank page - try the "login" button at the upper right.

I should have tried it before suggesting it, cause that button does the same : leads to a blank page in both Firefox and Edge.

Unless somebody else comes up with a solution, maybe you could contact them :

https://www.gazt.gov.sa/en/contact-us

''McCoy [[#answer-1222485|said]]'' <blockquote> Clicking the login button on the left results in the same blank page - try the "login" button at the upper right. </blockquote> I should have tried it before suggesting it, cause that button does the same : leads to a blank page in both Firefox and Edge. Unless somebody else comes up with a solution, maybe you could contact them : https://www.gazt.gov.sa/en/contact-us
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8502 solutions 69433 answers

Helpful Reply

There is a script in the page hiding the entire document body. Maybe it intends to unhide it based on certain circumstances, I didn't look into it that far. First screenshot is what happens when scripts from the site are enabled. (Some other scripts are disabled.) Second screenshot is what happens when all scripts are disabled.

Note: I use NoScript, but I am not recommending it as a workaround because disabling scripts may break this and other sites in numerous ways that are not apparent without deep knowledge of how they work.

There is a script in the page hiding the entire document body. Maybe it intends to unhide it based on certain circumstances, I didn't look into it that far. First screenshot is what happens when scripts from the site are enabled. (Some other scripts are disabled.) Second screenshot is what happens when all scripts are disabled. Note: I use NoScript, but I am not recommending it as a workaround because disabling scripts may break this and other sites in numerous ways that are not apparent without deep knowledge of how they work.
Was this helpful to you? 1
Quote
McCoy
  • Top 10 Contributor
464 solutions 4227 answers

Chosen Solution

I disabled Javascript on the "about:config" page, and : Yay  ! Page loads .....

(re-enabling Javascript now)

I disabled Javascript on the "about:config" page, and : Yay ! Page loads ..... (re-enabling Javascript now)
Was this helpful to you? 1
Quote

Question owner

McCoy said

I disabled Javascript on the "about:config" page, and : Yay  ! Page loads ..... (re-enabling Javascript now)

Yep... This works.. Thanks....

''McCoy [[#answer-1222561|said]]'' <blockquote> I disabled Javascript on the "about:config" page, and : Yay ! Page loads ..... (re-enabling Javascript now) </blockquote> Yep... This works.. Thanks....
Was this helpful to you?
Quote

Question owner

Thanks for the insight

Thanks for the insight
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
464 solutions 4227 answers

regahamz said

Yep... This works.. Thanks....

My pleasure  ! I didn't even have to tell you how to get on the "about:config" page and what to do there - well done  !

''regahamz [[#answer-1222690|said]]'' <blockquote> Yep... This works.. Thanks.... </blockquote> My pleasure ! I didn't even have to tell you how to get on the "about:config" page and what to do there - well done !
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
464 solutions 4227 answers

This may be a redundant remark, but please re-enable JavaScript after you're done on that particular site - you'll need JavaScript enabled on other sites.

This may be a redundant remark, but please re-enable JavaScript after you're done on that particular site - you'll need JavaScript enabled on other sites.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17267 solutions 156055 answers

The body has a display:none property if i check this in the Inspector. If I remove the tick on the property then the page content appears.

The body has a display:none property if i check this in the Inspector. If I remove the tick on the property then the page content appears. *"3-bar" menu button or Tools -> Web Developer *https://developer.mozilla.org/en-US/Tools/Page_Inspector

Modified by cor-el

Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.