Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox not loading previous session on start - pages not loading.

  • 9 replies
  • 2 have this problem
  • Last reply by teeny_weeny

more options

Sorry folks. This has only recently happened, and I am still not 100% sure what the problem is. (Skip to bottom part for recent event)

Ubuntu 18.04 as far as I know up to date with updates. 2019 04 24.

Originally I would load FF and "restore previous session".

The sessions would load - granted slowly, but they would load.

Beyond that, nothing has changed, other than now when I load FF, it just sits there.

It won't start loading pages.

How I make it load pages is click a couple of other tabs and try to invoke them to load.

After a while it finally starts loading.

Using another browser, though not restoring a previous session, the "blank page" loads and I can go to pages and they load there and then.

I really don't want to lose all the tabs.

The plugins have been installed before the problem happened.

Last thing: (Probably nothing, but I want to declare it here now as this is about the time this problem started happening.) I am about to connect to a new type of service being rolled out here. NBN. That means new modem and connection style.

I bought a new modem. Linksys 1900 ACS.

My network is STATIC IP - mostly.

I wanted to ste up the new modem before the "cut over" so it can go smoother. As I didn't know the IP address, I changed/edited the OS network type. From Fixed IP to DHCP.

Rebooted and loaded another browser (only to keep the old session in FF) and set up the modem. All done. Reset the IP settings and all back to normal.

Loaded FF as per normal. The problem then manifested itself.

But as said: Other browsers load and I can surf there and then. Load FF and it just "stalls" loading any page. I can't open a new tab, or much else for a while.

Chosen solution

Seems it is/was ghostery.

Disabling it and FF loads perfectly.

Sorry for wasting everyone's time.

I shall try to work out how to report it.

Read this answer in context 👍 0

All Replies (9)

more options

Hi there. Let's start with the easy thing first:

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Make sure your options are set to load the last session.

more options


Silly me.

It seems to load ok with all addons disabled.

So, I then loaded FF as normal. Just to prove the point.

While it was running/loading/starting (and hanging) I see this in the CLI

me@me-desktop:~$ firefox

      1. !!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost

[Child 2996, MediaPlayback #3] WARNING: Decoder=7f29af6f5000 Decode error: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - RefPtr<mozilla::mozpromise<refptr&lt;mozilla::mediatrackdemuxer::samplesholder&gt;, #2]="" #4]="" &gt;="" (0x806e0005)="" -="" 2996,="" 3331="" <="" [child="" build="" decode="" decoder="7f29af6f5000" detached.:="" dom="" error:="" file="" firefox-66.0.3+build1="" firefox-6m4fhv="" is="" line="" manager="" media="" mediadecoderstatemachine.cpp,="" mediaplayback="" mozilla::mediaresult,="" mozilla::mediasourcetrackdemuxer::dogetsamples(int32_t):="" ns_error_dom_media_fatal_err="" p="" refptr<mozilla::mozpromise<refptr&lt;mozilla::mediatrackdemuxer::samplesholder&gt;,="" true&gt;="" warning:=""></mozilla::mozpromise<refptr&lt;mozilla::mediatrackdemuxer::samplesholder&gt;,>

Is that important?

more options


Just got FF working and went into the addons and disabled all.

(Just to double check)

Seems with all addons disabled, it loads and seems to be nice.

Now I guess I will have to go through enabling them one at a time.

more options

Chosen Solution

Seems it is/was ghostery.

Disabling it and FF loads perfectly.

Sorry for wasting everyone's time.

I shall try to work out how to report it.

more options

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

And this was not a waste of time. There was a problem and you needed help. Someone else with the same problem may solve their own because of your solution.

more options

Hello, This forum has a very confusing structure so I beg your pardon in case I'm posting to a wrong thread. I have a similar issue but in macOS High Sierra: all pages load very well etc however the problem is that every time I launch Firefox it starts a new fresh session with default preferences completely anew, ignoring my profile. I run FF in Mavericks as well and I don't have this issue there.

Modified by scrutinizer1

more options

How about your other information? bookmarks, history, passwords . . . . .

more options

FredMcD said

How about your other information? bookmarks, history, passwords . . . . .

How's that relevant? Have you read carefully my question? I already told about my entire profile not loading on launch. "An entire profile" means "bookmarks, history, passwords" among other things.

I sorted out by setting the profile in question as default one in hidden preferences "about:profiles".

Modified by scrutinizer1

more options

Hi you two.

Just something I would like to say:

I can understand how when FF isn't "playing the game nicely" it can be annoying. But I explained my solution how to fix the problem.

That was a fair while ago.

Why are you not starting your own thread?