X
Tap here to go to the mobile version of the site.

Support Forum

firefox overheats microsoft surface pro 4 and 6 with intel i

Posted

I purchase a Microsoft surface pro 4 and I used firefox . somehow the tablet overheated to the point of melting the glue tape and releasing the lcd panel from the box and cooking the lcd panel to the shape of a turtle shell. now I have a surface pro 6 and when I use firefox even with minimal tabs the tablet overheats severely. this is ridiculous why does firefox cause the cpu to overclock and overheat and WORSE OF ALL THIS IS NON STOP

there is no doubt that firefox is the cause. I am using edge and chrome and the tablet is colder than my fridge.

why this cpu abuse.

I purchase a Microsoft surface pro 4 and I used firefox . somehow the tablet overheated to the point of melting the glue tape and releasing the lcd panel from the box and cooking the lcd panel to the shape of a turtle shell. now I have a surface pro 6 and when I use firefox even with minimal tabs the tablet overheats severely. this is ridiculous why does firefox cause the cpu to overclock and overheat and WORSE OF ALL THIS IS NON STOP there is no doubt that firefox is the cause. I am using edge and chrome and the tablet is colder than my fridge. why this cpu abuse.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.140 Safari/537.36 Edge/17.17134

More Information

FredMcD
  • Top 10 Contributor
4255 solutions 59596 answers

What's your computer system and Firefox version?

Don't forget this could be a hardware issue.

Make sure your cooling fan is working properly. Buy a can of compressed air and blow out the fan and the air vents.


Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh).

Just let the browser sit there for a while. Is the problem still there?

What's your computer system and Firefox version? Don't forget this could be a hardware issue. Make sure your cooling fan is working properly. Buy a can of compressed air and blow out the fan and the air vents. --------------- [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Just let the browser sit there for a while. Is the problem still there?

Question owner

Microsoft surface pro 4 intel i7 Microsoft surface pro 6 intel i7 7660 windows 10 pro with latest fixes and patches no matter what status. firefox somehow heats the cpu beyond normal and worst is IT KEEPS THE CPU HEATED. I notices yhis dramatically with my new surface pro 6 very seldom have a dozen tabs open at a time but it truly destroid the tablet. as I said I am using edge now and the tablet is cold as soon as firefox launches the tablet starts to heat up even with just one tab. I have no more than 4 addons, adblocker, forecastfox and tab color. further I make sure that no movies are running in none. I do not know what effect firefox has on a laptop, but on the surface pro I will stop using it. it effectively cost me a 700 usd tablet. thoroughly disgusting. and further I am constantly pruning the task manager for background applications. so basically I am only using firefox and I got burned. not satisfied this is one bad application. I stopped using all other browsers to favor firefox nomore. until I am notified that someone found a solution to the cpu cooking not bug BUT SUPER GIGANTIC BUG. NO DOUBT WHATSOEVER.

Microsoft surface pro 4 intel i7 Microsoft surface pro 6 intel i7 7660 windows 10 pro with latest fixes and patches no matter what status. firefox somehow heats the cpu beyond normal and worst is IT KEEPS THE CPU HEATED. I notices yhis dramatically with my new surface pro 6 very seldom have a dozen tabs open at a time but it truly destroid the tablet. as I said I am using edge now and the tablet is cold as soon as firefox launches the tablet starts to heat up even with just one tab. I have no more than 4 addons, adblocker, forecastfox and tab color. further I make sure that no movies are running in none. I do not know what effect firefox has on a laptop, but on the surface pro I will stop using it. it effectively cost me a 700 usd tablet. thoroughly disgusting. and further I am constantly pruning the task manager for background applications. so basically I am only using firefox and I got burned. not satisfied this is one bad application. I stopped using all other browsers to favor firefox nomore. until I am notified that someone found a solution to the cpu cooking not bug BUT SUPER GIGANTIC BUG. NO DOUBT WHATSOEVER.
FredMcD
  • Top 10 Contributor
4255 solutions 59596 answers

What version of Firefox are you using?

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh).

Don't do anything. Just let it sit. Is the problem still there?

What version of Firefox are you using? [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Don't do anything. Just let it sit. Is the problem still there?

Question owner

quantum 66.0.2 64

quantum 66.0.2 64

Question owner

no difference safe or naked after plain reonstall i clearly said i have no addons and even listed them, so pls skip the safe, im being insulted having a long bookmark toolbar is no reason for cpu overclock no doubt bad progtamming. perhaps not mny users of firefox windows on tablets . not too many tablets use windows as opposed to stripped down android time to check the code efffect on intel i7 used in tablets as opposed to i7 used in laptops or desktops. microsoft cooling [ipes cant handle the excessive heat comimg out of firefox o doubt about it, none whatsoever

no difference safe or naked after plain reonstall i clearly said i have no addons and even listed them, so pls skip the safe, im being insulted having a long bookmark toolbar is no reason for cpu overclock no doubt bad progtamming. perhaps not mny users of firefox windows on tablets . not too many tablets use windows as opposed to stripped down android time to check the code efffect on intel i7 used in tablets as opposed to i7 used in laptops or desktops. microsoft cooling [ipes cant handle the excessive heat comimg out of firefox o doubt about it, none whatsoever

Question owner

further just opening a mozilla tab in edge starts the cpu heating i am reading it in cpu thermometer

further just opening a mozilla tab in edge starts the cpu heating i am reading it in cpu thermometer

Question owner

with 2 mozilla tabs in edge temp went to 44 just in the time i typed previous 2 messages after closing 2 tabs temp dropped to 38

with 2 mozilla tabs in edge temp went to 44 just in the time i typed previous 2 messages after closing 2 tabs temp dropped to 38
FredMcD
  • Top 10 Contributor
4255 solutions 59596 answers

I called for more help.

I called for more help.

Question owner

donot understand ,

who called whom,

you to me, please explain

meanwhile firefox, goner

donot understand , who called whom, you to me, please explain meanwhile firefox, goner
FredMcD
  • Top 10 Contributor
4255 solutions 59596 answers
https://support.mozilla.org/en-US/forums/support-forum-contributors/713449 Tablet overheats only with Firefox

Question owner

further info

when i use firefox i check task manager constantly to prune applications. '

what i did notice that although i have A SINGLE FIREFOX program running ALWAYS, i did notice that in task manager firefox has always no less than 5 applications running in the background with high memory use. so in effect althouth i see ONE FIREFOX PROGRAM OPEN WITH AT MOST 10 TABS, IN BACKGROUND FIREFOX HAS MANY TIMES 5 FIREFOX APPLICATIONS RUNNING IN BACKGROUND AND EACH USES XYZ% OF CPU , i never paid attention at cpu levels for each but yes i notice that there are always several firefox running so there you go. when you think you have ONE firefox running most likely your 5 or 6 and that's why it uses high cpu and MEMORY RIDICULOUS not edge opera waterfox chrome do that ONE FIREFOX may i get an explanation

further info when i use firefox i check task manager constantly to prune applications. ' what i did notice that although i have A SINGLE FIREFOX program running ALWAYS, i did notice that in task manager firefox has always no less than 5 applications running in the background with high memory use. so in effect althouth i see ONE FIREFOX PROGRAM OPEN WITH AT MOST 10 TABS, IN BACKGROUND FIREFOX HAS MANY TIMES 5 FIREFOX APPLICATIONS RUNNING IN BACKGROUND AND EACH USES XYZ% OF CPU , i never paid attention at cpu levels for each but yes i notice that there are always several firefox running so there you go. when you think you have ONE firefox running most likely your 5 or 6 and that's why it uses high cpu and MEMORY RIDICULOUS not edge opera waterfox chrome do that ONE FIREFOX may i get an explanation
FredMcD
  • Top 10 Contributor
4255 solutions 59596 answers

More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/

Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess


Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false (before v 58)

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/ Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the '''about:config''' page. '''browser.tabs.remote.autostart''' = false '''browser.tabs.remote.autostart.2''' = false (before v 58) Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''I Accept the Risk''' button. At the top of the screen is a search bar.