X
Tap here to go to the mobile version of the site.

Support Forum

Embedded Youtube videos do not work

Posted

I am running Firefox 52.9.0 (32-bit), Win XP PRO SP3 on several computers and only my desktop has this problem.

Youtube videos embedded in other pages do not work and only blank space is displayed but if I go to Youtube the videos play correctly. This only happens in one computer. In other computers running same Firefox 52.9.0 (32-bit), Win XP PRO SP3 this problem does not happen.

I guess it might be some configuration problem.

I am running Firefox 52.9.0 (32-bit), Win XP PRO SP3 on several computers and only my desktop has this problem. Youtube videos embedded in other pages do not work and only blank space is displayed but if I go to Youtube the videos play correctly. This only happens in one computer. In other computers running same Firefox 52.9.0 (32-bit), Win XP PRO SP3 this problem does not happen. I guess it might be some configuration problem.

Chosen solution

Well, after spending some time here and there I finally figured out it was indeed, as FredMcD suggested, the blocking of tracking. Once I allowed tracking the videos will play. I don know what I did wrong the first time around that it did not work. Anyway, thanks to all. Issue resolved.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • DivX VOD Helper Plug-in
  • GEPlugin
  • Google Update
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Shockwave Flash 30.0 r0
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • npGuide 动态链接库
  • npmedia 动态链接库

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

FredMcD
  • Top 10 Contributor
4113 solutions 57446 answers

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

Make sure you are not blocking content. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? --------------- One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: [https://support.mozilla.org/en-US/kb/tracking-protection Tracking Protection] {web link}
Was this helpful to you?
Quote

Question owner

Thanks for your reply. I started FF in safe mode and the videos do work. So what do I need to do to repair this problem in normal mode?

Thanks for your reply. I started FF in safe mode and the videos do work. So what do I need to do to repair this problem in normal mode?
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4113 solutions 57446 answers

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

It could be the work of one of your add-ons, or it could be '''Hardware Acceleration. ''' ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link} Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Disable a few add-ons, then '''Restart Firefox. ''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All Of them. ''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.
Was this helpful to you?
Quote

Question owner

OK, I tried disabling video acceleration and that did not do anything.

Regarding add-ons, I compared the configuration of the computer with the problem with the one with no problem and did not see anything obvious. I played with the add-ons as you said but still no luck.

At this point, do you think reinstalling FF might make sense?

Any other ideas?

OK, I tried disabling video acceleration and that did not do anything. Regarding add-ons, I compared the configuration of the computer with the problem with the one with no problem and did not see anything obvious. I played with the add-ons as you said but still no luck. At this point, do you think reinstalling FF might make sense? Any other ideas?
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4113 solutions 57446 answers

Update your Flash Player

Uninstall Flash Player | Windows {web link} Uninstall Flash Player | Mac {web link}

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version 32.0.0.156

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Update your Flash Player [http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows] {web link} [http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac] {web link} '''Note: Windows users''' should download the '''ActiveX''' for ''Internet Explorer.'' '''and''' the '''plugin''' for ''Plugin-based browsers'' (like Firefox). '''Note: Windows 8 and Windows 10''' have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX. Flash Player '''Version 32.0.0.156 ''' https://get.adobe.com/flashplayer/ Direct link scans current system and browser '''Note: Other software''' is offered in the download. <Windows Only> https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) '''Note: Other software''' is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration
Was this helpful to you?
Quote
James
  • Top 25 Contributor
  • Moderator
1593 solutions 11222 answers

FredMcD said

One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

On the article page you linked to says this feature started as of Firefox 63.0 while the OP has Fx 52.9.0esr on WinXP as Fx 53.0 and later requires Windows 7 and later.

''FredMcD [[#answer-1210011|said]]'' <blockquote> One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: [https://support.mozilla.org/en-US/kb/tracking-protection Tracking Protection] {web link} </blockquote> On the article page you linked to says this feature started as of Firefox '''63.0''' while the OP has Fx 52.9.0esr on WinXP as Fx 53.0 and later requires Windows 7 and later.

Modified by James

Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17168 solutions 155185 answers

Some websites disallow their pages to be opened in an iframe embedded in the web page. You can usually see a security error message in the Web Console that the action isn't safe.

Did you try Firefox Safe Mode?

Some websites disallow their pages to be opened in an iframe embedded in the web page. You can usually see a security error message in the Web Console that the action isn't safe. *"3-bar" menu button or Tools -> Web Developer *https://developer.mozilla.org/en-US/Tools/Web_Console Did you try Firefox Safe Mode? *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Was this helpful to you?
Quote
James
  • Top 25 Contributor
  • Moderator
1593 solutions 11222 answers

sail33 said

I am running Firefox 52.9.0 (32-bit), Win XP PRO SP3 on several computers and only my desktop has this problem. Youtube videos embedded in other pages do not work and only blank space is displayed but if I go to Youtube the videos play correctly. This only happens in one computer. In other computers running same Firefox 52.9.0 (32-bit), Win XP PRO SP3 this problem does not happen. I guess it might be some configuration problem.

The Windows XP is a big factor in how well you can view videos using a HTML5 player like Youtube uses.

You likely have at least three red check marks on https://www.youtube.com/html5/ instead of all blue.

The reason is due to Microsoft not supporting the old EOL WinXP with the Media Feature packs as they do with Vista and later. The packs provided codecs used by the HTML5 players in Firefox.

With some work you may be able to support HTML5 players better in Firefox 52.9.0 ESR on WinXP. https://msfn.org/board/topic/175591-enable-mp4-h264-aac-html5-video-in-firefox-on-windows-xp-without-flash/

Another option is to dual boot with a light 32-bit Linux distro with a lighter desktop like LXQt or XFCE. Have to make sure you have packages like FFmpeg installed.

''sail33 [[#question-1254887|said]]'' <blockquote> I am running Firefox 52.9.0 (32-bit), Win XP PRO SP3 on several computers and only my desktop has this problem. Youtube videos embedded in other pages do not work and only blank space is displayed but if I go to Youtube the videos play correctly. This only happens in one computer. In other computers running same Firefox 52.9.0 (32-bit), Win XP PRO SP3 this problem does not happen. I guess it might be some configuration problem. </blockquote> The Windows XP is a big factor in how well you can view videos using a HTML5 player like Youtube uses. You likely have at least three red check marks on https://www.youtube.com/html5/ instead of all blue. The reason is due to Microsoft not supporting the old EOL WinXP with the Media Feature packs as they do with Vista and later. The packs provided codecs used by the HTML5 players in Firefox. With some work you may be able to support HTML5 players better in Firefox 52.9.0 ESR on WinXP. https://msfn.org/board/topic/175591-enable-mp4-h264-aac-html5-video-in-firefox-on-windows-xp-without-flash/ Another option is to dual boot with a light 32-bit Linux distro with a lighter desktop like LXQt or XFCE. Have to make sure you have packages like FFmpeg installed.
Was this helpful to you?
Quote

Question owner

I have been messing some more but still no joy. As I said, I have several computers running same FF and Win XP and only one has this problem and I do not see any difference in configuration.

Videos play fine in youtube.com but not when embedded in a page.

I mean, I can work around it but it would be nice to fix it. I will continue tomorrow but if I can't resolve it I might trying reinstalling FF.

I have been messing some more but still no joy. As I said, I have several computers running same FF and Win XP and only one has this problem and I do not see any difference in configuration. Videos play fine in youtube.com but not when embedded in a page. I mean, I can work around it but it would be nice to fix it. I will continue tomorrow but if I can't resolve it I might trying reinstalling FF.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17168 solutions 155185 answers

Did you check the Web Console?

Can you right-click the player area and open the frame in a new tab?

Did you check the Web Console? Can you right-click the player area and open the frame in a new tab?
Was this helpful to you?
Quote

Question owner

The page displays with a blank area where the video should be but it is just like empty space and if I right-click it is just like empty space and no menu for video URL etc.

Here is something which might provide some clue to experts. When I open in safe mode the video does show and play. I checked the source code and compared it to the source code in normal mode. I thought they would be the same although interpreted differently but this is not the case. When in normal mode some things are removed from the source code. (To break the links to youtube I modified them slightly.)

Safe mode: <iframe width="640" height="385" src="https ://www. youtube .com/embed/edO3q" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>

Normal mode: <iframe width="640" height="385" src="//www. youtube .com/embed/edO3q?fs=1&start=" frameborder="0" allowfullscreen></iframe>

So, the difference is that "https://" disappears and also this part has been removed: allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"

My other computer running XP displays the video correctly with the same code so it seems the problem is not with the code but how my FF handles it.

Does that help?

Thanks again.

The page displays with a blank area where the video should be but it is just like empty space and if I right-click it is just like empty space and no menu for video URL etc. Here is something which might provide some clue to experts. When I open in safe mode the video does show and play. I checked the source code and compared it to the source code in normal mode. I thought they would be the same although interpreted differently but this is not the case. When in normal mode some things are removed from the source code. (To break the links to youtube I modified them slightly.) Safe mode: <iframe width="640" height="385" src="https ://www. youtube .com/embed/edO3q" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe> Normal mode: <iframe width="640" height="385" src="//www. youtube .com/embed/edO3q?fs=1&start=" frameborder="0" allowfullscreen></iframe> So, the difference is that "https://" disappears and also this part has been removed: allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" My other computer running XP displays the video correctly with the same code so it seems the problem is not with the code but how my FF handles it. Does that help? Thanks again.
Was this helpful to you?
Quote

Question owner

Oh, I forgot to add that I updated SWF to 32.0 as it is in the other computer but now it does not show the warning "SWF is known to be vulnerable and should be updated".

What confuses me is that videos play correctly in the youtube page but not when embedded in other pages.

Oh, I forgot to add that I updated SWF to 32.0 as it is in the other computer but now it does not show the warning "SWF is known to be vulnerable and should be updated". What confuses me is that videos play correctly in the youtube page but not when embedded in other pages.
Was this helpful to you?
Quote

Question owner

And it is not only Youtube but videos in general. This video does not play but at least I get a still image whereas with youtube I only get empty space and no indication there should be a video there.

http://video.sina.cn/news/2019-03-07/detail-ihsxncvh0655131.d.html

And it is not only Youtube but videos in general. This video does not play but at least I get a still image whereas with youtube I only get empty space and no indication there should be a video there. http://video.sina.cn/news/2019-03-07/detail-ihsxncvh0655131.d.html
Was this helpful to you?
Quote

Question owner

That sina video does not play in safe mode either so it seems like that is a different issue. What a mess.

That sina video does not play in safe mode either so it seems like that is a different issue. What a mess.
Was this helpful to you?
Quote

Question owner

Any ideas? Is removing and reinstalling FF a good idea?

Any ideas? Is removing and reinstalling FF a good idea?
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4113 solutions 57446 answers

I don't think that will help, but:

Full clean re-install;

Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Note: Check Both Folders

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any Mozilla or Firefox program folders. Do not remove the Mozilla Thunderbird folder if there is one.

Do Not remove any profile folders.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

I don't think that will help, but: Full clean re-install; [http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems] {web link} Save the file. Then '''Close Firefox. ''' Using your file browser, open the '''Programs Folder''' on your computer. '''Windows: ''' C:\Program Files C:\Program Files (x86) '''Note:''' Check Both Folders '''Mac: ''' Open the ''' "Applications" ''' folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac '''Linux: ''' Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any '''Mozilla''' or '''Firefox''' program folders. Do not remove the '''Mozilla Thunderbird''' folder if there is one. '''Do Not''' remove any profile folders. After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your '''Computer''' in safe mode and try again. http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia
Was this helpful to you? 0
Quote

Question owner

Well, if you don't think it will help then I won't try it because I do not want to waste time and run the risk of making things worse.

For now I am just skipping watching videos and if I really want to see one I have to go to another computer. My Linux computer displays the videos correctly.

It just seems strange that all my win XP computers show the videos just fine except this one. :(

Well, if you don't think it will help then I won't try it because I do not want to waste time and run the risk of making things worse. For now I am just skipping watching videos and if I really want to see one I have to go to another computer. My Linux computer displays the videos correctly. It just seems strange that all my win XP computers show the videos just fine except this one. :(
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17168 solutions 155185 answers

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

You can create a new profile to test if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox
Was this helpful to you?
Quote

Question owner

Thanks for that suggestion but I am thinking I do not have any settings I really need to keep and I would not might resetting FF to "default factory settings". Is it possible to do this? That is why I was considering removing and re-installing FF entirely.

Can I somehow just "delete" the current profile and have FF rebuilt a profile from scratch?

Thanks for that suggestion but I am thinking I do not have any settings I really need to keep and I would not might resetting FF to "default factory settings". Is it possible to do this? That is why I was considering removing and re-installing FF entirely. Can I somehow just "delete" the current profile and have FF rebuilt a profile from scratch?
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4113 solutions 57446 answers

Refreshing Firefox {web link} is a LAST RESORT ! !

Refreshing Firefox -- easily fix most problems

If you're having problems with Firefox, refreshing it can help. The refresh feature fixes many issues by restoring Firefox to its factory default state while saving your essential information like bookmarks and open tabs. Everything else, like user settings and add-ons, are removed. Note: Refresh saves your old profile to the desktop in a folder called Old Firefox.

[https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings Refreshing Firefox] {web link} is a '''LAST RESORT ! !''' Refreshing Firefox -- easily fix most problems If you're having problems with Firefox, refreshing it can help. The refresh feature fixes many issues by restoring Firefox to its factory default state while saving your essential information like bookmarks and open tabs. Everything else, like user settings and add-ons, are removed. '''Note:''' Refresh saves your old profile to the desktop in a folder called '''Old Firefox.'''
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.