Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

File Types missing from "Save Image As" - only option is "All Files"

  • 3 replies
  • 2 have this problem
  • 60 views
  • Last reply by cor-el

more options

When I right-click to get the "Save Image As" command the only file type available in the drop-down box is All Files - and pictures saved that way will not paste into other applications. How do I get Firefox to save the image in its native format (jpg, png, gif, tiff, etc.) so that it is usable?

Attached screenshots

Chosen solution

You can add the correct file extension (e.g. .jpg or .png yourself) if Firefox doesn't add it.

This can be cause for the Windows feature to hide the file extension for known file types, so maybe check this in the Windows folder setting to see if that has effect.

Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

You can add the correct file extension (e.g. .jpg or .png yourself) if Firefox doesn't add it.

This can be cause for the Windows feature to hide the file extension for known file types, so maybe check this in the Windows folder setting to see if that has effect.

Modified by cor-el

more options

Thank you for your response - I appreciate it. And yes, I can do that manually, but this behavior does not happen with other browsers such as Chrome or Edge so I do not believe it is an issue with Windows. Why do I have to manually add a file type in Firefox?

more options

See: