Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

stop autoplay videos

  • 1 reply
  • 2 have this problem
  • 20 views
  • Last reply by jscher2000

more options

I tried all the support answers, about:config, autoplay default set to 0, 1, 2, set all the media autoplay options to prevent videos from autoplaying, to no avail. Nothing works! I love firefox but autoplay videos are very annoying. I hope you are able to provide a solution for me. I read it will be in options soon but I have little faith anything will work since I've tried every suggestion.

All Replies (1)

more options

Hi Tonoos22, Firefox's built-in feature seems limited to videos that start shortly after page load. As you scroll around the page, you may trigger a script that starts a video that Firefox doesn't pick up. But let's see if we can maximize the functionality of the built-in feature first before looking at add-ons.

Could you try a little experiment:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste autop and pause while the list is filtered

(3) Double-click the media.autoplay.default preference to display a dialog and change from 0 to 1 and click OK -- this is the same as checking the box on the Options page -- that should be enough for many sites

(4) Double-click the media.autoplay.allow-muted preference to switch the value from true to false

This is the odd one:

(5) Double-click the media.autoplay.enabled.user-gestures-needed preference to switch the value from true to false -- previously setting this to true helped control videos, but in some user experiments, it worked better set to false

Any difference?