Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Gmail window has shrunk to a much smaller size.

  • 18 replies
  • 1 has this problem
  • 90 views
  • Last reply by osprey1111

more options

Every since the most recent update to 66.0 the Gmail window has shrunk to half it's size. No other windows are effected and Gmail works fine with Google Chrome. Is there an easy fix for this? I appreciate your help. Thank you.

P.S. I've tried to send a screenshot but for some reason it won't upload. It's just a simple jpeg.

Chosen solution

osprey1111 said

I disabled the two extensions but it still didn't correct the problem.

Hello osprey1111,

A stab in the dark, but would you do the same with "Zoom 2.4.7.0" and see if that will make a difference  ?

Another stab in the dark : you're using a bookmark to get to
Gmail - what happens when you use this link :

https://mail.google.com/  ?

Read this answer in context 👍 1

All Replies (18)

more options

Hi osprey1111, could you explain this in a little more detail:

Every since the most recent update to 66.0 the Gmail window has shrunk to half it's size. No other windows are effected and Gmail works fine with Google Chrome.

Is the problem with the text size? For that, I would try zoom. For example, hold down the Ctrl key and tap 0 (that's a zero) to reset the zoom level on the page, and tap + to enlarge further.

Is the problem with the layout of the page, i.e., part of the window is not used? For that, I'd point to:

If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server).

(A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: What happened to Tracking Protection?.

(B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data"
  • (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Hi jscher2000,

 Thanks so much for your help. The issue is with the layout of the page. Gmail only takes up the top left corner half of the screen.
 I've gone through all your suggestions and putting it in safe mode works. So there must be an issue with one of the extensions. Where do I go from here? Should I disable each add-on and restart Firefox one at a time to see who the culprit is or is there an easier way to do this?
  I have to leave in a few minutes and get back to this later. I WILL get back to you. Again, thanks for your help!

Steve

more options

Hi Steve, Firefox's Safe Mode also disables the userContent.css and userChrome.css files, in case you have one of those.

Regarding extensions, I would focus on the ones that make changes to page content, such as various kinds of blockers.

more options

Sounds good. I'll try disabling some "blocker" type extensions and see what happens. Thanks!

more options

Well, no luck so far. It's odd because I haven't added any more extensions since yesterday when Firefox was updated. And each time I restart Firefox, Gmail starts normally for about 1 second and then reverts to the smaller window.

 Well I have to leave now so I'll get back to this later. Thanks again jscher2000 for your help.
more options

I haven't been able to figure anything else out. I'm still having the same problem.

more options

Can you attach a screenshot?

more options

I'm a little puzzled by the behavior. Initially, as the page is loading, Gmail has its normal layout, but then a moment after it finishes loading, it shrinks from using the whole tab to using the upper left corner of the tab.

It sounds as though there is some bad math going on with the sizing of the layout, but since it works in Firefox's Safe Mode, I'm still wondering if an extension could be involved. ??

more options

I've tried to disable all the "blocker" extensions without luck is there any others you would recommend to try? The odd thing though is that I haven't added anything new since it worked on the last version of Firefox.

I was asked for a screenshot. I'll try again to attach one...

more options

Thank you for the screenshot.

What is the Gmail-ish icon on your toolbar? Could you try disabling that extension temporarily in case it somehow interacts with the Gmail tab.

Would any of your other add-ons be interacting with Gmail?

more options

The two icons are for Gmail Notifier and X-Notifier for Gmail. Both of which I've used for a long time. Could they be the culprits? I'll try disabling these two add-ons.

Thank you for your help with this. I'll be away from the computer for awhile but I will get back to you...

more options

I disabled the two extensions but it still didn't correct the problem.

more options

Do you have either a userChrome.css or userContent.css file? To check on that:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in File Explorer.

Look for a folder named chrome (yellow folder icon, all lower case wording).

If you do not have this folder, then this is not the issue.

If you do that this folder, double-click into the folder.

Do you have either or both of these files:

  • userChrome.css -- rules modifying the user interface area and sidebar
  • userContent.css -- rules modifying the content area of the tab
more options

Hi. No, unfortunately, I don't have the chrome folder.

more options

Chosen Solution

osprey1111 said

I disabled the two extensions but it still didn't correct the problem.

Hello osprey1111,

A stab in the dark, but would you do the same with "Zoom 2.4.7.0" and see if that will make a difference  ?

Another stab in the dark : you're using a bookmark to get to
Gmail - what happens when you use this link :

https://mail.google.com/  ?

more options

You did it! Disabling the "Zoom 2.4.7.0" extension did the trick! Thank you McCoy! And thank you jscher2000 for all your hard work. Where would I be without you two! I honestly can't tell you how much I appreciate the effort that was put into this. Thank you again. All the very best, Steve

more options

osprey1111 said

You did it! Disabling the "Zoom 2.4.7.0" extension did the trick!
Thank you McCoy!

My pleasure, Steve - it was a mere stab in the dark, but I sure am glad that it worked.

more options

Well I really appreciate it. Many thanks again!