Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Problem Playing Music Tracks on www.FreeMusicArchive.org

  • 4 replies
  • 1 has this problem
  • 96 views
  • Last reply by Pj

more options

https://freemusicarchive.org/genre/Instrumental/?sort=track_date_published&d=1&page=1&per_page=100

I can't get the music tracks to play. I've Disabled all Extensions (but haven't yet Closed/Restarted the browser).

I already turned OFF Content Blocking and Made Exceptions from that and for Cookies, Pastries, and Pies.

I thought I had it figured when I un-checked the boxes for 'Deceptive Content and Dangerous Software Protection', as the tracks would play... but later... it stopped again and I can't get anything to play now.


~Pj (Ok, when I get a chance to end my session, I'll do a FF Safe Mode (Disable Extensions/Add-ons and Restart Browser) and see what happens.)

Chosen solution

I tried 'everything' and no go... then I found something in the About:Config Audio settings that were shown 'Modified'.

I didn't recognize the settings and that I had made the changes, but I 'Reset' a few of these settings back to their defaults.

I think some of these got changed by me or FF when I was fiddling around with Audio/Video changes in About:Config for YouTube, plus I have the Enhancer For YouTube Extension may have played a part in this. (Whew. So many things to keep track of. FF needs an Auto-Logger for Config changes.) (Wink)

Anyway, I think that did it, because so far, FMA is now working again.

Thanks-a-Bunch!


~Pj

Read this answer in context 👍 0

All Replies (4)

more options

The website use JPlayer for me to play MP3 files via an audio tag.

more options

cor-el said

The website use JPlayer for me to play MP3 files via an audio tag.

Hmm. I thought the browser itself was playing the music. I don't see any pop-up player or anything.

Usually, in the past versions of FF, I click play and each track would play until it reached the end of the track on the one page. I haven't played anything on this site since somewhere around FF 60, give or take. Today, with FF 65.xx, I see this problem.

I'll look more into this.

Thanks,

~Pj

more options

The JPlayer code only creates the HTML code for the audio tag that shows in the screenshot. The audio tag makes Firefox play the MP3 file via the HTML5 media player. If this audio tag isn't created/updated and the JavaScript bound to the play buttons isn't working properly then you won't hear sound.

more options

Chosen Solution

I tried 'everything' and no go... then I found something in the About:Config Audio settings that were shown 'Modified'.

I didn't recognize the settings and that I had made the changes, but I 'Reset' a few of these settings back to their defaults.

I think some of these got changed by me or FF when I was fiddling around with Audio/Video changes in About:Config for YouTube, plus I have the Enhancer For YouTube Extension may have played a part in this. (Whew. So many things to keep track of. FF needs an Auto-Logger for Config changes.) (Wink)

Anyway, I think that did it, because so far, FMA is now working again.

Thanks-a-Bunch!


~Pj