X
Tap here to go to the mobile version of the site.

Support Forum

Firefox blocks content on a site I trust and doesn't allow me to unblock it

Posted

When I open a mail from my online mail box, the images are being blocked. I have read the instructions from the Mozilla forum but I can't figure out how to unblock the content. - There is no Turn Off Blocking For This Site option under the content options - There is no Disable Protection For Now option under the connection options (is it available only for secured connections?)

I have even turned off all tracking protection just to see if I would get my mail in order - didn't change anything more than just seeing more trackers and cookies under the content section.

I have opened the same mails from the same computer, in the same network in IE - there everything is fine. So it is not something from the mail provider.

This applies to all images in all mails - youtube, online shopping sites I have subscribed to, travel sites I have subscribed to (as the one from the screen shots).

I don't want to move to another browser but this is getting really frustrating - I am fighting with this for several days already :(

When I open a mail from my online mail box, the images are being blocked. I have read the instructions from the Mozilla forum but I can't figure out how to unblock the content. - There is no Turn Off Blocking For This Site option under the content options - There is no Disable Protection For Now option under the connection options (is it available only for secured connections?) I have even turned off all tracking protection just to see if I would get my mail in order - didn't change anything more than just seeing more trackers and cookies under the content section. I have opened the same mails from the same computer, in the same network in IE - there everything is fine. So it is not something from the mail provider. This applies to all images in all mails - youtube, online shopping sites I have subscribed to, travel sites I have subscribed to (as the one from the screen shots). I don't want to move to another browser but this is getting really frustrating - I am fighting with this for several days already :(
Attached screenshots

Chosen solution

I FOUND IT!!!

I turned off this setting and everything is back to normal. Now I have to read more and figure out why... because I don't want to be completely exposed and I definitely don't want the dangerous downloads to be on but there is no custom settings here. FF never warned me (as the check box suggests) and gave me the option for me to decide myself what to block and what not :( I hope the FF team would improve that (as the exceptions for the sites).

Thank you all for the suggestions.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

FredMcD
  • Top 10 Contributor
4261 solutions 59654 answers

Some e-mail providers may block content. Ask their support about this.

Are you using ab blocker add-ons/programs?

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Some e-mail providers may block content. Ask their support about this. Are you using ab blocker add-ons/programs? [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
McCoy
  • Top 10 Contributor
545 solutions 5143 answers

Hello OliBelokapova,

Just in case the above doesn't make a difference - would you try this please : When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown and then on "More Information", which will take you to "Page Info".

Click on the 'Permissions" tab and scroll down to "Load Images". Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.

Hello OliBelokapova, Just in case the above doesn't make a difference - would you try this please : When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar. Then click on the little black arrow on the dropdown and then on "More Information", which will take you to "Page Info". Click on the 'Permissions" tab and scroll down to "Load Images". Uncheck "Use Default" and check "Allow". Then close and restart Firefox.

Question owner

FredMcD said

Some e-mail providers may block content. Ask their support about this. Are you using ab blocker add-ons/programs? Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

If you have read my whole post you should have read the part where I said I have opened the same mail in IE and nothing was blocked there so it is NOT coming from the mail provider. And since you didn't read my whole post, I don't trust to try the solution you propose since it is not based on the full picture of the issue. Also I don't want to view content in Safe Mode, I want to browse normally as I used to do until the last FF upgrade happened. Thank you reading at least some part of my post though.

''FredMcD [[#answer-1197599|said]]'' <blockquote> Some e-mail providers may block content. Ask their support about this. Are you using ab blocker add-ons/programs? [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? </blockquote> If you have read my whole post you should have read the part where I said I have opened the same mail in IE and nothing was blocked there so it is NOT coming from the mail provider. And since you didn't read my whole post, I don't trust to try the solution you propose since it is not based on the full picture of the issue. Also I don't want to view content in Safe Mode, I want to browse normally as I used to do until the last FF upgrade happened. Thank you reading at least some part of my post though.

Question owner

McCoy said

Hello OliBelokapova, Just in case the above doesn't make a difference - would you try this please : When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar. Then click on the little black arrow on the dropdown and then on "More Information", which will take you to "Page Info". Click on the 'Permissions" tab and scroll down to "Load Images". Uncheck "Use Default" and check "Allow". Then close and restart Firefox.

Hello McCoy,

I tried that and restarted twice but it seems the setting doesn't stick up. Also the images are still broken :(

I set it up (MozillaImageSetting1.png) and close the pop up window (I don't see any Save button). I open it again after the restart (MozillaImageSetting2.png) it is again Default. I have opened the same mail (the url is the same) even though the permissions are for the domain part.

I really don't know what to do.

''McCoy [[#answer-1197603|said]]'' <blockquote> Hello OliBelokapova, Just in case the above doesn't make a difference - would you try this please : When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar. Then click on the little black arrow on the dropdown and then on "More Information", which will take you to "Page Info". Click on the 'Permissions" tab and scroll down to "Load Images". Uncheck "Use Default" and check "Allow". Then close and restart Firefox. </blockquote> Hello McCoy, I tried that and restarted twice but it seems the setting doesn't stick up. Also the images are still broken :( I set it up (MozillaImageSetting1.png) and close the pop up window (I don't see any Save button). I open it again after the restart (MozillaImageSetting2.png) it is again Default. I have opened the same mail (the url is the same) even though the permissions are for the domain part. I really don't know what to do.
McCoy
  • Top 10 Contributor
545 solutions 5143 answers

Your first screenshots shows 'Blockable content detected on this site', but nothing is blocked ..... (as you turned off Content Blocking). So, that's not the reason images don't show.

As you mention that images don't show on other sites either - would you please take a ook at this article :

https://support.mozilla.org/en-US/kb/fix-problems-images-not-show

Also : FredMcD suggested to start Firefox in Safe Mode - that does not mean that you would have to do that every time; just to see if in Safe Mode images do load, and if that's the case : that might indicate what caused it .....

Your first screenshots shows 'Blockable content detected on this site', but nothing is blocked ..... (as you turned off Content Blocking). So, that's not the reason images don't show. As you mention that images don't show on other sites either - would you please take a ook at this article : https://support.mozilla.org/en-US/kb/fix-problems-images-not-show Also : FredMcD suggested to start Firefox in Safe Mode - that does not mean that you would have to do that every time; just to see if in Safe Mode images do load, and if that's the case : that might indicate what caused it .....

Question owner

Oh, the images show on the sites themselves. Just when I open the notifications in the mail they don't. And I use the notifications to decide whether I want to go to the site at all. I am attaching how I see the same mail in IE (I really hate using IE though) and FF. Also how the site look like in FF (everything is OK there).

I will try the Safe Mode and the options from the link you provided and write back what happened.

Oh, the images show on the sites themselves. Just when I open the notifications in the mail they don't. And I use the notifications to decide whether I want to go to the site at all. I am attaching how I see the same mail in IE (I really hate using IE though) and FF. Also how the site look like in FF (everything is OK there). I will try the Safe Mode and the options from the link you provided and write back what happened.
McCoy
  • Top 10 Contributor
545 solutions 5143 answers

Ahh, I see - the images do show on the sites themselves, just not in your email account.

(BTW : I know what you mean about IE ..... )

Now, you take all the time you need to go over that article and to try Safe Mode.

Ahh, I see - the images do show on the sites themselves, just not in your email account. (BTW : I know what you mean about IE ..... ) Now, you take all the time you need to go over that article and to try Safe Mode.

Chosen Solution

I FOUND IT!!!

I turned off this setting and everything is back to normal. Now I have to read more and figure out why... because I don't want to be completely exposed and I definitely don't want the dangerous downloads to be on but there is no custom settings here. FF never warned me (as the check box suggests) and gave me the option for me to decide myself what to block and what not :( I hope the FF team would improve that (as the exceptions for the sites).

Thank you all for the suggestions.

I FOUND IT!!! I turned off this setting and everything is back to normal. Now I have to read more and figure out why... because I don't want to be completely exposed and I definitely don't want the dangerous downloads to be on but there is no custom settings here. FF never warned me (as the check box suggests) and gave me the option for me to decide myself what to block and what not :( I hope the FF team would improve that (as the exceptions for the sites). Thank you all for the suggestions.
FredMcD
  • Top 10 Contributor
4261 solutions 59654 answers

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

Go to the Mozilla Add-ons Web Page {web Link} (There’s a lot of good stuff here) and search for a good ad blocker.

That was very good work. Well done. Please flag your last post as '''Solved Problem''' so others will know. Go to the [https://addons.mozilla.org/en-US/firefox/ Mozilla Add-ons Web Page] {web Link} (There’s a lot of good stuff here) and search for a good ad blocker.

Modified by James