Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox default browser preference does not stick

  • 3 replies
  • 1 has this problem
  • 26 views
  • Last reply by Jimmyhelena

more options

I'm running FF 63.0.3 on Win10x64. For a long time, I kept Firefox to set my default browser to Firefox in the Options menu. Lately, every time I open FF, I am advised that FF is not my default browser. Then, I set it to the default in Windows/Settings/Apps. But after I close FF and reopen it, I'm again prompted that FF is not the default browser. So I go through the process yet again.

Could there be some Windows registry setting? I created second profile and copied the bookmarks, cert8/9 files over from the original profile, and I installed the same extensions. However, the issue occurs in my new profile as well. Thanks for any suggestions.

I'm running FF 63.0.3 on Win10x64. For a long time, I kept Firefox to set my default browser to Firefox in the Options menu. Lately, every time I open FF, I am advised that FF is not my default browser. Then, I set it to the default in Windows/Settings/Apps. But after I close FF and reopen it, I'm again prompted that FF is not the default browser. So I go through the process yet again. Could there be some Windows registry setting? I created second profile and copied the bookmarks, cert8/9 files over from the original profile, and I installed the same extensions. However, the issue occurs in my new profile as well. Thanks for any suggestions.

All Replies (3)

more options

Firefox checks some Windows Registry keys to see whether they point to Firefox and haven't been modified. If something has changed then Firefox shows this message.

You can try to set another browser as the default browser and then let Firefox try again to see if that works.

more options

Okay, I'll list my steps so that it's easier to explain.

1. Run Firefox, receive the notice that it's not the default.

2. Make FF the default in notice window and in Windows settings, which opens automatically to make FF the default.

3. Close and re-open FF, the issue repeats. Go through the same steps, and close.

4. Open Chrome, which advises that it is not my default browser. Make it my default browser and do so in Windows settings. Close Chrome.

5. Re-open Chrome, which remains the default browser.

6. Restart computer, open Chrome, and it remains default browser.

7. Open Firefox, receive notice, make FF my default. However, after doing so in the notice window and trying to do so in Firefox options, Firefox will not let me make it the default in FF options. The FF General options will not change to FF when I click "Make Default." Again, FF will not accept the change in FF options.

more options

I solved the problem. It was with a Firefox shortcut that I placed on the Taskbar. The shortcut opened FF o my home page, my.yahoo.com. I found that. if I opened FF from a Taskbar shortcut that opened Google.com, the issue did not occur. I deleted the problem shortcut and created a new one that opened FF to my.yahoo.com and the problem did not present or recur. Regardless, thanks very much for your help!