X
Tap here to go to the mobile version of the site.

Support Forum

firefox showing alter text in images when loading for a few seconds but not by other browsers

Posted

Im a developer when loading a web page firefox first load the alter text and then load the images where as other browsers load the images first.I have check with couple of sites same issue is happening.Alter text appeared for around for 1sec and load the image.but for other browsers it is ok.how can i overcome this issue My internet connection is also a good one

Im a developer when loading a web page firefox first load the alter text and then load the images where as other browsers load the images first.I have check with couple of sites same issue is happening.Alter text appeared for around for 1sec and load the image.but for other browsers it is ok.how can i overcome this issue My internet connection is also a good one
Attached screenshots

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

More Information

FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!


Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Hello, In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see [[How do I create a screenshot of my problem?]] Once you've done this, attach the saved screenshot file to your forum post by clicking the '''Browse...''' button below the ''Post your reply'' box. This will help us to visualize the problem. Thank you! ---------------------- [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Question owner

here is one sample image for the scenario .This is not only for this site but also other sites having the same issue.but fine with other browsers. Please refer the link with firefox and also other browsers

Tisot Discovery

here is one sample image for the scenario .This is not only for this site but also other sites having the same issue.but fine with other browsers. Please refer the link with firefox and also other browsers [https://us.tissotshop.com/ Tisot] [https://www.discovery.com/ Discovery]
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Have you tried Firefox Safe Mode?

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

Have you tried Firefox Safe Mode? Make sure you are not blocking content. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? --------------- One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: [https://support.mozilla.org/en-US/kb/tracking-protection Tracking Protection] {web link}

Question owner

yes i have run firefox in safe mode and i`m not blocking any content and also no addons installed.padlock icon is not related to this issue i guess.it is for SSL verification

yes i have run firefox in safe mode and i`m not blocking any content and also no addons installed.padlock icon is not related to this issue i guess.it is for SSL verification
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Is this with just those websites, or are there others as well?

https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history

Remove History For One Site

Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any passwords / settings.

Is this with just those websites, or are there others as well? https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history Remove History For One Site Open the History Manager '''<Control><Shift> H.''' In the search bar, enter the name of the site. Right-click on one of the listings and select '''Forget About This Site.''' This should remove all information, including any passwords / settings.

Question owner

ya i have deleted the cache as wel.this is not only for these sites is a common issue in firefox i guess.i need to how we can over come these issue in firefox. because it is not happening in other browser

ya i have deleted the cache as wel.this is not only for these sites is a common issue in firefox i guess.i need to how we can over come these issue in firefox. because it is not happening in other browser
cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157871 answers

The alt text is normally displayed as a placeholder when Firefox fails to load an image.

Are those images loaded via JavaScript (XHR)? Are there possible server redirects?

Did you check the Web Console for related messages and the timings in the Network Monitor?

The alt text is normally displayed as a placeholder when Firefox fails to load an image. Are those images loaded via JavaScript (XHR)? Are there possible server redirects? Did you check the Web Console for related messages and the timings in the Network Monitor? *https://developer.mozilla.org/en/Tools/Web_Console *https://developer.mozilla.org/en/Tools/Network_Monitor