X
Tap here to go to the mobile version of the site.

Support Forum

Block video autoplay not working

Posted

In the past few days, the block video autoplay option is not working. It had been working properly for years. I have video autoplay turned off in about:config and the option to block autoplay is no longer available under the settings menu. What settings need to be changed to re-enable this in the update. This is extremely annoying.

In the past few days, the block video autoplay option is not working. It had been working properly for years. I have video autoplay turned off in about:config and the option to block autoplay is no longer available under the settings menu. What settings need to be changed to re-enable this in the update. This is extremely annoying.

Chosen solution

hi, in firefox 63 the autoplay preferences are reorganised in preparation for this feature shipping out of the box in one of the upcoming versions. in about:config you can set media.autoplay.default to 1 in order to block automatic playback on all pages or set it to 2 to decide on a per domain basis.

Read this answer in context 14

Additional System Details

Installed Plug-ins

  • Shockwave Flash 31.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5322 solutions 23504 answers

Chosen Solution

hi, in firefox 63 the autoplay preferences are reorganised in preparation for this feature shipping out of the box in one of the upcoming versions. in about:config you can set media.autoplay.default to 1 in order to block automatic playback on all pages or set it to 2 to decide on a per domain basis.

hi, in firefox 63 the autoplay preferences are reorganised in preparation for this feature shipping out of the box in one of the upcoming versions. in about:config you can set ''media.autoplay.default'' to 1 in order to block automatic playback on all pages or set it to 2 to decide on a per domain basis.
lsk123 0 solutions 12 answers

Why. oh, why do they keep changing things without telling us, making us spend an hour searching for answers and trying things! You'd think they'd let you know when they make changes.

Thank you for posting what I hope is the solution.

Why. oh, why do they keep changing things without telling us, making us spend an hour searching for answers and trying things! You'd think they'd let you know when they make changes. Thank you for posting what I hope is the solution.
jscher2000
  • Top 10 Contributor
8792 solutions 71899 answers

Hi lsk123, these hidden autoplay-related preferences have been under development for a long time. If you read past support threads about how they broke the Netflix player, or GIFV "images" on Imgur, etc., you know they needed more work before being unleashed on 300 million Firefox users. Meanwhile, Firefox 58 introduced a new approach to site permissions on the Options/Preferences page. When the feature is fully debugged and ready for prime-time, we expect a new section to appear where you'll be able to manage it like other site permissions, and if you want site-by-site control, a drop-panel from the left end of the address bar.

Until it is fully baked, please understand that its behavior and naming will remain in flux. And please report problems as they arise.

Hi lsk123, these hidden autoplay-related preferences have been under development for a long time. If you read past support threads about how they broke the Netflix player, or GIFV "images" on Imgur, etc., you know they needed more work before being unleashed on 300 million Firefox users. Meanwhile, Firefox 58 introduced a new approach to site permissions on the Options/Preferences page. When the feature is fully debugged and ready for prime-time, we expect a new section to appear where you'll be able to manage it like other site permissions, and if you want site-by-site control, a drop-panel from the left end of the address bar. Until it is fully baked, please understand that its behavior and naming will remain in flux. And please report problems as they arise.

Modified by jscher2000

Susan_F 0 solutions 2 answers

The solution here solved my problem (once I remembered how to punctuate about:config).

Is there any way to make this post appear at the top of the search results when anyone searches "disable autoplay"? I went through multiple out-of-date posts and tried a bunch of things before I found this.

The solution here solved my problem (once I remembered how to punctuate about:config). Is there any way to make this post appear at the top of the search results when anyone searches "disable autoplay"? I went through multiple out-of-date posts and tried a bunch of things before I found this.
cor-el
  • Top 10 Contributor
  • Moderator
17574 solutions 158975 answers

Helpful Reply

You can set the first two prefs listed below (or at least user-gestures-needed) to true then to have a setting available in "Options/Preferences -> Privacy & Security -> Permissions" that also allows to inspect and modify the exceptions.

  • media.autoplay.enabled.user-gestures-needed = true
  • media.autoplay.ask-permission = true
  • media.autoplay.default = 0 [0=Allowed, 1=Blocked, 2=Prompt]

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

You can set the first two prefs listed below (or at least user-gestures-needed) to true then to have a setting available in "Options/Preferences -> Privacy & Security -> Permissions" that also allows to inspect and modify the exceptions. *media.autoplay.enabled.user-gestures-needed = true *media.autoplay.ask-permission = true *media.autoplay.default = 0 [0=Allowed, 1=Blocked, 2=Prompt] You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config
jscher2000
  • Top 10 Contributor
8792 solutions 71899 answers

Susan_F said

Is there any way to make this post appear at the top of the search results when anyone searches "disable autoplay"?

I wish! Unfortunately the old threads got a lot of "Helpful" votes back in the day and I'm not aware of a way to erase those.

''Susan_F [[#answer-1168939|said]]'' <blockquote>Is there any way to make this post appear at the top of the search results when anyone searches "disable autoplay"? </blockquote> I wish! Unfortunately the old threads got a lot of "Helpful" votes back in the day and I'm not aware of a way to erase those.
CiaoBella1 5 solutions 239 answers

I just ran into this now. Very interesting. I tried media autoplay 'default' (correctly typed, though) but it's not on my list. The other ones on your list of three, ending with "gestures needed" and "ask permission" are on my list. I changed them both to true.

I was surprised that my former settings didn't work - I must have changed them a couple of weeks ago.

Thank you, cor-el.

I just ran into this now. Very interesting. I tried media autoplay 'default' (correctly typed, though) but it's not on my list. The other ones on your list of three, ending with "gestures needed" and "ask permission" are on my list. I changed them both to true. I was surprised that my former settings didn't work - I must have changed them a couple of weeks ago. Thank you, cor-el.

Modified by CiaoBella1

KezzerN 0 solutions 29 answers

This worked for me initially, but now videos are auto-playing again. Any other suggestions please?

Also, why can't we just have an easy option under preferences to stop them auto-playing?

Thanks.

This worked for me initially, but now videos are auto-playing again. Any other suggestions please? Also, why can't we just have an easy option under preferences to stop them auto-playing? Thanks.
jscher2000
  • Top 10 Contributor
8792 solutions 71899 answers

Hi KezzerN, Mozilla is planning to add a media autoplay permissions section to the Options/Preferences page once the settings have completed full testing and interface design. For now, you can use what's available.

This worked for me initially, but now videos are auto-playing again. Any other suggestions please?

Could you check again:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste autop and pause while the list is filtered

To set your preferred behavior:

Block autoplay by default

  • Double-click the media.autoplay.default preference and set it to 1
  • Some people suggest you also: Double-click the media.autoplay.allow-muted preference to switch the value from true to false

=> Does that work for you?

Ask on a site-by-site basis (default for "Nightly")

  • Double-click the media.autoplay.default preference and set it to 2
  • Double-click the media.autoplay.ask-permission preference to switch the value from false to true
  • Double-click the media.autoplay.enabled.user-gestures-needed preference to switch the value from false to true

Allow autoplay by default (default for Release)

  • Double-click the media.autoplay.default preference and set it to 0 (or right-click > Reset)

I'm sure we'll learn more about the interaction of these various preferences and what sites can bypass them as more users begin to run Firefox 63. If there are problem pages, feel free to share the links.

Hi KezzerN, Mozilla is planning to add a media autoplay permissions section to the Options/Preferences page once the settings have completed full testing and interface design. For now, you can use what's available. <blockquote>This worked for me initially, but now videos are auto-playing again. Any other suggestions please? </blockquote> Could you check again: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''autop''' and pause while the list is filtered To set your preferred behavior: '''''Block autoplay by default''''' * Double-click the '''media.autoplay.default''' preference and set it to '''1''' * ''Some people suggest you also:'' Double-click the '''media.autoplay.allow-muted''' preference to switch the value from true to false => ''Does that work for you?'' '''''Ask on a site-by-site basis''''' (default for "Nightly") * Double-click the '''media.autoplay.default''' preference and set it to '''2''' * Double-click the '''media.autoplay.ask-permission''' preference to switch the value from false to true * Double-click the '''media.autoplay.enabled.user-gestures-needed''' preference to switch the value from false to true '''''Allow autoplay by default''''' (default for Release) * Double-click the '''media.autoplay.default''' preference and set it to '''0''' (or right-click > Reset) I'm sure we'll learn more about the interaction of these various preferences and what sites can bypass them as more users begin to run Firefox 63. If there are problem pages, feel free to share the links.
McCoy
  • Top 10 Contributor
546 solutions 5143 answers

@KezzerN,

Would you please continue in your own thread :

https://support.mozilla.org/en-US/questions/1239777

I told you I would call for help (and jscher2000 is the one
I called ..... )

@KezzerN, Would you please continue in your own thread : https://support.mozilla.org/en-US/questions/1239777 I told you I would call for help (and jscher2000 is the one <BR>I called ..... )
KezzerN 0 solutions 29 answers

McCoy said

@KezzerN, Would you please continue in your own thread : https://support.mozilla.org/en-US/questions/1239777 I told you I would call for help (and jscher2000 is the one
I called ..... )

Yes, sorry I posted this before I thought that I would be better starting a new thread.

''McCoy [[#answer-1170942|said]]'' <blockquote> @KezzerN, Would you please continue in your own thread : https://support.mozilla.org/en-US/questions/1239777 I told you I would call for help (and jscher2000 is the one <BR>I called ..... ) </blockquote> Yes, sorry I posted this before I thought that I would be better starting a new thread.
trennor 0 solutions 2 answers

jscher2000 said

Hi lsk123, these hidden autoplay-related preferences have been under development for a long time. If you read past support threads about how they broke the Netflix player, or GIFV "images" on Imgur, etc., you know they needed more work before being unleashed on 300 million Firefox users. Meanwhile, Firefox 58 introduced a new approach to site permissions on the Options/Preferences page. When the feature is fully debugged and ready for prime-time, we expect a new section to appear where you'll be able to manage it like other site permissions, and if you want site-by-site control, a drop-panel from the left end of the address bar. Until it is fully baked, please understand that its behavior and naming will remain in flux. And please report problems as they arise.

Who has time OR inclination for this, when you're not a geek?! All a non-geek wants is for something to WORK when s/he turns it on, like my coffee pot in the morning. I know when I add water and grounds, and turn it on, a little light comes on and in 8 minutes I have coffee; I don't need to go to a website if something goes wrong. Same with this. If you're going to change things, TELL US! Put it in the update: This is changed, THIS is what to do about and oh, sorry for the inconvenience. What is so difficult about that?! The thing about geeks is they never seem to have PR skills, perhaps employing someone to do just this might help?!

''jscher2000 [[#answer-1167568|said]]'' <blockquote> Hi lsk123, these hidden autoplay-related preferences have been under development for a long time. If you read past support threads about how they broke the Netflix player, or GIFV "images" on Imgur, etc., you know they needed more work before being unleashed on 300 million Firefox users. Meanwhile, Firefox 58 introduced a new approach to site permissions on the Options/Preferences page. When the feature is fully debugged and ready for prime-time, we expect a new section to appear where you'll be able to manage it like other site permissions, and if you want site-by-site control, a drop-panel from the left end of the address bar. Until it is fully baked, please understand that its behavior and naming will remain in flux. And please report problems as they arise. </blockquote> Who has time OR inclination for this, when you're not a geek?! All a non-geek wants is for something to WORK when s/he turns it on, like my coffee pot in the morning. I know when I add water and grounds, and turn it on, a little light comes on and in 8 minutes I have coffee; I don't need to go to a website if something goes wrong. Same with this. If you're going to change things, TELL US! Put it in the update: This is changed, THIS is what to do about and oh, sorry for the inconvenience. What is so difficult about that?! The thing about geeks is they never seem to have PR skills, perhaps employing someone to do just this might help?!
jscher2000
  • Top 10 Contributor
8792 solutions 71899 answers

Hi trennor, if you can find and change a hidden setting for a half-working feature still under development, are you sure you aren't a geek, too? Anyway:

(1) To give feedback to Mozilla, you can use one or more of the following (depending on whether you want a suggestion box or a discussion):

(2) A good site to keep an eye on Firefox developments is Ghacks:

https://www.ghacks.net/category/firefox/

Hi trennor, if you can find and change a hidden setting for a half-working feature still under development, are you sure you aren't a geek, too? Anyway: (1) To give feedback to Mozilla, you can use one or more of the following (depending on whether you want a suggestion box or a discussion): * Feedback: https://qsurvey.mozilla.com/s3/FirefoxInput/ * Reddit: https://www.reddit.com/r/firefox/ * Twitter: https://twitter.com/firefox * Facebook: https://www.facebook.com/Firefox * Discourse: https://discourse.mozilla.org/c/firefox-development (2) A good site to keep an eye on Firefox developments is Ghacks: https://www.ghacks.net/category/firefox/
resucami2 0 solutions 9 answers

When I set media.autoplay.default to 1 videos don't start automatically anymore. However, when I quit and restart Firefox the setting is back to 0.

I kind of understand that the whole video play section is under development. However, I don't understand why it should not be possible to allow me to change settings permanently. What is the reason for this? Can this be fixed upfront, please?

When I set media.autoplay.default to 1 videos don't start automatically anymore. However, when I quit and restart Firefox the setting is back to 0. I kind of understand that the whole video play section is under development. However, I don't understand why it should not be possible to allow me to change settings permanently. What is the reason for this? Can this be fixed upfront, please?

Modified by resucami2

jscher2000
  • Top 10 Contributor
8792 solutions 71899 answers

Hi resucami2, I don't know why the change isn't sticking for you. Are you losing any other settings, or just this one? If the problem is more general, and/or to check for an optional user.js file, see: How to fix preferences that won't save.

Hi resucami2, I don't know why the change isn't sticking for you. Are you losing any other settings, or just this one? If the problem is more general, and/or to check for an optional '''user.js''' file, see: [[How to fix preferences that won't save]].
resucami2 0 solutions 9 answers

Thanks, jscher2000. Refreshing Firefox seems to have solved this issue.

Thanks, jscher2000. Refreshing Firefox seems to have solved this issue.
eddman 0 solutions 3 answers

@cor-el @jscher2000

Thanks for the detailed info. It's really interesting that you can actually make the autoplay settings show up in the permissions options.

Still, I wish they'd add an option to disable HTML5 Video itself, since disabling autoplay does not prevent videos from being loaded, slowing down the connection and wasting my monthly quota.

@cor-el @jscher2000 Thanks for the detailed info. It's really interesting that you can actually make the autoplay settings show up in the permissions options. Still, I wish they'd add an option to disable HTML5 Video itself, since disabling autoplay does not prevent videos from being loaded, slowing down the connection and wasting my monthly quota.
jscher2000
  • Top 10 Contributor
8792 solutions 71899 answers

eddman said

Still, I wish they'd add an option to disable HTML5 Video itself, since disabling autoplay does not prevent videos from being loaded, slowing down the connection and wasting my monthly quota.

You can disable the built-in player using a different group of preferences, but it's not on a site-by-site basis so you wouldn't have a convenient way to make exceptions for sites that you want to be able to play video. I think you would need an add-on to handle it on a site-by-site basis.

''eddman [[#answer-1183969|said]]'' <blockquote> Still, I wish they'd add an option to disable HTML5 Video itself, since disabling autoplay does not prevent videos from being loaded, slowing down the connection and wasting my monthly quota. </blockquote> You can disable the built-in player using a different group of preferences, but it's not on a site-by-site basis so you wouldn't have a convenient way to make exceptions for sites that you want to be able to play video. I think you would need an add-on to handle it on a site-by-site basis.
eddman 0 solutions 3 answers

jscher2000 said

You can disable the built-in player using a different group of preferences, but it's not on a site-by-site basis so you wouldn't have a convenient way to make exceptions for sites that you want to be able to play video. I think you would need an add-on to handle it on a site-by-site basis.

I can? I didn't know it was possible. I searched around a bit but couldn't find anything. To be honest I'm not that familiar with FF's hidden configs. Could you please post a link or explain how it's done?

I think it'd be fine. I'd enable it when needed, but if you do know an add-on please let me know. These random autoplaying videos, even on reputable news sites, are really starting to make me lose my composure.

EDIT: Apparently disabling autoplay has no effect on videos that start muted, an approach that most websites have cunningly adopted, so it's not that much of a help for my situation.

''jscher2000 [[#answer-1183971|said]]'' <blockquote> You can disable the built-in player using a different group of preferences, but it's not on a site-by-site basis so you wouldn't have a convenient way to make exceptions for sites that you want to be able to play video. I think you would need an add-on to handle it on a site-by-site basis. </blockquote> I can? I didn't know it was possible. I searched around a bit but couldn't find anything. To be honest I'm not that familiar with FF's hidden configs. Could you please post a link or explain how it's done? I think it'd be fine. I'd enable it when needed, but if you do know an add-on please let me know. These random autoplaying videos, even on reputable news sites, are really starting to make me lose my composure. EDIT: Apparently disabling autoplay has no effect on videos that start muted, an approach that most websites have cunningly adopted, so it's not that much of a help for my situation.

Modified by eddman

jscher2000
  • Top 10 Contributor
8792 solutions 71899 answers

eddman said

jscher2000 said
You can disable the built-in player using a different group of preferences, but it's not on a site-by-site basis so you wouldn't have a convenient way to make exceptions for sites that you want to be able to play video. I think you would need an add-on to handle it on a site-by-site basis.
I can? I didn't know it was possible. I searched around a bit but couldn't find anything. To be honest I'm not that familiar with FF's hidden configs. Could you please post a link or explain how it's done?

This is my old list for Windows. I haven't tested recently. Some preferences may be different on other platforms:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

WebM Formats

(2) In the search box above the list, type or paste webm and pause while the list is filtered

(3) If the media.mediasource.webm.enabled preference is true, double-click it to switch it to false

(4) Double-click the media.webm.enabled preference to switch it to false

Windows Media Foundation (for proprietary codecs)

(5) In the search box above the list, type or paste wmf and pause while the list is filtered

(6) Double-click the media.wmf.enabled preference to switch it to false

MP4 Formats (should already be blocked by #6, but...)

(7) In the search box above the list, type or paste mp4 and pause while the list is filtered

(8) Double-click the media.mediasource.mp4.enabled preference to switch it to false

(9) Double-click the media.mp4.enabled preference to switch it to false

MediaSource interface

(10) In the search box above the list, type or paste mediaso and pause while the list is filtered

(11) Double-click the media.mediasource.enabled preference to switch it to false

What about web audio?

That leaves OPUS and OGG enabled for audio purposes, but proprietary audio decoding probably will also be blocked.

''eddman [[#answer-1183978|said]]'' <blockquote> ''jscher2000 [[#answer-1183971|said]]'' <blockquote> You can disable the built-in player using a different group of preferences, but it's not on a site-by-site basis so you wouldn't have a convenient way to make exceptions for sites that you want to be able to play video. I think you would need an add-on to handle it on a site-by-site basis. </blockquote> I can? I didn't know it was possible. I searched around a bit but couldn't find anything. To be honest I'm not that familiar with FF's hidden configs. Could you please post a link or explain how it's done?</blockquote> This is my old list for Windows. I haven't tested recently. Some preferences may be different on other platforms: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. ''WebM Formats'' (2) In the search box above the list, type or paste '''webm''' and pause while the list is filtered (3) If the '''media.mediasource.webm.enabled''' preference is true, double-click it to switch it to false (4) Double-click the '''media.webm.enabled''' preference to switch it to false ''Windows Media Foundation (for proprietary codecs)'' (5) In the search box above the list, type or paste '''wmf''' and pause while the list is filtered (6) Double-click the '''media.wmf.enabled''' preference to switch it to false ''MP4 Formats (should already be blocked by #6, but...)'' (7) In the search box above the list, type or paste '''mp4''' and pause while the list is filtered (8) Double-click the '''media.mediasource.mp4.enabled''' preference to switch it to false (9) Double-click the '''media.mp4.enabled''' preference to switch it to false ''MediaSource interface'' (10) In the search box above the list, type or paste '''mediaso''' and pause while the list is filtered (11) Double-click the '''media.mediasource.enabled''' preference to switch it to false ''What about web audio?'' That leaves OPUS and OGG enabled for audio purposes, but proprietary audio decoding probably will also be blocked.