Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

FF 62.0.3 (64-bit) - Ramdomly Restoring Sessions, Private Mode Icon is gone, etc.

  • 6 replies
  • 3 have this problem
  • 35 views
  • Last reply by FredMcD

more options

Hi there!

I'm using Windows 10 Pro x64 (build 1803) with FF 62.0.3 (64-bit) and have noticed some weird things.

1) The browser sometimes wants to Restore Sessions, when nothing was wrong. 2) Sometimes I click on Private Mode and a regular browser window opens. 3) Sometimes I click on Private Mode and the Private mode Icon is gone from the top right.

Here's a picture... note the arrow in the upper right corner - no Private Mode Icon.

I uninstalled and reinstalled FF, keeping my existing profile but the browser is not quite stable.

Any definitive help appreciated!

TIA :)

Attached screenshots

Modified by Compumind

All Replies (6)

more options

Compumind said

1) The browser sometimes wants to Restore Sessions

You may have corrupt sessionstore [v56] sessionstore.jsonlz4 file(s). Delete all sessionstore* files and the sessionstore-backups folder.

Type about:support<enter> in the address bar.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Locate the above file. Then rename or delete it. Restart Firefox.


Don't delete the files if you need to rescue any data from them, just move them out of the profile folder to some location where Firefox doesn't look for them. You can try to read out their contents using this tool: https://www.jeffersonscher.com/res/scrounger.html

more options

Compumind said

2) Sometimes I click on Private Mode and a regular browser window opens.
3) Sometimes I click on Private Mode and the Private mode Icon is gone from the top right.

Let’s do a full clean re-install;

Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86)

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any Mozilla or Firefox program folders. Do not remove the Mozilla Thunderbird folder if there is one.

Do Not remove any profile folders.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

more options

Hi FredMcD -

Well this gets more interesting....

Just bought a new Dell Inspiron laptop running W10 Home, build 1803, x64 and I downloaded and installed the latest rev of FF 62.0.3 (64-bit).

Would you believe that I am having the exact symptoms on the new computer as well? The only software that I have added is the latest edition of Norton Security and for Firefox, the QuickCut add-on, YouTube High Definition and the Metal Paint theme.

Uninstalling the Firefox embellishments does not change anything.

Thoughts?

:)

Modified by Compumind

more options

Did you follow the instructions in my first post? https://support.mozilla.org/en-US/questions/1237106#answer-1163981

more options

FredMcD said

Did you follow the instructions in my first post? https://support.mozilla.org/en-US/questions/1237106#answer-1163981

Yes. The only item to delete was sessionstore-backups.

Next? :)

Modified by Compumind

more options

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


Check the startup option; Type about:preferences#general<enter> in the address bar.

There are two settings;

  • When Firefox Starts

When the browser is started, what do you want to display? Many of us choose Show My Home Page.

  • Home Page

When a new page is opened, what do you want to be displayed?

  1. Use Current Page. Use what ever page(s) are open at that time.
  2. Use Bookmark
  3. Restore To Default. about:home shows a Mozilla home page with tools.

You can use any of these that you wish;

about:home (Firefox default home page), about:newtab (shows the sites most visited), about:blank (a blank page),

or you can enter any webpage or about: page you want.