X
Tap here to go to the mobile version of the site.

Support Forum

Firefox is the only browser that doesn't render Google Map images, it needs to be programmed correctly.

Posted
Click any image on the left in this Google Map Images and it should show up in full on the right, but Alas, Firefox is the only browser that is incapable of rendering the image in full on the right hand side, what gives? https://www.google.com/maps/uv?hl=en&pb=!1s0x47e671d82c25eb2d%3A0xfa3666d653524ab6!2m21!8m3!7m2!3e2!4e34!16m16!1b1!2m2!1m1!1e1!2m2!1m1!1e3!2m2!1m1!1e6!2m2!1m1!1e4!2m2!1m1!1e5!3m1!7e115!4shttps%3A%2F%2Flh5.googleusercontent.com%2Fp%2FAF1QipOc-daI_ZTT_qgSnE8-LBkLt51db1nLZGJ9V1nI%3Dw311-h200-k-no!5sles%20deux%20magots%20paris%20-%20Google%20Search&imagekey=!1e10!2sAF1QipNqZBh4WZmpW20R4AnZvVscPyQd6x2Jg4ALPG6P&sa=X&ved=2ahUKEwi64KLsyNTdAhXimeAKHQjVC10QoiowDnoECAoQCQ&activetab=vibe See attached image
Attached screenshots

Chosen solution

Hi Fiascokid, that particular image uses Google's Street View viewer (scrolls 360 degrees), you can tell by the little circling arrow image at the lower left.

Does Street View work for you on Google maps? If not, possibly there is a WebGL issue on your Firefox, such as incompatibility with your graphics card driver software.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 31.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:62.0) Gecko/20100101 Firefox/62.0

More Information

Shadow110 1072 solutions 14836 answers

Helpful Reply

Hi, when you made the question you had a chance to share information. You decided not to. So now please Provide information.

What Extensions are you running ? (Menu--> add-ons)

What Security Software are you running please ?

I have no problem with the page, Please try in : SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Performance > Uncheck to view)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

Hi, when you made the question you had a chance to share information. You decided not to. So now please Provide information. What Extensions are you running ? (Menu--> add-ons) What Security Software are you running please ? I have no problem with the page, Please try in : SAFE MODE *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes In Firefox Safe mode these changes are effective: *all extensions are disabled (about:addons) *default theme is used (no persona) *userChrome.css and userContent.css are ignored (chrome folder) *default toolbar layout is used (file: localstore-safe.rdf) *Javascript JIT compilers are disabled (prefs: javascript.options.*jit) *hardware acceleration is disabled (Options > Performance > Uncheck to view) *plugins are not affected *preferences are not affected TEST'''''''''is issue still there ?

Question owner

Well something is not adding up, I refreshed Firefox and it didn't do the trick, I then uninstalled it completely with all of its registry entries and installed a brand new unmolested Firefox 62.0.2 with nothing added to it, not even bookmarks, and that too wouldn't work, so why do I need to have it in safe mode to view the images, my other two browsers work fine without this safe mode thing? As far as add on, I only have three; "uBlock Origin" which is disabled on all Google Sites, so that add on has no effect whatsoever, I also have "QuickCut" and "Web ScrapBook", but these two didn't exist when I refreshed and when I installed a brand new Firefox? Safe Mode must be disabling something else like a registry entry that is not part of Firefox to make it work, other than that, I do have an older portable version of Firefox (56) in a different drive. It too has same identical problem, and yet works fine in safe mode. This problem didn't exist 6 months ago if I recall! This is what I can confirm, disabling all add on, and theme, and the Chrome folder had no effect, Hardware Acceleration has always been disabled in my Firefox before baby Jesus was born. OK, now that I know Safe Mode works, I might be able to configure the solution and will get back to you soon.... Many Thanks, stand by...

Well something is not adding up, I refreshed Firefox and it didn't do the trick, I then uninstalled it completely with all of its registry entries and installed a brand new unmolested Firefox 62.0.2 with nothing added to it, not even bookmarks, and that too wouldn't work, so why do I need to have it in safe mode to view the images, my other two browsers work fine without this safe mode thing? As far as add on, I only have three; "uBlock Origin" which is disabled on all Google Sites, so that add on has no effect whatsoever, I also have "QuickCut" and "Web ScrapBook", but these two didn't exist when I refreshed and when I installed a brand new Firefox? Safe Mode must be disabling something else like a registry entry that is not part of Firefox to make it work, other than that, I do have an older portable version of Firefox (56) in a different drive. It too has same identical problem, and yet works fine in safe mode. This problem didn't exist 6 months ago if I recall! This is what I can confirm, disabling all add on, and theme, and the Chrome folder had no effect, Hardware Acceleration has always been disabled in my Firefox before baby Jesus was born. OK, now that I know Safe Mode works, I might be able to configure the solution and will get back to you soon.... Many Thanks, stand by...

Modified by Fiascokid

Shadow110 1072 solutions 14836 answers
Hi, it is probably the theme. https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
Pj 42 solutions 869 answers

Fiascokid said

OK, now that I know Safe Mode works, I might be able to configure the solution and will get back to you soon...

I just looked at it and it works fine with my FF 61.0.2 version. So, I don't think it's FF 62 unless others are having the same problem widespread. Something at your end, I suppose, since you have it working in Safe Mode.

~Pj

''Fiascokid [[#answer-1158339|said]]'' <blockquote> OK, now that I know Safe Mode works, I might be able to configure the solution and will get back to you soon... </blockquote> I just looked at it and it works fine with my FF 6'''1'''.0.2 version. So, I don't think it's FF 62 unless others are having the same problem widespread. Something at your end, I suppose, since you have it working in Safe Mode. ~Pj
cor-el
  • Top 10 Contributor
  • Moderator
17569 solutions 158915 answers

The large images are drawn on canvas.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content.

Firefox shows the shield icon at the left end of the location/address bar in case content is blocked by Tracking Protection.

The large images are drawn on canvas. If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content. *make sure your extensions and filters are updated to the latest version *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems Firefox shows the shield icon at the left end of the location/address bar in case content is blocked by Tracking Protection. *click the shield icon for more detail and possibly disable the protection *You can check the Web Console by Tracking Protection *"3-bar" menu button or Tools -> Web Developer *https://support.mozilla.org/en-US/kb/tracking-protection-firefox

Question owner

It is none of these issues for the simple reason, I installed a brand new virgin Firefox with no add on and no theme, with absolutely nothing added to it and yet the problem persisted. Conclusion: Simply put it is a configuration I added to both Firefox browser in the About:Config (or in the registry) and when I uninstall either or both browsers, this entry seems to resides in the registry, it will take me sometimes to find it and when I do, I will get back to you all, sorry for the delay, but it won't happen any time soon, thanks for the feedback though. P.S. It may have been affected by an update, I will resolve it one way or another.

It is none of these issues for the simple reason, I installed a brand new virgin Firefox with no add on and no theme, with absolutely nothing added to it and yet the problem persisted. Conclusion: Simply put it is a configuration I added to both Firefox browser in the About:Config (or in the registry) and when I uninstall either or both browsers, this entry seems to resides in the registry, it will take me sometimes to find it and when I do, I will get back to you all, sorry for the delay, but it won't happen any time soon, thanks for the feedback though. P.S. It may have been affected by an update, I will resolve it one way or another.

Modified by Fiascokid

cor-el
  • Top 10 Contributor
  • Moderator
17569 solutions 158915 answers

You can check the Web Console to see if there are messages about blocked content.

You can check the Web Console to see if there are messages about blocked content. *"3-bar" menu button or Tools -> Web Developer *https://developer.mozilla.org/en-US/Tools/Web_Console

Question owner

See Below

See Below

Modified by Fiascokid

Question owner

Everyone Please Relax The problem, there is no problem, boy scout honor! Firefox works with similar sites fine, I opened same site with Google Chromium and it didn't work either, only I.E. rendered it correctly. I then tried to open a similar site with Firefox 62 and it worked fine, so the glitch must be in the HTML script, some sites are just not compatible with Firefox, they are few and far in between, conclusion, in life poop happens. Here is the proof, this site opens fine with Firefox and reading its hieroglyph is no sweat, honesty the truth, try it yourself: Google Maps

'''Everyone Please Relax''' The problem, '''''there is no problem''''', boy scout honor! Firefox works with similar sites fine, I opened same site with Google Chromium and it didn't work either, only I.E. rendered it correctly. I then tried to open a similar site with Firefox 62 and it worked fine, so the glitch must be in the HTML script, some sites are just not compatible with Firefox, they are few and far in between, conclusion, in life poop happens. Here is the proof, this site opens fine with Firefox and reading its hieroglyph is no sweat, honesty the truth, try it yourself: [https://www.google.com/maps/place/Cairo,+Cairo+Governorate,+Egypt/@29.9757265,31.1308001,3a,75y,90t/data=!3m8!1e2!3m6!1sAF1QipOKCAmCJ8lA-V6P3--UXBnFcSOm92zXIrBwMD0v!2e10!3e12!6shttps:%2F%2Flh5.googleusercontent.com%2Fp%2FAF1QipOKCAmCJ8lA-V6P3--UXBnFcSOm92zXIrBwMD0v%3Dw203-h135-k-no!7i3000!8i1998!4m5!3m4!1s0x14583fa60b21beeb:0x79dfb296e8423bba!8m2!3d30.0444196!4d31.2357116 Google Maps]
jscher2000
  • Top 10 Contributor
8787 solutions 71865 answers

Chosen Solution

Hi Fiascokid, that particular image uses Google's Street View viewer (scrolls 360 degrees), you can tell by the little circling arrow image at the lower left.

Does Street View work for you on Google maps? If not, possibly there is a WebGL issue on your Firefox, such as incompatibility with your graphics card driver software.

Hi Fiascokid, that particular image uses Google's Street View viewer (scrolls 360 degrees), you can tell by the little circling arrow image at the lower left. Does Street View work for you on Google maps? If not, possibly there is a WebGL issue on your Firefox, such as incompatibility with your graphics card driver software.

Question owner

You my friend need to fix your Firefox, J.K. The site you were looking at should have an image of the Sphinx. Now if you are referring to a street view like this one (see attached image), then yes I do have it, but I have to choose it among few other choices.

You my friend need to fix your Firefox, J.K. The site you were looking at should have an image of the Sphinx. Now if you are referring to a street view like this one (see attached image), then yes I do have it, but I have to choose it among few other choices.

Question owner

OK, now I see the problem the 360° Viewer is not present in some sites, yet present in others, both my Chromium and Firefox show same identical symptoms on the very same sites but not I.E., the latter renders these sites correctly, I sent a complain to Google let's see if they reply, they usually do. Thanks, I will deal with it from here. I believe we are all set with this issue.

OK, now I see the problem the 360° Viewer is not present in some sites, yet present in others, both my Chromium and Firefox show same identical symptoms on the very same sites but not I.E., the latter renders these sites correctly, I sent a complain to Google let's see if they reply, they usually do. Thanks, I will deal with it from here. I believe we are all set with this issue.

Question owner

cor-el said

You can check the Web Console to see if there are messages about blocked content.

The above solution does give me an error, but unreadable and unworkable with a lot of gobbledygook extraterrestrial characters, if I expand on it, OMG... Not a practical solution, see image attached. Thanks for trying though...

''cor-el [[#answer-1158407|said]]'' <blockquote> You can check the Web Console to see if there are messages about blocked content. *"3-bar" menu button or Tools -> Web Developer *https://developer.mozilla.org/en-US/Tools/Web_Console </blockquote> The above solution does give me an error, but unreadable and unworkable with a lot of gobbledygook extraterrestrial characters, if I expand on it, OMG... Not a practical solution, see image attached. Thanks for trying though...
jscher2000
  • Top 10 Contributor
8787 solutions 71865 answers

Fiascokid said

The site you were looking at should have an image of the Sphinx.

I loaded and panned around an interior scene you linked to originally. The faces were blurred, but I believe they were humans and not mythical animals.

EDIT: Adding attachment showing the image I'm talking about.

''Fiascokid [[#answer-1158454|said]]'' <blockquote> The site you were looking at should have an image of the Sphinx. </blockquote> I loaded and panned around an interior scene you linked to originally. The faces were blurred, but I believe they were humans and not mythical animals. '''EDIT: Adding attachment showing the image I'm talking about.'''

Modified by jscher2000

Question owner

Your created a confusion, not all the images in that site have 360° Rotational view, some do and some don't, see attached image, you claimed the Sphinx does and it doesn't have that option, it can't be rotated by any browser, period. I don't know about mythical creatures, the Sphinx has the head of a human and the body of a lion, the Arabs called him "The father of all terrors" and so a moron doctor broke his nose off in the process of destroying it with a chisel, poor Sphinx. Napoleon soldiers used the Sphinx as a shooting target, it is more likely to be 7,500 years old statue, so some archeologists claim, the head of the lion was re-curved as the head of pharaoh Khafre (which is questionable) around 4,500 years ago (probably as a symbol of power, as you know lions are truly the kings of the jungle, or should we say Pharaohs of the jungle?). There are plenty of evidences to support this claim.

Your created a confusion, not all the images in that site have 360° Rotational view, some do and some don't, see attached image, you claimed the Sphinx does and it doesn't have that option, it can't be rotated by any browser, period. I don't know about mythical creatures, the Sphinx has the head of a human and the body of a lion, the Arabs called him "The father of all terrors" and so a moron doctor broke his nose off in the process of destroying it with a chisel, poor Sphinx. Napoleon soldiers used the Sphinx as a shooting target, it is more likely to be 7,500 years old statue, so some archeologists claim, the head of the lion was re-curved as the head of pharaoh Khafre (which is questionable) around 4,500 years ago (probably as a symbol of power, as you know lions are truly the kings of the jungle, or should we say Pharaohs of the jungle?). There are plenty of evidences to support this claim.
jscher2000
  • Top 10 Contributor
8787 solutions 71865 answers

Hi Fiascokid, you mischaracterized my comments, which were about your original link. I attached a screenshot to my last reply showing the results of your original link. Your original link, not your later one. Original. No Sphinx to be seen.

Anyway, if you notice problems with regular photos, non-360 degree photos, that would be a different issue than the one I was mentioning.

Hi Fiascokid, you mischaracterized my comments, which were about your original link. I attached a screenshot to my last reply showing the results of your original link. Your original link, not your later one. Original. No Sphinx to be seen. Anyway, if you notice problems with regular photos, non-360 degree photos, that would be a different issue than the one I was mentioning.

Question owner

You are correct with the last reply, but I am referring to your earlier reply when I was frantically trying to fix the problem, I sent you this site and no other link text

which should have landed you directly on the Sphinx image with no rotational option, yet this was your reply in reference to t his image (see below), which meant this sphinx image must have a rotational option which caused quite a confusion from my end while I am having serious problem fixing FF.

This is your comment in reference to the Sphinx image: Hi Fiascokid, that particular image uses Google's Street View viewer (scrolls 360 degrees), you can tell by the little circling arrow image at the lower left. NO IT DOESN'T, SORRY, WRONG & CONFUSING INSTRUCTION and wrong image. Do you see the words (That particular image? meaning the Sphinx Image, that is how anyone would understand it). If you were trying to refer to Paris earlier picture, then you should have indicated it but you didn't, because that comment came after the Sphinx image not Paris St. Germain image, yes it did cause confusion, I just couldn't rotate the Sphinx image with any browser. C'est La Vie as the French would say. Sorry to hurt your feelings, I don't know how to express it otherwise, it did cause confusion on my end, I thought my Firefox is totally fucked up.

You are correct with the last reply, but I am referring to your earlier reply when I was frantically trying to fix the problem, I sent you this site and no other [https://www.google.com/maps/place/Cairo,+Cairo+Governorate,+Egypt/@29.9757265,31.1308001,3a,75y,90t/data=!3m8!1e2!3m6!1sAF1QipOKCAmCJ8lA-V6P3--UXBnFcSOm92zXIrBwMD0v!2e10!3e12!6shttps:%2F%2Flh5.googleusercontent.com%2Fp%2FAF1QipOKCAmCJ8lA-V6P3--UXBnFcSOm92zXIrBwMD0v%3Dw203-h135-k-no!7i3000!8i1998!4m5!3m4!1s0x14583fa60b21beeb:0x79dfb296e8423bba!8m2!3d30.0444196!4d31.2357116 link text] which should have landed you directly on the Sphinx image with no rotational option, yet this was your reply in reference to t his image (see below), which meant this sphinx image must have a rotational option which caused quite a confusion from my end while I am having serious problem fixing FF. This is your comment in reference to the Sphinx image: Hi Fiascokid, that particular image uses Google's Street View viewer (scrolls 360 degrees), you can tell by the little circling arrow image at the lower left. '''NO IT DOESN'T, SORRY, WRONG & CONFUSING INSTRUCTION and wrong image.''' Do you see the words (That particular image? meaning the Sphinx Image, that is how anyone would understand it). If you were trying to refer to Paris earlier picture, then you should have indicated it but you didn't, because that comment came after the Sphinx image not Paris St. Germain image, yes it did cause confusion, I just couldn't rotate the Sphinx image with any browser. C'est La Vie as the French would say. Sorry to hurt your feelings, I don't know how to express it otherwise, it did cause confusion on my end, I thought my Firefox is totally fucked up.
jscher2000
  • Top 10 Contributor
8787 solutions 71865 answers

I was replying to the post you deleted and replaced with the test "See Below", not your Sphinx photo post. Apologies for the confusion, but you snuck that new one in there and edited out the other text while I was working on my reply and I wasn't expecting that. That I why I referred to your original screenshot with the white circling arrow:

https://prod-cdn.sumo.mozilla.net/uploads/images/2018-09-24-15-55-17-6042cd.png

I was replying to the post you deleted and replaced with the test "See Below", not your Sphinx photo post. Apologies for the confusion, but you snuck that new one in there and edited out the other text while I was working on my reply and I wasn't expecting that. That I why I referred to your original screenshot with the white circling arrow: https://prod-cdn.sumo.mozilla.net/uploads/images/2018-09-24-15-55-17-6042cd.png

Question owner

Mr. Jscher2000, the text I deleted was in reply to the contributor Pkshadow who still has the best solution (which is safe Mode), and the follow up text which you claimed was snicked in was actually typed simultaneously along with the first just a couple of minutes or so later. Here is the irony of it all, this confusion made me realize not every site is compatible with Firefox, in essence your confusion resolved the issue I was having without fixing anything. So I credited you with the best answer, I think I was fair. can we now put it to rest. Moral of the story, you need more than one browser to roam the WWW, and that is the absolute and correct answer, because no matter what, some sites can't be rendered correctly with this version or that version of any browser, Amen.

Mr. Jscher2000, the text I deleted was in reply to the contributor Pkshadow who still has the best solution (which is safe Mode), and the follow up text which you claimed was snicked in was actually typed simultaneously along with the first just a couple of minutes or so later. Here is the irony of it all, this confusion made me realize not every site is compatible with Firefox, in essence your confusion resolved the issue I was having without fixing anything. So I credited you with the best answer, I think I was fair. can we now put it to rest. Moral of the story, you need more than one browser to roam the WWW, '''and that is the absolute and correct answer''', because no matter what, some sites can't be rendered correctly with this version or that version of any browser, Amen.