X
Tap here to go to the mobile version of the site.

Support Forum

canot use google search I get SEC_ERROR_BAD_SIGNATURE

Posted

I can not open google search engine, or other webpages I get SEC_ERROR_BAD_SIGNATURE Hoe do I fix it?

I can not open google search engine, or other webpages I get SEC_ERROR_BAD_SIGNATURE Hoe do I fix it?

Chosen solution

HI, please try this : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 62.0.0 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

Read this answer in context 0
Shadow110 1072 solutions 14836 answers

Hi, sorry to hear that, please see : https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can and https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware

If you are using a Proxy or a VPN please turn off or check your connection set up. Note some Security Programs can cause connection issues also : Avast/AVG, Kaspersky, BitDefender and ESET and sometimes McAfee.

You did not share information when making your question so I have no information on your Extensions/add-ons that could possibly cause the issue. Please Test : SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Performance > Uncheck to view)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

Hi, sorry to hear that, please see : https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can and https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware If you are using a Proxy or a VPN please turn off or check your connection set up. Note some Security Programs can cause connection issues also : Avast/AVG, Kaspersky, BitDefender and ESET and sometimes McAfee. You did not share information when making your question so I have no information on your Extensions/add-ons that could possibly cause the issue. Please Test : SAFE MODE *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes In Firefox Safe mode these changes are effective: *all extensions are disabled (about:addons) *default theme is used (no persona) *userChrome.css and userContent.css are ignored (chrome folder) *default toolbar layout is used (file: localstore-safe.rdf) *Javascript JIT compilers are disabled (prefs: javascript.options.*jit) *hardware acceleration is disabled (Options > Performance > Uncheck to view) *plugins are not affected *preferences are not affected TEST'''''''''is issue still there ?

Question owner

I tried all the links you send to me. They do NOT OPEN. In all of them I got the same message Secure Connection Failed

An error occurred during a connection to www.google.com. Peer’s certificate has an invalid signature. Error code: SEC_ERROR_BAD_SIGNATURE

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

I did try also safe mode. It didn't help. Same thing. Many other sites do not open either.

This did happen after the last up-date of windows. Could be windows blocking google search and other sites ? gmail works fine!!!

I tried all the links you send to me. They do NOT OPEN. In all of them I got the same message Secure Connection Failed An error occurred during a connection to www.google.com. Peer’s certificate has an invalid signature. Error code: SEC_ERROR_BAD_SIGNATURE The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem. I did try also safe mode. It didn't help. Same thing. Many other sites do not open either. This did happen after the last up-date of windows. Could be windows blocking google search and other sites ? gmail works fine!!!
Shadow110 1072 solutions 14836 answers

Chosen Solution

HI, please try this : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 62.0.0 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

HI, please try this : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 62.0.0 with a Full Version Installer *https://www.mozilla.org/firefox/all/ Please let us know if this solved your issue or if need further assistance.

Question owner

Thank you so much

Thank you so much