X
Tap here to go to the mobile version of the site.

Support Forum

multiple instances of firefox.exe in task manager

Posted

hello,

I noticed recently that there are multiple instances of firefox.exe running in task manager, at the moment I have 7 tabs open in firefox and there are 7 instances in task manager. I tried going to 'about:config' and setting 'browser.tabs.remote.autostart.2' to false but this didn't make any difference. I had some problems with firefox crashing often, and was worried that there might be a problem

Any advice appreciated

hello, I noticed recently that there are multiple instances of firefox.exe running in task manager, at the moment I have 7 tabs open in firefox and there are 7 instances in task manager. I tried going to 'about:config' and setting 'browser.tabs.remote.autostart.2' to false but this didn't make any difference. I had some problems with firefox crashing often, and was worried that there might be a problem Any advice appreciated

Additional System Details

Installed Plug-ins

  • Shockwave Flash 29.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

More Information

Scribe 725 solutions 3456 answers

Hi, you can try reducing the number of processes: Go to the 3-bar menu > Options (General) - Performance, then deselect 'Use recommended performance settings' and change 'Content process limit' to 1 or 2. See - Firefox's performance settings, and Startup, home page, tabs, and download settings.

Whilst in the 3-bar menu, you can also go to Options (Privacy & Security) - Permissions, and tick/check 'Prevent accessibility services from accessing your browser' then restart Firefox. More - What is the Accessibility Service Indicator?

This shouldn't be necessary unless you have very limited RAM, but if you wish, you can try turning off Multiprocess altogether: Type about:config into the address bar, press Enter, accept the warning, scroll down the alphabetical list to browser.tabs.remote.autostart and browser.tabs.remote.autostart.2 then double click on each to change 'Value' from True to False and restart Firefox.

If you need help with crashes, please follow the steps below to provide us crash IDs to help us learn more about your crash.

The crash report is several pages of data. We need the report numbers to see the whole report.

  1. Enter about:crashes in the Firefox address bar and press Enter. A Submitted Crash Reports list will appear, similar to the one shown below.
  2. Copy the 5 most recent Report IDs that start with bp- and then go back to your forum question and paste those IDs into the "Post a Reply" box.

Note: If a recent Report ID does not start with bp- click on it to submit the report.

(Please don't take a screenshot of your crashes, just copy and paste the IDs. The below image is just an example of what your Firefox screen should look like.)

aboutcrashesFx57

More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you!

Hi, you can try reducing the number of processes: Go to the 3-bar menu > Options (General) - Performance, then deselect 'Use recommended performance settings' and change 'Content process limit' to 1 or 2. See - [[Firefox's performance settings]], and [[Startup, home page, tabs, and download settings]]. Whilst in the 3-bar menu, you can also go to Options (Privacy & Security) - Permissions, and tick/check 'Prevent accessibility services from accessing your browser' then restart Firefox. More - [[What is the Accessibility Service Indicator?]] This shouldn't be necessary unless you have very limited RAM, but if you wish, you can try turning off Multiprocess altogether: Type '''about:config''' into the address bar, press Enter, accept the warning, scroll down the alphabetical list to '''browser.tabs.remote.autostart''' and '''browser.tabs.remote.autostart.2''' then double click on each to change 'Value' from True to False and '''restart Firefox.''' If you need help with crashes, please follow the steps below to provide us crash IDs to help us learn more about your crash. '''The crash report is several pages of data.''' '''We need the report numbers to see the whole report.''' #Enter ''about:crashes'' in the Firefox address bar and press Enter. A Submitted Crash Reports list will appear, similar to the one shown below. #Copy the '''5''' most recent Report IDs that start with '''bp-''' and then go back to your forum question and paste those IDs into the "Post a Reply" box. ''' Note:''' If a recent Report ID does not start with '''bp-''' click on it to submit the report. (Please don't take a screenshot of your crashes, just copy and paste the IDs. The below image is just an example of what your Firefox screen should look like.) ;[[Image:aboutcrashesFx57|width=500]] More information and further troubleshooting steps can be found in the [[Firefox crashes - Troubleshoot, prevent and get help fixing crashes]] article. ''If your question is resolved by this or another answer, please take a minute to let us know. Thank you!''

Modified by Scribe

FFus3r 50 solutions 757 answers
see this answer https://support.mozilla.org/en-US/questions/1223605#answer-1127524
cor-el
  • Top 10 Contributor
  • Moderator
17467 solutions 157849 answers

It is quite normal to see three or more Firefox processes running.

  • one process for the main Firefox thread (user interface)
  • one or more content processes set via dom.ipc.processCount
    Options/Preferences -> General -> Performance
    remove checkmark: [ ] "Use recommended performance settings"
  • one process for the compositor thread (Windows;graphics)

You can find the current multi-process state on the Troubleshooting Information (about:support) page.

  • "Help -> Troubleshooting Information" -> "Application Basics":
    Multiprocess Windows
    Web Content Processes
It is quite normal to see three or more Firefox processes running. *one process for the main Firefox thread (user interface) *one or more content processes set via dom.ipc.processCount<br>Options/Preferences -> General -> Performance<br>remove checkmark: [ ] "Use recommended performance settings" *one process for the compositor thread (Windows;graphics) You can find the current multi-process state on the Troubleshooting Information (about:support) page. *"Help -> Troubleshooting Information" -> "Application Basics":<br>Multiprocess Windows<br>Web Content Processes

Question owner

thanks for your replies, I since changed the settings in about:config for both browser.tabs.remote.autostart and browser.tabs.remote.autostart.2 , I set them both to false and now I see only one instance of firefox.exe in task manager. Also now I haven't had any crashes since :) so for now the problem is solved

Regards

Mike

thanks for your replies, I since changed the settings in '''about:config''' for both '''browser.tabs.remote.autostart''' and '''browser.tabs.remote.autostart.2 ''', I set them both to false and now I see only one instance of firefox.exe in task manager. Also now I haven't had any crashes since :) so for now the problem is solved Regards Mike

Modified by Spikey020

Bud 0 solutions 14 answers

I have this never-ending dilemma, too. I'm running 'Firefox Quantum' on a Toshiba Laptop with an 'i7 3630QM @ 2.40GHz processor and 8.00GB Dual-Channel DDR3 @ 798MHz'.

As I am entering comments in a textbox (Email, FB, or this comment box) a new instance of Firefox browser starts on some page I may have visited 3 years ago and hijacks the focus from my current page stopping my text input. It is quite maddening! Usually, it is only 2 or 3 instances, but sometimes 8 or 10.

I do not fiddle with the Firefox settings so I don't believe that is the problem. Of course, in today's world God only knows what virus or malware does what to your settings!

Why must Firefox need a workaround to fix this "Phantom?"

I have this never-ending dilemma, too. I'm running ''''''Firefox Quantum'''''' on a Toshiba Laptop with an ''''''i7 3630QM @ 2.40GHz processor and 8.00GB Dual-Channel DDR3 @ 798MHz'''.''' As I am entering comments in a textbox (Email, FB, or this comment box) a new instance of Firefox browser starts on some page I may have visited 3 years ago and hijacks the focus from my current page stopping my text input. It is quite maddening! Usually, it is only 2 or 3 instances, but sometimes 8 or 10. I do not fiddle with the Firefox settings so I don't believe that is the problem. Of course, in today's world God only knows what virus or malware does what to your settings! Why must Firefox need a workaround to fix this "Phantom?"