Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Blue Overlay on Firefox Toolbars, Tabs. Menus, Etc after Update to v62

  • 13 replies
  • 1 has this problem
  • 39 views
  • Last reply by jscher2000

more options

A transparent blue overlay appears on all Firefox Toolbars, Tabs. Menus, Settings Pages, etc - but not on actual web pages which display fine.

This happened immediately after the Update to v62.

The effect looks a bit like when you select a page in windows and it's highlighted in blue. The text on the active tab is also blurred but is sharp on the other tabs.

I've tried restarting browser and computer, changed the theme (back to default) and disabled anti-virus (AVG) but it hasn't solved the problem.

I have screenshots but I can't get them to upload.

Thanks, G

All Replies (13)

more options

upload the screenshots on other site and put it here.

more options

Here are the screenshots.

more options

thank you for those screenshots - something's definitely off here. can you try to replicate this behaviour when you launch firefox in safe mode once?

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

more options

Hello,

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

more options

Ok, Starting Firefox in safe mode does solve the problem.

But restarting and working through all the troubleshooting options doesn't work.

I now have the default theme set, all extensions and plugins disabled and hardware acceleration disabled but I still have the problem. So logically, safe mode must be changing or turning off something else I'm not aware of.

more options

it is not being caused by an extension or theme.

check your settings, see if you change something accidentally.

more options

Are you using a lightweight theme top style the user interface area?

You can check the Theme settings in the Customize palette window.

more options

or it might be due to a userChrome.css file in your profile folder...

more options

I shouldn't have changed anything accidentally because the problem just appeared as soon as Firefox restarted after the update.

It might be a previous setting in about:config that's not compatible with the update. There's about 800 settings flagged as modified in about:config but I've only changed a few directly, I'll have to try and remember which ones.

Do you know if safe mode actually overrides the settings in about:config before I start changing things?

more options

yes safe mode resets some settings ,

and disables add-ons (extensions and themes) that might be causing problems. By comparing Firefox behavior in normal mode to its behavior in Safe Mode you may be able to pinpoint the cause of the problem

more options

gp238 said

Do you know if safe mode actually overrides the settings in about:config before I start changing things?

I can't think of any appearance-related preferences in about:config that would be ignored in Firefox's Safe Mode.

As mentioned before, do you use any custom style rules in a userChrome.css file? Firefox's Safe Mode ignores that file.

more options

Got it!

It was a specific colour management setting in about:config. My settings were as per the attached screenshot.

I changed the 'gfx.color_management.mode' value back to '2' (the default value) and this solved the problem. The other settings are fine.

FYI the reason I changed it in the first place was to colour manage all images. The values for this setting correspond to: 0 - Disable color management. 1 - Enable color management for all rendered graphics. (Recommended) 2 - Enable color management only for tagged images only. (Default)

Hope this is tweaked in a future update. As far as I can tell most imaging professionals think setting 1 should be the default, this is how colour management is implemented in other browsers apparently.

Thank you everybody for your very prompt help, I really appreciate it.

G

more options

Ohhh. I wonder what all needs to be set to cause this.

Do you have a custom monitor profile?

I notice you have "gfx.color_management.rendering_intent" set to 1. Does the default value also generate this problem: https://developer.mozilla.org/docs/Mozilla/Firefox/Releases/3.5/ICC_color_correction_in_Firefox

If your combination of settings is good for web content, maybe there should be a separate preference for color management of the UI.