X
Tap here to go to the mobile version of the site.

Support Forum

Weird behaviour of SHIFT

Posted

Whenever I press SHIFT in twitter message form, or on forms of some other sites (but not in this form), I get weird behaviour, like:

  • removal of the previous symbol, or
  • acts like i pressed HOME, or
  • does not type the symbol at all.

GIFs are attached (in twitter):

  • in one of them I literally type <write SHIFT> but get only <write F>
  • in another I type <press """"">

(ignore symbols < and >)

This behaviour is in *safe* mode already. Related is this unanswered reddit thread: https://www.reddit.com/r/firefox/comments/7jdmll/firefox_57_issue_shift_key_deleting_text/

Chrome works perfectly; ~one year ago, firefox worked perfectly.

Firefox Quantum 61.0.1 (64-bit), Ubuntu 16.04, T420 thinkpad laptop.

Whenever I press SHIFT in twitter message form, or on forms of some other sites (but not in this form), I get weird behaviour, like: * removal of the previous symbol, or * acts like i pressed HOME, or * does not type the symbol at all. GIFs are attached (in twitter): * in one of them I literally type <write SHIFT> but get only <write F> * in another I type <press """""> (ignore symbols < and >) This behaviour is in *safe* mode already. Related is this unanswered reddit thread: https://www.reddit.com/r/firefox/comments/7jdmll/firefox_57_issue_shift_key_deleting_text/ Chrome works perfectly; ~one year ago, firefox worked perfectly. Firefox Quantum 61.0.1 (64-bit), Ubuntu 16.04, T420 thinkpad laptop.
Attached screenshots

Modified by ayrat

Additional System Details

Application

  • Firefox 61.0.1
  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
  • Support URL: https://support.mozilla.org/1/firefox/61.0.1/Linux/en-US/

Extensions

  • DuckDuckGo Privacy Essentials 2018.8.9 (jid1-ZAdIEUB7XOzOJw@jetpack) (Inactive)
  • Google Translator for Firefox 3.0.3.1 (translator@zoli.bod) (Inactive)
  • Omnibar 0.7.28.20141004.1-signed.1-signed (omnibar@ajitk.com) (Inactive)
  • pwgen - Password Generator 0.5.2.1-signed.1-signed (pwgen@alouche.net) (Inactive)
  • uBlock Origin 1.16.16 (uBlock0@raymondhill.net) (Inactive)
  • VimFx 0.20.10 (VimFx@akhodakivskiy.github.com) (Inactive)
  • Vimium 1.63.3 ({d7742d87-e61d-4b78-b8a1-b469842139fa}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) Sandybridge Mobile
  • adapterDeviceID: Mesa DRI Intel(R) Sandybridge Mobile
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • contentUsesTiling: False
  • crashGuards: []
  • driverDate:
  • driverVersion: 3.0 Mesa 18.0.5
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'blocked', u'message': u'Acceleration blocked by platform', u'type': u'default'}, {u'status': u'blocked', u'message': u'Acceleration blocked by safe-mode', u'type': u'runtime'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u"Build doesn't include WebRender", u'type': u'runtime'}], u'name': u'WEBRENDER'}, {u'status': u'blocked', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}, {u'status': u'blocked', u'message': u'OMTP blocked by safe-mode', u'type': u'runtime'}], u'name': u'OMTP'}]}
  • info: {u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'CairoUseXRender': 0, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 2
  • offMainThreadPaintEnabled: False
  • offMainThreadPaintWorkerCount: 0
  • usesTiling: False
  • webgl1DriverExtensions: -
  • webgl1Extensions: -
  • webgl1Renderer: WebGL is currently disabled.
  • webgl1Version: -
  • webgl1WSIInfo: -
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL is currently disabled.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17670 solutions 159841 answers

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution. *https://www.mozilla.org/en-US/firefox/all/

Question owner

As I wrote in the original post, I tried the safe mode.

I just now tried the default theme (in safe mode) and a latest version from the server you mentioned.

The same problem.

I also tried a new keyboard, the problem persists.

As I wrote in the original post, I tried the safe mode. I just now tried the default theme (in safe mode) and a latest version from the server you mentioned. The same problem. I also tried a new keyboard, the problem persists.
McCoy
  • Top 10 Contributor
572 solutions 5338 answers

Too bad that SHIFT works fine in Chrome, otherwise we could blame it on your device (not necessarily the keyboard, but the motherboard) .....

See these search results

Question : Does SHIFT behave the same way on the on-screen keyboard  ?

Too bad that SHIFT works fine in Chrome, otherwise we could blame it on your device (not necessarily the keyboard, but the motherboard) ..... See [https://www.google.nl/search?authuser=0&ei=p55-W4ODN9LKwAKf84LoBw&q=in+firefox%3A++problems+with+the+SHIFT+key+on+T420+thinkpad+laptop&oq=in+firefox%3A++problems+with+the+SHIFT+key+on+T420+thinkpad+laptop&gs_l=psy-ab.3...88024.93630.0.94993.23.21.0.0.0.0.140.1499.20j1.21.0....0...1c.1.64.psy-ab..5.9.703...33i160k1j35i39k1.0.KE_FgpeinUk these search results] Question : Does SHIFT behave the same way on the on-screen keyboard ?

Question owner

Thanks for reply. Yes, on-screen keyboard produces the same results. Just recorded the video of the twitter form. The same for right-shift. CAPS lock works as expected.

Thanks for reply. Yes, on-screen keyboard produces the same results. Just recorded the video of the twitter form. The same for right-shift. CAPS lock works as expected.

Modified by ayrat