X
Tap here to go to the mobile version of the site.

Support Forum

Quantum takes all my RAM and only releases it after crashing

Posted

I am regularly suffering from this issue where Quantum grinds to a halt and crashes after a few minutes (5 to 10 mins).

Whilst viewing the Processes tab in Windows Task Manager I have found that I have 7 entries of firefox.exe whilst having 9 tabs open in the browser.

As an example, whilst viewing ebay, carrying out a search and then looking at further pages, clicking back a page and then looking at another entry I find that the CPU increases from 2 or 3% to 50%, but the memory changes from 115,000k to over 3,000,000k. Only 1 tab shows the increased usage all the other remain relatively static. However I have opened Firefox with just one tab and had exactly the same issue.

Even as I write this question the memory has gone up to 3,150,256k and I am waiting to type further text but the memory has gone again. After 4 minutes of doing nothing it has has it dropped back to 150,552k and hopefully I will be able to finish this question before it crashes again.

I occassionally have a small Excel file open as well, but once Firefox starts using up the memory Excel crashes as the computer tries to close programs to give more memory to Firefox.

If I leave Firefox open, but not use it for about 20 minutes it seems to give back the memory, but within 5 minutes of using it again it is back up to 3,000,000k or above.

I used to be able to use Firefox whilst having other programs open at the same time, such as Photoshop CS5, Illustrator CS5, Thunderbird, Excel and Word, but since upgrading to Quantum I cannot have any other program open in the background. In fact all these programs work fine, even with all of them open at the same time until I open my browser.

The problem started with Quantum as I have not had the same issue with previous versions of Firefox.

I am using Firefox version 61.0.2 (64 bit) on Windows 7 with 4GB Ram.

I have added a couple of images to show the errors/memory issues.

Does anybody have any suggestions how to solve the problem?

I am regularly suffering from this issue where Quantum grinds to a halt and crashes after a few minutes (5 to 10 mins). Whilst viewing the Processes tab in Windows Task Manager I have found that I have 7 entries of firefox.exe whilst having 9 tabs open in the browser. As an example, whilst viewing ebay, carrying out a search and then looking at further pages, clicking back a page and then looking at another entry I find that the CPU increases from 2 or 3% to 50%, but the memory changes from 115,000k to over 3,000,000k. Only 1 tab shows the increased usage all the other remain relatively static. However I have opened Firefox with just one tab and had exactly the same issue. Even as I write this question the memory has gone up to 3,150,256k and I am waiting to type further text but the memory has gone again. After 4 minutes of doing nothing it has has it dropped back to 150,552k and hopefully I will be able to finish this question before it crashes again. I occassionally have a small Excel file open as well, but once Firefox starts using up the memory Excel crashes as the computer tries to close programs to give more memory to Firefox. If I leave Firefox open, but not use it for about 20 minutes it seems to give back the memory, but within 5 minutes of using it again it is back up to 3,000,000k or above. I used to be able to use Firefox whilst having other programs open at the same time, such as Photoshop CS5, Illustrator CS5, Thunderbird, Excel and Word, but since upgrading to Quantum I cannot have any other program open in the background. In fact all these programs work fine, even with all of them open at the same time until I open my browser. The problem started with Quantum as I have not had the same issue with previous versions of Firefox. I am using Firefox version 61.0.2 (64 bit) on Windows 7 with 4GB Ram. I have added a couple of images to show the errors/memory issues. Does anybody have any suggestions how to solve the problem?
Attached screenshots

Chosen solution

Jems1 said

.

Wow. 4GB Memory system. I'm struggling with an 8GB system (from Nov 2010).

I haven't tried the turning-off the 'MultiProcessor' setup yet. I'm using 2 now and have Hardware Acceleration un-checked. I may try turning-off the 'MultiProcessor' setup.

There's another thing you could try that's helped me extend my browser sessions before becoming Memory-Choked or an occasional crash. Setting the Disk Cache in About:Config to 0. It's been working great for me for a while now.

  • browser.cache.disk.capacity (Set to 0)


~Pj

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

More Information

Scribe 730 solutions 3472 answers

Helpful Reply

Hi, you can try reducing the number of processes: Go to the 3-bar menu > Options (General) - Performance, then deselect 'Use recommended performance settings' and change 'Content process limit' to 1. See - Firefox's performance settings, and Startup, home page, tabs, and download settings.

Whilst in the 3-bar menu, you can also go to Options (Privacy & Security) - Permissions, and tick/check 'Prevent accessibility services from accessing your browser' then restart Firefox. More - What is the Accessibility Service Indicator?

If necessary, you can try turning off Multiprocess altogether: Type about:config into the address bar, press Enter, accept the warning, scroll down the alphabetical list to browser.tabs.remote.autostart and browser.tabs.remote.autostart.2 then double click on each to change 'Value' from True to False and restart Firefox.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you!

Hi, you can try reducing the number of processes: Go to the 3-bar menu > Options (General) - Performance, then deselect 'Use recommended performance settings' and change 'Content process limit' to 1. See - [[Firefox's performance settings]], and [[Startup, home page, tabs, and download settings]]. Whilst in the 3-bar menu, you can also go to Options (Privacy & Security) - Permissions, and tick/check 'Prevent accessibility services from accessing your browser' then restart Firefox. More - [[What is the Accessibility Service Indicator?]] If necessary, you can try turning off Multiprocess altogether: Type '''about:config''' into the address bar, press Enter, accept the warning, scroll down the alphabetical list to '''browser.tabs.remote.autostart''' and '''browser.tabs.remote.autostart.2''' then double click on each to change 'Value' from True to False and restart Firefox. ''If your question is resolved by this or another answer, please take a minute to let us know. Thank you!''

Question owner

Scribe said

Hi, you can try reducing the number of processes: Go to the 3-bar menu > Options (General) - Performance, then deselect 'Use recommended performance settings' and change 'Content process limit' to 1. See - Firefox's performance settings, and [[Startup, home page, tabs, and download settings]].

'Use recommended performance settings' was already deselected, but I have reduced the limit from 4 to 1 as suggested. I still reach 3GB, which in itself is fine as long as the computer keeps running; but unfortunately this is not the case. Now I have the page taking a lot longer to load, up to 45 seconds, the mouse does not change to a hand until the page has loaded so the whole page is unresponsive until fully loaded. In addition when I scroll down a webpage the screen turns to a blank page and I have to wait for the graphics to finish loading the page.

Whilst in the 3-bar menu, you can also go to Options (Privacy & Security) - Permissions, and tick/check 'Prevent accessibility services from accessing your browser' then restart Firefox. More - What is the Accessibility Service Indicator?

This option was already ticked/checked, however I restarted Firefox again to make sure I began from a 'clean start'.

If necessary, you can try turning off Multiprocess altogether: Type about:config into the address bar, press Enter, accept the warning, scroll down the alphabetical list to browser.tabs.remote.autostart and browser.tabs.remote.autostart.2 then double click on each to change 'Value' from True to False and restart Firefox. If your question is resolved by this or another answer, please take a minute to let us know. Thank you!

I have carried out this procedure as both were set to true. Initially I thought this had cured the problem as only 1 entry of firefox.exe was showing in Windows Task Manager, and the browser was working very fast. However after about 10 minutes the same problems have returned, i.e. very slow to load a page, the grey dot or blue dot in the page tab seems to keep swinging for ages before the page finishes loading. Again whilst the dot swings the mouse seems virtually unresponsive to any clicking although it does move around the screen. Eventually Firefox shows in the title bar that it is no longer responding and I have to wait a couple of minutes until it comes back.

Thank you for your input but at this stage it does not seem to have improved the problem.

''Scribe [[#answer-1145639|said]]'' <blockquote> Hi, you can try reducing the number of processes: Go to the 3-bar menu > Options (General) - Performance, then deselect 'Use recommended performance settings' and change 'Content process limit' to 1. See - [[Firefox's performance settings]], and [[Startup, home page, tabs, and download settings]]. </blockquote> 'Use recommended performance settings' was already deselected, but I have reduced the limit from 4 to 1 as suggested. I still reach 3GB, which in itself is fine as long as the computer keeps running; but unfortunately this is not the case. Now I have the page taking a lot longer to load, up to 45 seconds, the mouse does not change to a hand until the page has loaded so the whole page is unresponsive until fully loaded. In addition when I scroll down a webpage the screen turns to a blank page and I have to wait for the graphics to finish loading the page. <blockquote> Whilst in the 3-bar menu, you can also go to Options (Privacy & Security) - Permissions, and tick/check 'Prevent accessibility services from accessing your browser' then restart Firefox. More - [[What is the Accessibility Service Indicator?]] </blockquote> This option was already ticked/checked, however I restarted Firefox again to make sure I began from a 'clean start'. <blockquote> If necessary, you can try turning off Multiprocess altogether: Type '''about:config''' into the address bar, press Enter, accept the warning, scroll down the alphabetical list to '''browser.tabs.remote.autostart''' and '''browser.tabs.remote.autostart.2''' then double click on each to change 'Value' from True to False and restart Firefox. ''If your question is resolved by this or another answer, please take a minute to let us know. Thank you!'' </blockquote> I have carried out this procedure as both were set to true. Initially I thought this had cured the problem as only 1 entry of firefox.exe was showing in Windows Task Manager, and the browser was working very fast. However after about 10 minutes the same problems have returned, i.e. very slow to load a page, the grey dot or blue dot in the page tab seems to keep swinging for ages before the page finishes loading. Again whilst the dot swings the mouse seems virtually unresponsive to any clicking although it does move around the screen. Eventually Firefox shows in the title bar that it is no longer responding and I have to wait a couple of minutes until it comes back. Thank you for your input but at this stage it does not seem to have improved the problem.
Shadow110 1072 solutions 14836 answers

Separate Security Issue, please update your Flash 27.0 r0 by removing it with this tool : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html If you use it Reinstall with Flash Player Version: 30.0.0.154 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

HI, now that is out of the way Please make sure in about:config this one is also set to 1 dom.ipc.processCount set to 1

If this is a older system with low ram and video card drivers that can not be updated nor has the Motherboard seen a update or a Bios Flash suggest moving to the Extended Release Version.

Firefox Extended Release Version : Firefox ESR does not come with the latest features but it has the latest security and stability fixes.

If do please :

Note if uninstall your Profile is saved though should do a backup because

If not wanting to move then please backup and do a clean install of 61.0.2 with a Full Version Installer. Note you will have re do some settings, most are saved.

Please let us know if this solved your issue or if need further assistance.

''Separate'' Security Issue, please update your Flash 27.0 r0 by removing it with this tool : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html If you use it Reinstall with Flash Player Version: 30.0.0.154 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only> HI, now that is out of the way Please make sure in about:config this one is also set to 1 dom.ipc.processCount set to 1 If this is a older system with low ram and video card drivers that can not be updated nor has the Motherboard seen a update or a Bios Flash suggest moving to the Extended Release Version. '''''Firefox Extended Release Version :''''' Firefox ESR does not come with the latest features but it has the latest security and stability fixes. *https://support.mozilla.org/en-US/kb/switch-to-firefox-extended-support-release-esr If do please : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Note if uninstall your Profile is saved though should do a backup because If not wanting to move then please backup and do a clean install of 61.0.2 with a Full Version Installer. Note you will have re do some settings, most are saved. *https://www.mozilla.org/firefox/all/ Please let us know if this solved your issue or if need further assistance.

Question owner

Pkshadow said

Separate Security Issue, please update your Flash 27.0 r0 by removing it with this tool : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html If you use it Reinstall with Flash Player Version: 30.0.0.154 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

I don't have adobe flashplayer in Firefox or on my computer.

HI, now that is out of the way Please make sure in about:config this one is also set to 1 dom.ipc.processCount set to 1

This is already set at 1. Incidentally just writing this in Firefox has resulted in the memory running at 3,025,628k, and I am having to waiting for the text to appear on screen before typing another sentance.

If this is a older system with low ram and video card drivers that can not be updated nor has the Motherboard seen a update or a Bios Flash suggest moving to the Extended Release Version.

I do have an older computer with 4GB RAM. The drivers mentioned above are the latest versions available but they are not currently being updated and are between 2 to 3 years old.

Firefox Extended Release Version : Firefox ESR does not come with the latest features but it has the latest security and stability fixes. If do please : Note if uninstall your Profile is saved though should do a backup because If not wanting to move then please backup and do a clean install of 61.0.2 with a Full Version Installer. Note you will have re do some settings, most are saved. Please let us know if this solved your issue or if need further assistance.

I had considered trying this but wasn't entirely sure which version to go back to. I was also concerned of what information I would lose and if I was putting my computer at risk by using software that may soon stop being supported with the latest security and stability issues.

It may be the only option to follow as I have sent in 18 crash reports in August alone.

''Pkshadow [[#answer-1145765|said]]'' <blockquote> ''Separate'' Security Issue, please update your Flash 27.0 r0 by removing it with this tool : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html If you use it Reinstall with Flash Player Version: 30.0.0.154 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only> </blockquote> I don't have adobe flashplayer in Firefox or on my computer. <blockquote> HI, now that is out of the way Please make sure in about:config this one is also set to 1 dom.ipc.processCount set to 1 </blockquote> This is already set at 1. Incidentally just writing this in Firefox has resulted in the memory running at 3,025,628k, and I am having to waiting for the text to appear on screen before typing another sentance. <blockquote> If this is a older system with low ram and video card drivers that can not be updated nor has the Motherboard seen a update or a Bios Flash suggest moving to the Extended Release Version. </blockquote> I do have an older computer with 4GB RAM. The drivers mentioned above are the latest versions available but they are not currently being updated and are between 2 to 3 years old. <blockquote> '''''Firefox Extended Release Version :''''' Firefox ESR does not come with the latest features but it has the latest security and stability fixes. *https://support.mozilla.org/en-US/kb/switch-to-firefox-extended-support-release-esr If do please : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Note if uninstall your Profile is saved though should do a backup because If not wanting to move then please backup and do a clean install of 61.0.2 with a Full Version Installer. Note you will have re do some settings, most are saved. *https://www.mozilla.org/firefox/all/ Please let us know if this solved your issue or if need further assistance. </blockquote> I had considered trying this but wasn't entirely sure which version to go back to. I was also concerned of what information I would lose and if I was putting my computer at risk by using software that may soon stop being supported with the latest security and stability issues. It may be the only option to follow as I have sent in 18 crash reports in August alone.
Shadow110 1072 solutions 14836 answers

Hi, Sorry you do have Flash Installed as it is reported to the right in your System Details --> More System Details If it is not showing up please run the uninstaller from link to finish the job.

The 60.1.0 Browser will update continually it is the 52 series that is loosing support as that was mostly for XP/Vista users and is finished at month end.

If you backup your Profile and Bookmarks will have what is needed and should not loose anything moving to esr and will have backups if something happens.

Hi, Sorry you do have Flash Installed as it is reported to the right in your System Details --> More System Details If it is not showing up please run the uninstaller from link to finish the job. The 60.1.0 Browser will update continually it is the 52 series that is loosing support as that was mostly for XP/Vista users and is finished at month end. *https://support.mozilla.org/en-US/kb/switch-to-firefox-extended-support-release-esr If you backup your Profile and Bookmarks will have what is needed and should not loose anything moving to esr and will have backups if something happens.

Question owner

Pkshadow said

Hi, Sorry you do have Flash Installed as it is reported to the right in your System Details --> More System Details If it is not showing up please run the uninstaller from link to finish the job.

It isn't showing up in Control Panel or Plugins or Extensions - please see images attached.

''Pkshadow [[#answer-1145795|said]]'' <blockquote> Hi, Sorry you do have Flash Installed as it is reported to the right in your System Details --> More System Details If it is not showing up please run the uninstaller from link to finish the job. </blockquote> It isn't showing up in Control Panel or Plugins or Extensions - please see images attached.

Question owner

Jems1 said

Pkshadow said
Hi, Sorry you do have Flash Installed as it is reported to the right in your System Details --> More System Details If it is not showing up please run the uninstaller from link to finish the job.

It isn't showing up in Control Panel or Plugins or Extensions - please see images attached.

My apologies to you; I stand corrected. I have now followed your link, and used the installer. I cannot believe the number of files left remaining on my computer.

Quantum is running at the moment with one instance of firefox.exe showing about 500,000 to 1,500,000k, so I will see how it works for the rest of the night before moving to the ESR.

Many thanks for your help.

''Jems1 [[#answer-1145802|said]]'' <blockquote> ''Pkshadow [[#answer-1145795|said]]'' <blockquote> Hi, Sorry you do have Flash Installed as it is reported to the right in your System Details --> More System Details If it is not showing up please run the uninstaller from link to finish the job. </blockquote> It isn't showing up in Control Panel or Plugins or Extensions - please see images attached. </blockquote> My apologies to you; I stand corrected. I have now followed your link, and used the installer. I cannot believe the number of files left remaining on my computer. Quantum is running at the moment with one instance of firefox.exe showing about 500,000 to 1,500,000k, so I will see how it works for the rest of the night before moving to the ESR. Many thanks for your help.
Pj 42 solutions 869 answers

Chosen Solution

Jems1 said

.

Wow. 4GB Memory system. I'm struggling with an 8GB system (from Nov 2010).

I haven't tried the turning-off the 'MultiProcessor' setup yet. I'm using 2 now and have Hardware Acceleration un-checked. I may try turning-off the 'MultiProcessor' setup.

There's another thing you could try that's helped me extend my browser sessions before becoming Memory-Choked or an occasional crash. Setting the Disk Cache in About:Config to 0. It's been working great for me for a while now.

  • browser.cache.disk.capacity (Set to 0)


~Pj

''Jems1 [[#answer-1145815|said]]'' <blockquote>.</blockquote> Wow. 4GB Memory system. I'm struggling with an 8GB system (from Nov 2010). I haven't tried the turning-off the 'MultiProcessor' setup yet. I'm using 2 now and have '''Hardware Acceleration''' un-checked. I may try turning-off the 'MultiProcessor' setup. There's another thing you could try that's helped me extend my browser sessions before becoming Memory-Choked or an occasional crash. Setting the Disk Cache in '''About:Config''' to '''0'''. It's been working great for me for a while now. *'''browser.cache.disk.capacity''' (Set to 0) ~Pj
cor-el
  • Top 10 Contributor
  • Moderator
17526 solutions 158458 answers

Did you submit a crash report about this issue?

What is the size of the Windows paging file?

If you have submitted crash reports then please post the IDs of one or more recent crash reports that start with "bp-".

  • bp-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

You can find the report ID of recent crash reports "on the "Help -> Troubleshooting Information" (about:support) page".

  • click the "All Crash Reports" button on this page to open the about:crashes page and see all crash reports.

Alternatively you can open about:crashes via the location/address bar.

See also:

Did you submit a crash report about this issue? What is the size of the Windows paging file? If you have submitted crash reports then please post the IDs of one or more recent crash reports that start with "bp-". *bp-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx You can find the report ID of recent crash reports "on the "Help -> Troubleshooting Information" (about:support) page". *click the "All Crash Reports" button on this page to open the <b>about:crashes</b> page and see all crash reports. Alternatively you can open about:crashes via the location/address bar. See also: *https://support.mozilla.org/en-US/kb/Mozilla+Crash+Reporter

Question owner

Pj said Wow. 4GB Memory system. I'm struggling with an 8GB system (from Nov 2010).

I haven't tried the turning-off the 'MultiProcessor' setup yet. I'm using 2 now and have Hardware Acceleration un-checked. I may try turning-off the 'MultiProcessor' setup.

There's another thing you could try that's helped me extend my browser sessions before becoming Memory-Choked or an occasional crash. Setting the Disk Cache in About:Config to 0. It's been working great for me for a while now.

  • browser.cache.disk.capacity (Set to 0)

~Pj </blockquote>

4GB is not so bad!

I can still have around 6 or 7 programs open at the same time without losing speed or power, even using memory hungry programs such as Adobe CS5 suite; that is until I want to use Quantum, then my computer starts closing one after another until Quantum is the only program left running - then Quantum crashes.

I will try reducing the cache as you suggested, but doesn't that increase the time taken to reload a page? I assume as you have chosen 0 that nothing from a previous page is kept in memory and by going back a page in the browser the whole page would take time to be reloaded.

Still it is worth a try.

''Pj [[#answer-1145868|said]]'' Wow. 4GB Memory system. I'm struggling with an 8GB system (from Nov 2010). I haven't tried the turning-off the 'MultiProcessor' setup yet. I'm using 2 now and have '''Hardware Acceleration''' un-checked. I may try turning-off the 'MultiProcessor' setup. There's another thing you could try that's helped me extend my browser sessions before becoming Memory-Choked or an occasional crash. Setting the Disk Cache in '''About:Config''' to '''0'''. It's been working great for me for a while now. *'''browser.cache.disk.capacity''' (Set to 0) ~Pj </blockquote> 4GB is not so bad! I can still have around 6 or 7 programs open at the same time without losing speed or power, even using memory hungry programs such as Adobe CS5 suite; that is until I want to use Quantum, then my computer starts closing one after another until Quantum is the only program left running - then Quantum crashes. I will try reducing the cache as you suggested, but doesn't that increase the time taken to reload a page? I assume as you have chosen 0 that nothing from a previous page is kept in memory and by going back a page in the browser the whole page would take time to be reloaded. Still it is worth a try.

Question owner

cor-el said

Did you submit a crash report about this issue?

Yes, and I have just sent in the remaining unsubmitted crash reports.

What is the size of the Windows paging file?

Will that information be in the crash report? I am not sure where to look for that detail.

If you have submitted crash reports then please post the IDs of one or more recent crash reports that start with "bp-".
  • bp-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
You can find the report ID of recent crash reports "on the "Help -> Troubleshooting Information" (about:support) page".
  • click the "All Crash Reports" button on this page to open the about:crashes page and see all crash reports.
Alternatively you can open about:crashes via the location/address bar. See also:

The last three that I have sent in today are:

bp-c9ef9f7c-697a-42d7-be51-f308d0180823 20/08/2018 17:56 bp-01a8ed9a-022f-406c-8ce2-8cb430180823 20/08/2018 17:30 bp-3b4a4d9c-d570-4f85-ac08-fc0060180823 16/08/2018 23:25

You can see the time between the last two crashes was just 26 minutes which includes closing down the computer and rebooting, using the browser for about 20 minutes and then crashing again.

''cor-el [[#answer-1145897|said]]'' <blockquote> Did you submit a crash report about this issue? </blockquote> Yes, and I have just sent in the remaining unsubmitted crash reports. <blockquote> What is the size of the Windows paging file? </blockquote> Will that information be in the crash report? I am not sure where to look for that detail. <blockquote> If you have submitted crash reports then please post the IDs of one or more recent crash reports that start with "bp-". *bp-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx You can find the report ID of recent crash reports "on the "Help -> Troubleshooting Information" (about:support) page". *click the "All Crash Reports" button on this page to open the <b>about:crashes</b> page and see all crash reports. Alternatively you can open about:crashes via the location/address bar. See also: *https://support.mozilla.org/en-US/kb/Mozilla+Crash+Reporter </blockquote> The last three that I have sent in today are: bp-c9ef9f7c-697a-42d7-be51-f308d0180823 20/08/2018 17:56 bp-01a8ed9a-022f-406c-8ce2-8cb430180823 20/08/2018 17:30 bp-3b4a4d9c-d570-4f85-ac08-fc0060180823 16/08/2018 23:25 You can see the time between the last two crashes was just 26 minutes which includes closing down the computer and rebooting, using the browser for about 20 minutes and then crashing again.

Question owner

Jems1 said

Pj said There's another thing you could try that's helped me extend my browser sessions before becoming Memory-Choked or an occasional crash. Setting the Disk Cache in About:Config to 0. It's been working great for me for a while now.
  • browser.cache.disk.capacity (Set to 0)
~Pj

Just tried to do this but whenever I restart Firefox the default value in my browser of 358400 replaces the 0. Not sure how to make it save the 0 that I entered in the box.

''Jems1 [[#answer-1146025|said]]'' <blockquote> ''Pj [[#answer-1145868|said]]'' There's another thing you could try that's helped me extend my browser sessions before becoming Memory-Choked or an occasional crash. Setting the Disk Cache in '''About:Config''' to '''0'''. It's been working great for me for a while now. *'''browser.cache.disk.capacity''' (Set to 0) ~Pj </blockquote> Just tried to do this but whenever I restart Firefox the default value in my browser of 358400 replaces the 0. Not sure how to make it save the 0 that I entered in the box.
Shadow110 1072 solutions 14836 answers

I think it would be best if left the cache alone especially if your a repeat user of the same sites.

If you do not use Sessions you can triple this guy's suggestion : https://www.servethehome.com/firefox-is-eating-your-ssd-here-is-how-to-fix-it/

I think it would be best if left the cache alone especially if your a repeat user of the same sites. If you do not use Sessions you can triple this guy's suggestion : https://www.servethehome.com/firefox-is-eating-your-ssd-here-is-how-to-fix-it/
Shadow110 1072 solutions 14836 answers

Note the Crash Reports are all : Signature IPCError-browser | ShutDownKill kernel32.dll ntdll.dll

FYI ONLY : Also a change like below for ZwUserMessageCall A MS breakdown of this https://blogs.msdn.microsoft.com/oldnewthing/20141024-00/?p=43773

IPC Channel Error, was: "vcruntime140.dll@0xce9a | je_free | mozilla::BufferList<T>::Clear" vcruntime140.dll https://answers.microsoft.com/en-us/windows/forum/windows_7-windows_install-wininstalls/vcruntime140dll-on-windows-7/796c229d-3e7c-4ba9-9cdc-7dab89073eb2

  • Above Response to vcruntime140.dll error
"vcruntime140.dll" error could indicate issues with the Microsoft Visual C++. I suggest that you install the Microsoft Visual C++ from this link https://www.microsoft.com/en-us/download/details.aspx?id=52685 and see how it goes. If you already have this installed on your PC, try to uninstall it, and then download and install.

The Report also has Notes on Video Card Drivers would recommend Updating or Uninstall and Reinstall

As per the Microsoft comments if you have Visual C installed and listed in Programs & Features, Microsoft then do as suggested.

Note the Crash Reports are all : Signature IPCError-browser | ShutDownKill kernel32.dll ntdll.dll FYI ONLY : Also a change like below for ZwUserMessageCall A MS breakdown of this https://blogs.msdn.microsoft.com/oldnewthing/20141024-00/?p=43773 IPC Channel Error, was: "vcruntime140.dll@0xce9a | je_free | mozilla::BufferList<T>::Clear" vcruntime140.dll https://answers.microsoft.com/en-us/windows/forum/windows_7-windows_install-wininstalls/vcruntime140dll-on-windows-7/796c229d-3e7c-4ba9-9cdc-7dab89073eb2 *Above Response to vcruntime140.dll error <blockquote>"vcruntime140.dll" error could indicate issues with the Microsoft Visual C++. I suggest that you install the Microsoft Visual C++ from this link https://www.microsoft.com/en-us/download/details.aspx?id=52685 and see how it goes. If you already have this installed on your PC, try to uninstall it, and then download and install.</blockquote> The Report also has Notes on Video Card Drivers would ''recommend'' Updating or Uninstall and Reinstall As per the Microsoft comments if you have Visual C installed and listed in Programs & Features, Microsoft then do as suggested.
Pj 42 solutions 869 answers

Jems1 said

Just tried to do this but whenever I restart Firefox the default value in my browser of 358400 replaces the 0. Not sure how to make it save the 0 that I entered in the box.

Check the following setting:

  • browser.cache.disk.smart_size.enabled (Mine is set to false.)


~Pj

''Jems1 [[#answer-1146047|said]]'' <blockquote> Just tried to do this but whenever I restart Firefox the default value in my browser of 358400 replaces the 0. Not sure how to make it save the 0 that I entered in the box. </blockquote> Check the following setting: *'''browser.cache.disk.smart_size.enabled''' (Mine is set to '''false'''.) ~Pj
Pj 42 solutions 869 answers

Jems1 said

I will try reducing the cache as you suggested, but doesn't that increase the time taken to reload a page? I assume as you have chosen 0 that nothing from a previous page is kept in memory and by going back a page in the browser the whole page would take time to be reloaded. Still it is worth a try.

Yes, going back to a page is reloaded. Info is always 'fresh'. If you have slow-loading pages (slow ISP speed?), this might be a bad trade-off. Maybe try a small Cache Number and slowly increase it. Or work the Cache Number downward over time?

However, for me, 0 has helped on the 'Memory Crunch' problem. With the Disk Cache set to 0, the Memory floats high and back down again, allowing for my FF sessions to last for days longer. I just recently was at a Weather Satellite site before coming here, and it's memory-intensive. Drives my CPU to 100% and Memory up and past 7GB. Right now, I'm mostly around 10-20% CPU and 5.79GB on Memory. Keeping a Disk Cache keeps my Memory high, a lot of disk-crunching, and shorter browsing sessions.

Also, I'm experimenting with a lower Windows Paging File setup. I've never seen a message from Windows saying 'Low Memory' prior to Quantum. This may be due in all or part to having too low of a Paging File size. I had it around 3GB, and I think it's now at 3.5GB. I may need to go to 4GB. I had it briefly at 6GB, but longer hard drive disk-crunching activity was happening. If I set it to what Windows 'recommends', (12GB) then I get a lot of disk-crunching activity, which lasts a lot longer.

At the moment, when starting my computer, it takes about 20 minutes to 'settle' down with all the disk-crunching activity. When I start FF, it takes 12 minutes to load all browser windows ready for use.

I could go a lot longer with my browsing sessions and faster FF startups, once I do 'housecleaning' and cut down my current 668 Tabs I have in this one browser window. (No, they're not all 'loaded'. Another Config setting I did a while back only loads one Tab per window upon FF start-up.)

I have Hardware Acceleration un-checked, but haven't tried it since setting the Disk Cache to 0. Also, I have yet to try reducing or turning-off Multi-thread. I have a Dual Processor system, so I have Multi-thread currently set at 2.


~Pj

''Jems1 [[#answer-1146025|said]]'' <blockquote> I will try reducing the cache as you suggested, but doesn't that increase the time taken to reload a page? I assume as you have chosen 0 that nothing from a previous page is kept in memory and by going back a page in the browser the whole page would take time to be reloaded. Still it is worth a try. </blockquote> Yes, going back to a page is reloaded. Info is always 'fresh'. If you have slow-loading pages (slow ISP speed?), this might be a bad trade-off. Maybe try a small Cache Number and slowly increase it. Or work the Cache Number downward over time? However, for me, 0 has helped on the 'Memory Crunch' problem. With the Disk Cache set to 0, the Memory floats high and back down again, allowing for my FF sessions to last for days longer. I just recently was at a Weather Satellite site before coming here, and it's memory-intensive. Drives my CPU to 100% and Memory up and past 7GB. Right now, I'm mostly around 10-20% CPU and 5.79GB on Memory. Keeping a Disk Cache keeps my Memory high, a lot of disk-crunching, and shorter browsing sessions. Also, I'm experimenting with a lower '''Windows Paging File''' setup. I've never seen a message from Windows saying 'Low Memory' prior to Quantum. This may be due in all or part to having too low of a Paging File size. I had it around 3GB, and I think it's now at 3.5GB. I may need to go to 4GB. I had it briefly at 6GB, but longer hard drive disk-crunching activity was happening. If I set it to what Windows 'recommends', (12GB) then I get a lot of disk-crunching activity, which lasts a lot longer. At the moment, when starting my computer, it takes about 20 minutes to 'settle' down with all the disk-crunching activity. When I start FF, it takes 12 minutes to load all browser windows ready for use. I could go a lot longer with my browsing sessions and faster FF startups, once I do 'housecleaning' and cut down my current '''668 Tabs''' I have in this one browser window. (No, they're not all 'loaded'. Another Config setting I did a while back only loads one Tab per window upon FF start-up.) I have '''Hardware Acceleration''' un-checked, but haven't tried it since setting the Disk Cache to 0. Also, I have yet to try reducing or turning-off '''Multi-thread'''. I have a Dual Processor system, so I have Multi-thread currently set at '''2'''. ~Pj

Question owner

Pkshadow said

FYI ONLY : Also a change like below for ZwUserMessageCall A MS breakdown of this https://blogs.msdn.microsoft.com/oldnewthing/20141024-00/?p=43773
"vcruntime140.dll" error could indicate issues with the Microsoft Visual C++. I suggest that you install the Microsoft Visual C++ from this link https://www.microsoft.com/en-us/download/details.aspx?id=52685 and see how it goes. If you already have this installed on your PC, try to uninstall it, and then download and install.

The Report also has Notes on Video Card Drivers would recommend Updating or Uninstall and Reinstall

As per the Microsoft comments if you have Visual C installed and listed in Programs & Features, Microsoft then do as suggested.

I will have a look at this tonight. I have just looked at my programs in Control Panel and see I have a number of different versions of C++ which I have not uploaded (see attached image). I assume this has been done by other software that has not removed previous versions.

I will remove all the different versions and download the one you have suggested above and see if that improves anything.

Regarding other latest drivers I replaced one of the hard drives in my computer around 2 or 3 years ago and downloaded all the latest drivers at that time. As pointed out, I have an older computer and I doubt drivers have been updated since then, but I will investigate and double check.

Thank you for your help and suggestions

''Pkshadow [[#answer-1146087|said]]'' <blockquote> FYI ONLY : Also a change like below for ZwUserMessageCall A MS breakdown of this https://blogs.msdn.microsoft.com/oldnewthing/20141024-00/?p=43773 <blockquote>"vcruntime140.dll" error could indicate issues with the Microsoft Visual C++. I suggest that you install the Microsoft Visual C++ from this link https://www.microsoft.com/en-us/download/details.aspx?id=52685 and see how it goes. If you already have this installed on your PC, try to uninstall it, and then download and install.</blockquote> The Report also has Notes on Video Card Drivers would ''recommend'' Updating or Uninstall and Reinstall As per the Microsoft comments if you have Visual C installed and listed in Programs & Features, Microsoft then do as suggested. </blockquote> I will have a look at this tonight. I have just looked at my programs in Control Panel and see I have a number of different versions of C++ which I have not uploaded (see attached image). I assume this has been done by other software that has not removed previous versions. I will remove all the different versions and download the one you have suggested above and see if that improves anything. Regarding other latest drivers I replaced one of the hard drives in my computer around 2 or 3 years ago and downloaded all the latest drivers at that time. As pointed out, I have an older computer and I doubt drivers have been updated since then, but I will investigate and double check. Thank you for your help and suggestions

Modified by Jems1

Shadow110 1072 solutions 14836 answers

Hi, Do not adjust Cache to 0

It is not recommended to do so, having a cache of all the sites gifs, jpegs, and headers and what ever else is stored in 350 megs is to speed up browsing so it does not need to be downloaded again.

All the versions of C++ are needed by various programs as some depend on older and some newer. So you would only uninstall : Microsoft Visual C++ 2015 Redistributable and reinstall the same by URL given/or https://www.microsoft.com/en-us/download/details.aspx?id=52685

Hi, Do not adjust Cache to 0 It is not recommended to do so, having a cache of all the sites gifs, jpegs, and headers and what ever else is stored in 350 megs is to speed up browsing so it does not need to be downloaded again. All the versions of C++ are needed by various programs as some depend on older and some newer. So you would only uninstall : Microsoft Visual C++ 2015 Redistributable and reinstall the same by URL given/or https://www.microsoft.com/en-us/download/details.aspx?id=52685
Pj 42 solutions 869 answers

Pkshadow said

Hi, Do not adjust Cache to 0 It is not recommended to do so, having a cache of all the sites gifs, jpegs, and headers and what ever else is stored in 350 megs is to speed up browsing so it does not need to be downloaded again.

But, that's why one day I tried the 0 Cache setting. Despite not Caching pages, it help me browse much longer before a crash or Memory-Pile-ups on the Memory Highway. If jems1 wants to try to see if it helps, why say no?

~Pj

''Pkshadow [[#answer-1146145|said]]'' <blockquote> Hi, Do not adjust Cache to 0 It is not recommended to do so, having a cache of all the sites gifs, jpegs, and headers and what ever else is stored in 350 megs is to speed up browsing so it does not need to be downloaded again. </blockquote> But, that's why one day I tried the 0 Cache setting. Despite not Caching pages, it help me browse much longer before a crash or Memory-Pile-ups on the Memory Highway. If jems1 wants to try to see if it helps, why say no? ~Pj

Question owner

Pkshadow said

Hi, Do not adjust Cache to 0 It is not recommended to do so, having a cache of all the sites gifs, jpegs, and headers and what ever else is stored in 350 megs is to speed up browsing so it does not need to be downloaded again. All the versions of C++ are needed by various programs as some depend on older and some newer. So you would only uninstall : Microsoft Visual C++ 2015 Redistributable and reinstall the same by URL given/or https://www.microsoft.com/en-us/download/details.aspx?id=52685

I am just backing everything up first and then I will update just the 2015 version as you have described above. I have left the cache at the default value of 358400. I will see how everything performs tomorrow, thank you.

''Pkshadow [[#answer-1146145|said]]'' <blockquote> Hi, Do not adjust Cache to 0 It is not recommended to do so, having a cache of all the sites gifs, jpegs, and headers and what ever else is stored in 350 megs is to speed up browsing so it does not need to be downloaded again. All the versions of C++ are needed by various programs as some depend on older and some newer. So you would only uninstall : Microsoft Visual C++ 2015 Redistributable and reinstall the same by URL given/or https://www.microsoft.com/en-us/download/details.aspx?id=52685 </blockquote> I am just backing everything up first and then I will update just the 2015 version as you have described above. I have left the cache at the default value of 358400. I will see how everything performs tomorrow, thank you.