X
Tap here to go to the mobile version of the site.

Support Forum

Firefox starts but does not show the browser

Posted

20.3.2018

MS WIndows 10 Pro

I have been using Firefox for years, but yesterday firefox stopped working. That is to say that the task manager showed firefox in the task list with 14%CPU but no browser page was started. ie Firefox running but no screen output. I then uninstalled firefox and reinstalled but I still have the same problem.

Any help on this ?

20.3.2018 MS WIndows 10 Pro I have been using Firefox for years, but yesterday firefox stopped working. That is to say that the task manager showed firefox in the task list with 14%CPU but no browser page was started. ie Firefox running but no screen output. I then uninstalled firefox and reinstalled but I still have the same problem. Any help on this ?
FredMcD
  • Top 10 Contributor
4256 solutions 59603 answers

Open Firefox. Right-click on the Firefox icon and select Open New Window. If a new window opens, close the first window using its icon.

Open Firefox. Right-click on the Firefox icon and select '''Open New Window. ''' If a new window opens, close the '''first''' window using its icon.

Question owner

FredMcD said

Open Firefox. Right-click on the Firefox icon and select Open New Window. If a new window opens, close the first window using its icon.

The browser does not open. As I wrote firefox is in the task manager running at 14% CPU but the is no screen output at all - almost as though I had not started firefox. I started ff nornally and as administration. My ID is as an administrator.

''FredMcD [[#answer-1090912|said]]'' <blockquote> Open Firefox. Right-click on the Firefox icon and select '''Open New Window. ''' If a new window opens, close the '''first''' window using its icon. </blockquote> The browser does not open. As I wrote firefox is in the task manager running at 14% CPU but the is no screen output at all - almost as though I had not started firefox. I started ff nornally and as administration. My ID is as an administrator.
FredMcD
  • Top 10 Contributor
4256 solutions 59603 answers

So, you are saying there is no Firefox icon on the computer's taskbar?

Let’s do a full clean re-install;

Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86)

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any Mozilla or Firefox program folders. Do not remove the Mozilla Thunderbird folder if there is one.

Do Not remove the profiles folder.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

So, you are saying there is no Firefox icon on the computer's taskbar? Let’s do a full clean re-install; [http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems] {web link} Save the file. Then '''Close Firefox. ''' Using your file browser, open the '''Programs Folder''' on your computer. '''Windows: ''' C:\Program Files C:\Program Files (x86) '''Mac: ''' Open the ''' "Applications" ''' folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac '''Linux: ''' Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any '''Mozilla''' or '''Firefox''' program folders. Do not remove the '''Mozilla Thunderbird''' folder if there is one. '''Do Not''' remove the profiles folder. After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your '''Computer''' in safe mode and try again. http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

Question owner

21.3.2018 @fredmcd

MAny thanks for your comment.

No, the Icon was on screen - hence the ability to start Firefox. It seem to do something that occupies 14% of the CPU but then nothing appears on my screen. A strange behaviour, since two day ago it was fine and I made no changes to it. I also - two day ago - I deleted firefox over the Windows remove programmes and then reinstalled it. Still no change. Opera and Edge both function well. I accept the problem is specific to my computer but I have no idea what.

21.3.2018 @fredmcd MAny thanks for your comment. No, the Icon was on screen - hence the ability to start Firefox. It seem to do something that occupies 14% of the CPU but then nothing appears on my screen. A strange behaviour, since two day ago it was fine and I made no changes to it. I also - two day ago - I deleted firefox over the Windows remove programmes and then reinstalled it. Still no change. Opera and Edge both function well. I accept the problem is specific to my computer but I have no idea what.
FredMcD
  • Top 10 Contributor
4256 solutions 59603 answers

FredMcD said

Open Firefox. Right-click on the Firefox icon and select Open New Window. If a new window opens, close the first window using its icon.

Bonzadog said

The browser does not open.

Bonzadog said

the Icon was on screen

Follow my instructions above.

''FredMcD [[#answer-1090912|said]]'' <blockquote> Open Firefox. Right-click on the Firefox icon and select '''Open New Window. ''' If a new window opens, close the '''first''' window using its icon. </blockquote> ''Bonzadog [[#answer-1090926|said]]'' <blockquote> The browser does not open. </blockquote> ''Bonzadog [[#answer-1091202|said]]'' <blockquote> the Icon was on screen </blockquote> Follow my instructions above.

Question owner

1) a click on the desktop icon to start - confirmed in task manager - nothing happens 1a) Left click get the hour glass then nothing

2) clicking right on the icon only gives the usual Open .... Properies menu. This is what I expect when I click on an Icon. There is no Open New WIndow I think the Firefox must be on screen for that.

1) a click on the desktop icon to start - confirmed in task manager - nothing happens 1a) Left click get the hour glass then nothing 2) clicking right on the icon only gives the usual Open .... Properies menu. This is what I expect when I click on an Icon. There is no Open New WIndow I think the Firefox must be on screen for that.
FredMcD
  • Top 10 Contributor
4256 solutions 59603 answers

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt xulstore.json or Localstore.rdf file.

Close Firefox. Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/Profiles
  • Linux: *~/.mozilla/firefox/Profiles
  • Windows: %AppData%\Mozilla\Firefox\Profiles
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles
  • Windows XP: C:\Documents and Settings\<user>\Application Data
    \Mozilla\Firefox\Profiles\

Search for the above files. Then rename or delete them. Restart Firefox.

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt '''xulstore.json''' or '''Localstore.rdf''' file. '''Close Firefox. ''' Open your file browser to this hidden location: * '''Mac: ''' *~/Library/Application Support/Firefox/Profiles * '''Linux: ''' *~/.mozilla/firefox/Profiles * '''Windows: ''' %AppData%\Mozilla\Firefox\Profiles * *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles * '''Windows XP: ''' C:\Documents and Settings\<user>\Application Data<br> \Mozilla\Firefox\Profiles\ Search for the above files. Then rename or delete them. Restart Firefox.

Question owner

Appreciate you help - but it did not work.

I bought a reno uninstaller programme and reinstalled firefox then uninstalled with the new uninstaller. Still did not work after the reboot and new install. This is indeed a rather toothsome problem.

Appreciate you help - but it did not work. I bought a reno uninstaller programme and reinstalled firefox then uninstalled with the new uninstaller. Still did not work after the reboot and new install. This is indeed a rather toothsome problem.
FredMcD
  • Top 10 Contributor
4256 solutions 59603 answers

Chosen Solution

Use these links to create a new profile. Use this new profile '''as is. ''' Is the problem still there? http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles Type '''about:profiles'''<enter> in the address bar.

Question owner

Thank you that solved the problem.

I changed the old default to default-ng because when I tried to delete I received a "not responding" message. After a firefox start all was OK.

Again thanks, and you are good for a couple of Pils should you ever be in Northern Germany....

Thank you that solved the problem. I changed the old default to default-ng because when I tried to delete I received a "not responding" message. After a firefox start all was OK. Again thanks, and you are good for a couple of Pils should you ever be in Northern Germany....
FredMcD
  • Top 10 Contributor
4256 solutions 59603 answers

Glad to help. Safe Surfing.

Glad to help. Safe Surfing.