Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My yahoo home page does not function properly in firefox anymore

  • 3 replies
  • 6 have this problem
  • 22 views
  • Last reply by FredMcD

more options

Within the past week, my Yahoo homepage modules do not function properly, IE; the mail module has no preview and the "Today" module does not advance to the next set of thumb nails via the arrows, nor do the thumbnails show in the preview screen when you hover the mouse over them. Additionally, I can not edit my homepage content at all, IE: add or remove content, or relocate content. My home page does, however, function properly in Internet Explorer. Any possible solutions?????

Within the past week, my Yahoo homepage modules do not function properly, IE; the mail module has no preview and the "Today" module does not advance to the next set of thumb nails via the arrows, nor do the thumbnails show in the preview screen when you hover the mouse over them. Additionally, I can not edit my homepage content at all, IE: add or remove content, or relocate content. My home page does, however, function properly in Internet Explorer. Any possible solutions?????

Chosen solution

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Type about:preferences<enter> in the address bar.

  • Cookies; Select Privacy. Under History, select

Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.

  • Cache; Select Advanced > Network.

[v57+] Select Privacy. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Type about:preferences<enter> in the address bar.

  • Cookies; Select Privacy. Under History, select

Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.

  • Cache; Select Advanced > Network.

[v57+] Select Privacy. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

Thank you FredMcDee.....Your advice solved this issue. I Cleared all of my cache, browsing history, and cookies and my Yahoo home page is functioning properly again.

more options

Glad to help. Safe Surfing.