Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

SOLVED: Keeping Google as my default search engine

  • 2 replies
  • 1 has this problem
  • Last reply by WestEnd

more options


I'm trying to keep Google as my default search engine on Firefox (56.0.2). Usually, if another search engine sneeks onto my PC, I can do a simple refresh of Firefox to get my preferred search engine back, but this time the default returns to Bing after I reopen Firefox.

I've tried reinstalling Firefox, clearing everything like cookies, and rebooting. I'm not keen to do a system restore. I don't have the Bing toolbar, and can't find any Bing files I might delete. For now I need to stay pre-Quantum.

Thanks in advance for any advice.

SOLVED by deleting the Mozilla Firefox files dsengine.cfg and dsengine.js (hopefully)

Modified by user1460423

Chosen solution

I've solved the problem now.

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

I've solved the problem now.

more options

Mine is set to google when I first setup and remains google search so not sure what you did after the first install to cause it not to stay at google search.