Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Add-ons don't appear in Firefox 57

  • 15 replies
  • 16 have this problem
  • 2342 views
  • Last reply by FredMcD

more options

I upgraded Firefox on my laptop to the 57 beta about a month and a half ago, and that went quite smoothly. But on my desktop PC, none of my add-ons/extensions appear in my toolbar, or in the "customize" menu to move to my toolbar. I've tried disabling/reenabling, uninstalling/reinstalling, and nothing has worked yet.

EDIT: Please note that these are COMPATIBLE and ENABLED add-ons. I am well aware of the new WebExtensions requirement and that most of my old add-ons will not work. These incompatible add-ons are currently DISABLED and are not related to my problem.

Modified by merkyor

Chosen solution

I tried doing a "refresh" and that fixed it. Thanks for your help, FredMcD.

Read this answer in context 👍 0

All Replies (15)

more options

It's possible some of the add-ons are not compatible with the new Firefox.

Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Now in the Reply Box on the forum page, do a right-click in the box and select Paste.

This will show us your system details. No Personal Information Is Collected.

more options

Yeah, a lot of my add-ons are incompatible after the WebExtensions apocalypse. :( But they are disabled and in the "incompatible" list. I'm talking about the ones that are active and (supposedly) working.

Here is my data:

EDIT: I can't post it because the post exceeds 10k characters, and I can only attach images, so I guess I'll put it on my FTP and link it: http://www.nonegrade.com/shared/firefox-about-support.txt

more options

That was good work on your part. I called for more help.

more options

Thanks for your help!

more options

I still haven't been able to get any of my add-ons to work.

more options

Don't want to seem arrogant but you should all have known that with FF57 all Legacy Add-Ons would cease to work! I installed as many compatible replacement extensions while still using FF56. So far my FF57 experience has gone fairly smooth!

more options

You need to re-read the thread.

more options

Do any developers monitor this forum?

Modified by marotti

more options

None of this has anything to do with my problem. Incompatible add-ons are a different issue. I have a number of incompatible add-ons installed, and they are currently disabled.

The issue I'm having is that COMPATIBLE AND ENABLED add-ons in my browser do not show up on my toolbar, and do not appear in my "customize" menu to drag to said toolbar.

more options

Here are screenshots showing my issue.

more options

It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Delete all extensions files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":

+++++++++++++++++++++++++++ You will have to approve the updating one last time.

more options

Unfortunately it didn't work. Thanks for the suggestion, though.

more options

Well, this is at least somewhat useful, because I'd like to downgrade on my HTPC to use a couple of important add-ons I use on it.

But again, DISABLED ADD-ONS ISN'T MY PROBLEM HERE.

Modified by merkyor

more options

Chosen Solution

I tried doing a "refresh" and that fixed it. Thanks for your help, FredMcD.

more options

Glad to help. Safe Surfing.