Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox crashes instantly on video playback

  • 14 replies
  • 3 have this problem
  • 883 views
  • Last reply by FredMcD

more options

Hi,

bp-d96dc6ad-f9a5-4fac-9482-13df01170828

Happens on YT, FB, Twitter ...

Things I have tried 1. switching from FF 32bit to 64bit 2. disabling HW acceleration 3. updating video drivers 4. safe mode (crash still happens)

Used to work fine and seems to have happened after latest update to FF. though I suspect it is not solely a result of this since I have another PC which is working fine. Since this happens on my work laptop, which is in a semi controlled configuration, the 'well ... check the differences' is not a useful approach since there are way too many of them and I do not have the luxury of going one by one, disabling/unintsalling and seeing if the problem goes away

any help is appreciated.

Modified by cor-el

Chosen solution

Note: v55 has been giving users problems. Reinstall v54.

https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

Read this answer in context 👍 0

All Replies (14)

more options

bp-d96dc6ad-f9a5-4fac-9482-13df01170828 Signature: RtlFreeHeap | CBridgeImpl<T>::LUCDestroyStatus

dnsapi.dll = DNS Client = Windows

igdumd64.dll = NVIDIA D3D shim drivers = NVIDIA Corporation

igd10umd64.dll = intel graphics driver or used to handle the startup services of Immunet Virus Removal

msmpeg2vdec.dll = Microsoft DTV-DVD Video Decoder

more options

See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

For that matter, check all software for updates.


Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem? Let us know.

more options

FredMcD said

bp-d96dc6ad-f9a5-4fac-9482-13df01170828 Signature: RtlFreeHeap | CBridgeImpl<T>::LUCDestroyStatus dnsapi.dll = DNS Client = Windows igdumd64.dll = NVIDIA D3D shim drivers = NVIDIA Corporation igd10umd64.dll = intel graphics driver or used to handle the startup services of Immunet Virus Removal msmpeg2vdec.dll = Microsoft DTV-DVD Video Decoder

not sure what this is telling me other than these DLLs are loaded at crash time.

more options

FredMcD said

See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration For that matter, check all software for updates.

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem? Let us know.

thanks! this seems to alleviate issue with YT. FB videos still crash FF.

more options

stubking said

FredMcD said
See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration For that matter, check all software for updates.

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem? Let us know.

thanks! this seems to alleviate issue with YT. FB videos still crash FF.

I may have jumped the gun. YT crashes as well. I guess it is a little more intermittent with YT.

video drivers have been updated before I posted this question

more options

Please post any new crash reports.

more options
more options

bp-6f21adb4-0059-404f-88e1-574371170830 Signature: RtlFreeHeap | CFmCtrlUnknown::Release

dnsapi.dll = DNS Client = Windows

igdumdim64.dll = Intel HD Graphics Drivers for Windows 8(R) = Intel Corporation

msmpeg2vdec.dll = Microsoft DTV-DVD Video Decoder


Perform a System File Check to fix corrupted system files

Win 7, 8, 10, Vista: https://support.microsoft.com/en-us/kb/929833 Win XP: https://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/system_file_checker.mspx?mfr=true

Wiki - Windows 10 System File Check http://answers.microsoft.com/en-us/windows/wiki/windows_10-update/system-file-check-sfc-scan-and-repair-system-files/bc609315-da1f-4775-812c-695b60477a93

more options

System File Check found nothing relevant.

more options

Let’s do a full clean re-install; Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86)

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Do Not remove the profiles folder.

Look for, and rename any Mozilla or Firefox program folders by adding .old to them. Do not rename the Mozilla Thunderbird folder if there is one.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. If all goes well, remove the OLD folders when you are done. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

more options

no dice.

installed new. looked OK for a bit but then crashes appear. here are some new crash reports

https://crash-stats.mozilla.com/report/index/bb28a086-94c2-4c37-a310-9d40b1170831

https://crash-stats.mozilla.com/report/index/bp-52cf0b9f-263c-4bcd-951d-8ee531170831

https://crash-stats.mozilla.com/report/index/6f5ccde8-b23e-48a2-8f26-de5d61170831

Been swapping profiles to see what could be a difference. but nothing found. disabled the Cisco h.264 codec that FF installs and the google plugin for protected videos. looks a tad more stable but problem by and large still there.

looking at crash reports it looks like the issue might be actually outside of FF. maybe it is ntdll.dll but puzzled as to why. should be a pretty stable DLL and will be nigh impossible to replace and too risky since it is so core.

more options

You can try to set this pref to false on the about:config page.

  • media.windows-media-foundation.allow-d3d11-dxva = false

You can try to disable hardware acceleration in Firefox.

  • Options/Preferences -> General: Performance
    remove checkmark: [ ] "Use recommended performance settings"
    "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

more options

thanks. tried changing this setting but no luck. if you look at my OP you will see I already disables HW acceleration and updated graphics display driver .

it seems like first video would play ok but as soon as you try another or nav away from page it crashes. which kind of makes sense since error seems to be when releasing from the heap.

more options

Chosen Solution

Note: v55 has been giving users problems. Reinstall v54.

https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements