X
Tap here to go to the mobile version of the site.

Support Forum

I just upgraded to Firefox 54.0 for Linux Mint. The toolbars are huge. How do I make them smaller?

Posted

How do I make the toolbars smaller? Since upgrading to the latest version, they are twice as tall as they used to be. The text in them is still a reasonable size but the toolbars take up twice the vertical space they used to. This has nothing to do with the size of the page I'm viewing so Ctrl+ or Ctgrl- has no effect.

Thanks for any help. Attached is a screen shot showing the wasted space at the top of my screen with the new toolbars.

How do I make the toolbars smaller? Since upgrading to the latest version, they are twice as tall as they used to be. The text in them is still a reasonable size but the toolbars take up twice the vertical space they used to. This has nothing to do with the size of the page I'm viewing so Ctrl+ or Ctgrl- has no effect. Thanks for any help. Attached is a screen shot showing the wasted space at the top of my screen with the new toolbars.

Chosen solution

cor-el said

You can try to set a different default fonts in the Linux system preferences in case Firefox tries to use a font with properties that doesn't work well.

I revisited this. Changing fonts didn't make any difference but 'Text Scaling Factor' nudged down one tenth did bring the size of the toolbars down again. Interesting that the scaling changed somehow with an upgrade.

Read this answer in context 0
jscher2000
  • Top 10 Contributor
8838 solutions 72240 answers

Oops, the screenshot didn't post. Common problem. You can attach it to a reply to yourself: https://support.mozilla.org/questions/1164504#question-reply

Also, do you generally update as versions are released -- so this is a new problem in Firefox 54 compared with Firefox 53 -- or do you tend to skip versions? You may be able to find your immediately previous version listed on the Troubleshooting Information page. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table, there usually is a row for Update history.

Finally, could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? (More info: Troubleshoot Firefox issues using Safe Mode)

Oops, the screenshot didn't post. Common problem. You can attach it to a reply to yourself: https://support.mozilla.org/questions/1164504#question-reply Also, do you generally update as versions are released -- so this is a new problem in Firefox 54 compared with Firefox 53 -- or do you tend to skip versions? You may be able to find your immediately previous version listed on the Troubleshooting Information page. Either: * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table, there usually is a row for Update history. Finally, could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement? (More info: [[Troubleshoot Firefox issues using Safe Mode]])
cor-el
  • Top 10 Contributor
  • Moderator
17692 solutions 160067 answers

It could that there are some icons on that toolbar that are that large that the toolbar gets that huge.

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

It could that there are some icons on that toolbar that are that large that the toolbar gets that huge. Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

Question owner

Thanks for the quick reply. Yeah, I tried to upload an image that was too big. I immediately realized that but once the image upload started, it wouldn't time out and there was no way for me to stop it so I just posted. I went back and tried to edit the post and put the photo in but couldn't find a way to edit. Well, I've resized it and will add it to this post as you suggested.

I update Firefox as updates come available. This is the first time there's been anything amiss. It doesn't hurt the way Firefox works, it just takes up a good portion of the top of my screen unnecessarily. It's nice to have as much monitor space available as possible.

"Show Update History" doesn't do anything so I can't tell you what the previous version was but it was the most recent one prior to this update. 53.xx for certain.

I tried 'safe mode' and there was no difference in the toolbar height.

My wife upgraded her Windows Firefox and the problem wasn't in that version. My OS is Linux Mint 17.3 Cinnamon 64-Bit.

Thanks for the quick reply. Yeah, I tried to upload an image that was too big. I immediately realized that but once the image upload started, it wouldn't time out and there was no way for me to stop it so I just posted. I went back and tried to edit the post and put the photo in but couldn't find a way to edit. Well, I've resized it and will add it to this post as you suggested. I update Firefox as updates come available. This is the first time there's been anything amiss. It doesn't hurt the way Firefox works, it just takes up a good portion of the top of my screen unnecessarily. It's nice to have as much monitor space available as possible. "Show Update History" doesn't do anything so I can't tell you what the previous version was but it was the most recent one prior to this update. 53.xx for certain. I tried 'safe mode' and there was no difference in the toolbar height. My wife upgraded her Windows Firefox and the problem wasn't in that version. My OS is Linux Mint 17.3 Cinnamon 64-Bit.

Question owner

Thanks for the reply, cor-el. None of the icons are oversized that I can tell. In fact, they are the same ones that were fine in the previous version before the upgrade.

I'm considering a fresh install of Linux Mint 18.1 Cinnamon and may just wait to see if the problem is the same in that version before I start messing with replacing Firefox just yet. Thanks for the information on how to get that done. It might come in handy.

Thanks for the guidance on this.

Thanks for the reply, cor-el. None of the icons are oversized that I can tell. In fact, they are the same ones that were fine in the previous version before the upgrade. I'm considering a fresh install of Linux Mint 18.1 Cinnamon and may just wait to see if the problem is the same in that version before I start messing with replacing Firefox just yet. Thanks for the information on how to get that done. It might come in handy. Thanks for the guidance on this.
bygabyga 15 solutions 171 answers

In order to change your Firefox Configuration please do the following:

  1. In the address bar, type about:config and press the Enter key.
  2. The about:config "This might void your warranty!" warning page may appear.
    Click I accept the risk! to continue to the about:config page.

Search for layout.css.devPixelsPerPx and make sure it's not bold.

If it is - right click it and select Reset (or set to -1.0).

In order to change your Firefox Configuration please do the following: # In the [[Awesome Bar - Search your Firefox bookmarks, history and tabs from the address bar|address bar]], type '''about:config''' and press the '''Enter''' key. # The about:config "''This might void your warranty!''" warning page may appear.<br> Click '''I accept the risk!''' to continue to the about:config page. Search for '''layout.css.devPixelsPerPx''' and make sure it's ''not'' '''bold'''. If it is - right click it and select Reset (or set to <code>-1.0</code>).

Question owner

Thank you for the assistance, bygabyga. I checked the layout.css.devPixelsPerPx and the value is already -1.0. Also, the Status is 'default' and type is 'string'. Would there be a different value to put in there that would change the size of the toolbar height?

Thank you for the assistance, bygabyga. I checked the layout.css.devPixelsPerPx and the value is already -1.0. Also, the Status is 'default' and type is 'string'. Would there be a different value to put in there that would change the size of the toolbar height?
jscher2000
  • Top 10 Contributor
8838 solutions 72240 answers

That preference is something of a global zoom factor, so it enlarges or reduces everything in proportion.

A value of -1 uses the OS default (on Windows, called Text Size), while 1.0 uses 96dpi.

That preference is something of a global zoom factor, so it enlarges or reduces everything in proportion. A value of -1 uses the OS default (on Windows, called Text Size), while 1.0 uses 96dpi.

Question owner

jscher2000 said

That preference is something of a global zoom factor, so it enlarges or reduces everything in proportion. A value of -1 uses the OS default (on Windows, called Text Size), while 1.0 uses 96dpi.

Thanks for the quick reply. Since I use Linux, could there be a conflict there?

''jscher2000 [[#answer-978673|said]]'' <blockquote> That preference is something of a global zoom factor, so it enlarges or reduces everything in proportion. A value of -1 uses the OS default (on Windows, called Text Size), while 1.0 uses 96dpi. </blockquote> Thanks for the quick reply. Since I use Linux, could there be a conflict there?
jscher2000
  • Top 10 Contributor
8838 solutions 72240 answers

rglm said

Since I use Linux, could there be a conflict there?

This method of determining the default "zoom level" has been in Linux versions of Firefox for several versions, so I don't think there would be a sudden change in behavior. Do you recall what versions you were using before your last update, i.e., Firefox 53 or something much older?

Your (tiny!) screenshot, to the extent I can see it, seems pretty normal to me. If you were used to having very little blank space above and below the icons on your bars, is it possible that a custom style rule or extension that was tightening up your layout has stopped working?

''rglm [[#answer-978674|said]]'' <blockquote>Since I use Linux, could there be a conflict there? </blockquote> This method of determining the default "zoom level" has been in Linux versions of Firefox for several versions, so I don't think there would be a sudden change in behavior. Do you recall what versions you were using before your last update, i.e., Firefox 53 or something much older? Your (tiny!) screenshot, to the extent I can see it, seems pretty normal to me. If you were used to having very little blank space above and below the icons on your bars, is it possible that a custom style rule or extension that was tightening up your layout has stopped working?

Question owner

jscher2000 said

rglm said
Since I use Linux, could there be a conflict there?

This method of determining the default "zoom level" has been in Linux versions of Firefox for several versions, so I don't think there would be a sudden change in behavior. Do you recall what versions you were using before your last update, i.e., Firefox 53 or something much older?

Your (tiny!) screenshot, to the extent I can see it, seems pretty normal to me. If you were used to having very little blank space above and below the icons on your bars, is it possible that a custom style rule or extension that was tightening up your layout has stopped working?

I always keep firefox updated so the last version would be 53.[something]. I haven't used any custom style rule or extension. All I've messed with are the standard settings in 'Preferences'. All I did was to upgrade the previous Linux version to the most recent release. The toolbars in my wife's Windows version are still smaller, the way mine used to be. This must be some glitch in the current version that will hopefully get corrected.

''jscher2000 [[#answer-978676|said]]'' <blockquote> ''rglm [[#answer-978674|said]]'' <blockquote>Since I use Linux, could there be a conflict there? </blockquote> This method of determining the default "zoom level" has been in Linux versions of Firefox for several versions, so I don't think there would be a sudden change in behavior. Do you recall what versions you were using before your last update, i.e., Firefox 53 or something much older? Your (tiny!) screenshot, to the extent I can see it, seems pretty normal to me. If you were used to having very little blank space above and below the icons on your bars, is it possible that a custom style rule or extension that was tightening up your layout has stopped working? </blockquote> I always keep firefox updated so the last version would be 53.[something]. I haven't used any custom style rule or extension. All I've messed with are the standard settings in 'Preferences'. All I did was to upgrade the previous Linux version to the most recent release. The toolbars in my wife's Windows version are still smaller, the way mine used to be. This must be some glitch in the current version that will hopefully get corrected.
bygabyga 15 solutions 171 answers

I also use GNU/Linux and Firefox from mozilla. I don't observe any issue.

Could it be something related to Mint or the GTK theme you're using? Is the menu bar intentionally shown?

Maybe use ESR for the time being.

I also use GNU/Linux and Firefox from mozilla. I don't observe any issue. Could it be something related to Mint or the GTK theme you're using? Is the menu bar intentionally shown? Maybe use [https://www.mozilla.org/en-US/firefox/organizations/ ESR] for the time being.

Modified by bygabyga

Question owner

I have the 'menu bar' and 'bookmarks toolbar' checked. They were checked before the upgrade, though. I made no changes after upgrading to 54.0 other than to adjust the zoom level for sites, which got really blown up and needed to be reduced. Of course changing the site zoom level doesn't affect the toolbars. I unchecked them then re-checked them in case there was some glitch there but nothing changed. Everything is the same except for the oversized toolbars. Almost 24% of my monitor height is filled with the toolbars. That's excessive.

I have one laptop with Linux Mint 18.1 on it and will upgrade Firefox on that to see if the same thing happens. Will report back with the results.

I have the 'menu bar' and 'bookmarks toolbar' checked. They were checked before the upgrade, though. I made no changes after upgrading to 54.0 other than to adjust the zoom level for sites, which got really blown up and needed to be reduced. Of course changing the site zoom level doesn't affect the toolbars. I unchecked them then re-checked them in case there was some glitch there but nothing changed. Everything is the same except for the oversized toolbars. Almost 24% of my monitor height is filled with the toolbars. That's excessive. I have one laptop with Linux Mint 18.1 on it and will upgrade Firefox on that to see if the same thing happens. Will report back with the results.

Question owner

Later:00

I just upgraded Firefox in my Mint 18.1 laptop. It's fine. Also upgraded the Firefox in my wife's desktop with Mint 17.3 (the same as this computer) and it is also fine. This seems to be the only computer with that issue. I'll look into reverting back to Firefox 53.0.3, which my other computer had on it before the upgrade and I think is what I had before.

As long as I was fiddling around with the system, I checked to see if I had the recommended (latest) video driver for my system and I do.

Later:00 I just upgraded Firefox in my Mint 18.1 laptop. It's fine. Also upgraded the Firefox in my wife's desktop with Mint 17.3 (the same as this computer) and it is also fine. This seems to be the only computer with that issue. I'll look into reverting back to Firefox 53.0.3, which my other computer had on it before the upgrade and I think is what I had before. As long as I was fiddling around with the system, I checked to see if I had the recommended (latest) video driver for my system and I do.

Question owner

I just posted on the Linux Mint Forum about this and will report back anything they may have to suggest.

I just posted on the Linux Mint Forum about this and will report back anything they may have to suggest.

Question owner

Okey-doke. On the Mint forum it was suggested by one of the senior members there to exit FF, rename my FF profile then restart to create a new one to see if the profile had been corrupted. With a newly created profile, the toolbars were still over sized so I deleted that profile and renamed my old one back.

It was also suggested that for security reasons, it wasn't wise to revert to an older version. Looks like I may have to live with it this way for now.

Thanks for all the help and guidance.

Okey-doke. On the Mint forum it was suggested by one of the senior members there to exit FF, rename my FF profile then restart to create a new one to see if the profile had been corrupted. With a newly created profile, the toolbars were still over sized so I deleted that profile and renamed my old one back. It was also suggested that for security reasons, it wasn't wise to revert to an older version. Looks like I may have to live with it this way for now. Thanks for all the help and guidance.
cor-el
  • Top 10 Contributor
  • Moderator
17692 solutions 160067 answers

You can try to set a different default fonts in the Linux system preferences in case Firefox tries to use a font with properties that doesn't work well.

You can try to set a different default fonts in the Linux system preferences in case Firefox tries to use a font with properties that doesn't work well.

Question owner

cor-el said

You can try to set a different default fonts in the Linux system preferences in case Firefox tries to use a font with properties that doesn't work well.

Thanks for the suggestion. I looked at that but the font doesn't appear to be the problem. I can make them larger, smaller or change font style but the toolbars remain oversized.

''cor-el [[#answer-978784|said]]'' <blockquote> You can try to set a different default fonts in the Linux system preferences in case Firefox tries to use a font with properties that doesn't work well. </blockquote> Thanks for the suggestion. I looked at that but the font doesn't appear to be the problem. I can make them larger, smaller or change font style but the toolbars remain oversized.

Chosen Solution

cor-el said

You can try to set a different default fonts in the Linux system preferences in case Firefox tries to use a font with properties that doesn't work well.

I revisited this. Changing fonts didn't make any difference but 'Text Scaling Factor' nudged down one tenth did bring the size of the toolbars down again. Interesting that the scaling changed somehow with an upgrade.

''cor-el [[#answer-978784|said]]'' <blockquote> You can try to set a different default fonts in the Linux system preferences in case Firefox tries to use a font with properties that doesn't work well. </blockquote> I revisited this. Changing fonts didn't make any difference but 'Text Scaling Factor' nudged down one tenth did bring the size of the toolbars down again. Interesting that the scaling changed somehow with an upgrade.