Search Support

Sync does not work and is stuck on loading

more options

Disconnected my account on sync page and when I tried to sync again it just says "working" endlessly...Tried to reset computer and ff with nothing happening. Every time I try to sync again, the result is the same.

Chosen solution

Note this issue is fixed in a Pre Release version of Firefox and a note has been added to the Fx 50 Release Notes about it being a known issue. Once the fix is in Firefox you may use Private Browsing or Not Remembering History without it affecting Sync.

We are hoping that the fix may be included in a special version Fx50.1 Release planned shortly.


Forum Notes

Read this answer in context 👍 0

All Replies (20)

more options

Hi   !
Over the past few days a lot of people have reported the same problem, and we are trying to figure out what's going on. Usually when this gets stuck on   'Working',   it means that some error has occurred. Could you please check in the web developer console for any errors or failing network requests   ?   (press :   Ctrl + Shift + k )
It would be great if you could provide a screenshot:
If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

more options

Hi Happy,

I've gone ahead and done as you asked. It shows two errors.

Hope this helps.

Cheers.

more options

Hi Happy,

I've gone ahead and done as you asked. It shows two errors.

Hope this helps.

Cheers.

more options

Thank you so much for going through all that trouble   ! This is way over my head;   I sure hope that somebody will figure out what's going on here and come up with a solution.

more options

I was, however, hoping you could provide a screenshot of the web developer console   (after you've clicked   Ctrl + Shift + k )   .....

more options

Personally I do not like using Sync neither do I have a good understanding of it so I am hoping someone else will chip in, meanwhile: If you can get a screen shot of the Console it may help. As a general tip give Sync a long time say 1/2 an hour if it says it is working just in case it does sort it self out with enough time.

What items have you you set Sync to sync ? And what are you syncing with another computer or an Android phone for instance. Please look at

Update In fact the correct status page is apparently https://status.services.mozilla.com/

Modified by John99

more options

Looks like the Console to me at the bottom of those screenshots.

Working. Response not received for: fxaccounts:can_link_account


I suspect that has been going on since Thursday or maybe even Wednesday. Like the last person out the door for the 4-day holiday weekend turned off the lights and inadvertently flipped an additional switch that turned of a Sync server.

more options

Thanks Ed, I had not noticed that at the bottom of the screenshots.

Sorry enixforeva I did not scroll your screenshot to see what else was included so missed the part showing the screenshot, as apparently did Happy112.

more options

John99 said

Thanks Ed, I had not noticed that at the bottom of the screenshots. Sorry enixforeva I did not scroll your screenshot to see what else was included so missed the part showing the screenshot, as apparently did Happy112.

Yes:   thank you Ed   !
And to   'fenixforeva' :   I owe you an appology,   big time   !!!
I hang my head in shame and I'm going to crawl under a rock now   .....

more options

Just an observation. I enabled Firefox Sync for test purposes. Sync Works for me right now. I did enable it and Sync bookmarks and addons successfully. I did get at least one error log, but the addons and bookmarks I Synced look ok and as would be expected at least from a cursory examination.

Possibly the issue is now fixed. Or possibly it is not affecting everyone. I also did an extremly quick bugzilla search and did not find anything.


At one time input allowed ordinary users to see the results grphed over time, we are no longer permitted access to that so it is dificult to tel if somethoing is spiking, but I guess the results we are allowed to see are not too unusual for instance:


Ed if you are around still, does Sync work for you ?

more options

To John:
The problem is not that Sync isn't working;   it is logging in getting stuck on 'Working'  .......

more options

John99 said

Just an observation. I enabled Firefox Sync for test purposes. Sync Works for me right now. I did enable it and Sync bookmarks and addons successfully. I did get at least one error log, but the addons and bookmarks I Synced look ok and as would be expected at least from a cursory examination. Possibly the issue is now fixed. Or possibly it is not affecting everyone. I also did an extremly quick bugzilla search and did not find anything.

At one time input allowed ordinary users to see the results grphed over time, we are no longer permitted access to that so it is dificult to tel if somethoing is spiking, but I guess the results we are allowed to see are not too unusual for instance:


Ed if you are around still, does Sync work for you ?

I have been "connected" for weeks now and Sync seems to work. But it is of no real use to me with only one device and no 2nd Sync Profile on that device. Maybe I'll create another Profile to see if I can duplicate the problem. But, I wonder of "mobile" might be involved? Where one one of the devices connected to the OP's Sync account is using Firefox for iOS or Firefox for Android? IMO, there is a long standing issue with Sync services on "mobile" that dates back to May 2015 (or thereabouts).

more options

Oh, there used to be a hidden pref for turning on the Sync error log to create a log of all Sync events. But that pref seems to be gone in all the Firefox versions that I currently have installed. I wonder of that "Working ..." glitch will trigger a Sync error log?

IMO this situation has been building for almost a week and with this being the end of a 4 day holiday weekend we should wait for Mozilla staff to look into it tomorrow. In addition to here I have seen mention of this over at mozillaZine and at Reddit since Wednesday, iirc.

more options

Hi again fenixforeva In case it is relevant could you answer my earlier questions

  • What items have you you set Sync to sync ?
  • And what are you syncing with another computer or an Android phone for instance.
  • Have you got a recent Sync Log from one of the days when you have this issue ?

Thanks Ed. I don't mind Syncing between computers or different profiles but I am not going to try out on my Android phone it may make a mess of it.

Not sure about hidden prefs, but an easier method may be the add-on

I think maybe the pref and value to increase the logging is

services.sync.log.appender.file.level; All

and may be set and changed, with the add-on to: All or Trace

I guess it is not going to work as long as error

Response not received for: fxaccounts:can_link_account  

is seen, but that is apparently not affecting everyone, so as you say maybe it is a fault at Mozilla's end, but it could also be for instance third party security software interfering. I don't really know what sort of percentage of the userbase use Sync, but I note the feedback is showing more other errors than the not working issue.

As you say lets see what if anything happens on Monday.

more options

P,S. The status check specific to Sync is apparently

more options

Same as I have been seeing for the last week or so when I first became aware that there might be a problem based upon users mentioning here in Support that they had a problem. Firefox Accounts The service is up Firefox Sync The service is up


OK, I just added an almost default Profile to my Sync account. No problem connecting and the little bit of data I have in Sync did Synchronize properly.

No problem Disconnecting and then Connecting again on either Profile.

Not seeing a problem here with it getting stuck at "Loading ..." .

more options

Will you do this please: 3-bar menu > Options > Privacy > History > Make sure you set it to : Remember History   ( and definately not to Never remember history )

more options

Hey, Sorry for the late reply... things got a little crazy.

I had all sync options selected with never remember history. I just got a message from happy now telling me to change it to remember history and that seems to have solved it...

I feel a bit silly now as I dunno if that was the solution all along or it was something else. Either way now I know and can keep my sync.

Thanks everyone for your assistance, and thanks happy, its all good :)

more options

I was just about to tell you here what you apparantly already read in another thread   (but I'm going to do it here as well) : 3-bar menu > Options > Privacy > History > and make sure it's set to   Remember History   (and definately not to   Never Remember History ).

more options

Chosen Solution

Note this issue is fixed in a Pre Release version of Firefox and a note has been added to the Fx 50 Release Notes about it being a known issue. Once the fix is in Firefox you may use Private Browsing or Not Remembering History without it affecting Sync.

We are hoping that the fix may be included in a special version Fx50.1 Release planned shortly.


Forum Notes

  1. 1
  2. 2