X
Tap here to go to the mobile version of the site.

Support Forum

Mozilla vs Wordpress

Posted

I am having a problem with the view in Mozilla when attempting to access my blog on Wordpress.

I posted in the Wordpress forum- https://en.forums.wordpress.com/topic/desktop-apbrowser-using-browser-returns-locked-pages?replies=1#post-2785273 - before I realized the issues is with Mozilla and not my other browsers e.g. IE & Chrome.

I will have to link back to this forum because I am not able to upload a screenshot in the WP forum. I apologize for any confusion. In fact, if you follow the link to the WP form I go into detail.

In light of repeating myself, I realize the screenshot shows my add-ons, but I have attempted to view the pages in safe mode, thus disabling my add-ons. I have also cleared my cache (I do that regularly) and dumped whatever cookies I had and set the browser to accept "sll" cookies, I had been only accepting cookies from sites I visited merely to avoid tracking cookies.

As I said, I go into more depth on the WP forum, mostly because I suspected WP. I was making a post yesterday in one tab and updating one in another and strangely, I had a normal view in the new post page and this blank view in the tab I of the post I was trying to update. At the time, I didn't give it a lot of thought. I simply thought it was a glitch. However, today every link from the front page leads to a blank page like the one in my screenshot, with the highlight in the address bar.

Mind you, if you read my post in the WP forum, they did release an update for their desktop application yesterday/today, and so I still wanted to believe the fault was with them, and it still may be and yet the pages view find in IE.

????????

I'm truly stumped.

I would hate to have to do a clean reinsall of Firefox entirely because I am not sure if it is all Mozilla except that I only get the blank view in Mozilla and not IE.

I am going to link my WP forum Post back to this one so, hoefully, someone can see the screenshot.

As always, any help would be appreciated.

Thank you.

I am having a problem with the view in Mozilla when attempting to access my blog on Wordpress. I posted in the Wordpress forum- https://en.forums.wordpress.com/topic/desktop-apbrowser-using-browser-returns-locked-pages?replies=1#post-2785273 - before I realized the issues is with Mozilla and not my other browsers e.g. IE & Chrome. I will have to link back to this forum because I am not able to upload a screenshot in the WP forum. I apologize for any confusion. In fact, if you follow the link to the WP form I go into detail. In light of repeating myself, I realize the screenshot shows my add-ons, but I have attempted to view the pages in safe mode, thus disabling my add-ons. I have also cleared my cache (I do that regularly) and dumped whatever cookies I had and set the browser to accept "sll" cookies, I had been only accepting cookies from sites I visited merely to avoid tracking cookies. As I said, I go into more depth on the WP forum, mostly because I suspected WP. I was making a post yesterday in one tab and updating one in another and strangely, I had a normal view in the new post page and this blank view in the tab I of the post I was trying to update. At the time, I didn't give it a lot of thought. I simply thought it was a glitch. However, today every link from the front page leads to a blank page like the one in my screenshot, with the highlight in the address bar. Mind you, if you read my post in the WP forum, they did release an update for their desktop application yesterday/today, and so I still wanted to believe the fault was with them, and it still may be and yet the pages view find in IE. ???????? I'm truly stumped. I would hate to have to do a clean reinsall of Firefox entirely because I am not sure if it is all Mozilla except that I only get the blank view in Mozilla and not IE. I am going to link my WP forum Post back to this one so, hoefully, someone can see the screenshot. As always, any help would be appreciated. Thank you.
Attached screenshots

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.20.20039
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.16
  • Google Update
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.111.2 for Mozilla browsers
  • NPWLPG
  • Shockwave Flash 23.0 r0
  • 5.1.50901.0

Application

  • Firefox 49.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
  • Support URL: https://support.mozilla.org/1/firefox/49.0.2/WINNT/en-US/

Extensions

  • Adblock Plus 2.8.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Adblock Plus Pop-up Addon 0.9.2.1-signed.1-signed (adblockpopups@jessehakanen.net)
  • Asynchronous Plugin Rendering 2.0 (asyncrendering@mozilla.org)
  • Classic Theme Restorer 1.5.8.1 (ClassicThemeRestorer@ArisT2Noia4dev)
  • Disconnect 3.15.3.1-signed.1-signed (2.0@disconnect.me)
  • Fasterfox 3.9.85.1-signed.1-signed ({c36177c0-224a-11da-8cd6-0800200c9a91})
  • Lightbeam 1.3.1 (jid1-F9UJ2thwoAm5gQ@jetpack)
  • Multi-process staged rollout 1.3 (e10srollout@mozilla.org)
  • Pocket 1.0.4 (firefox@getpocket.com)
  • SaveFrom.net helper 6.20 (helper@savefrom.net)
  • Stylish 2.0.7 ({46551EC9-40F0-4e47-8E18-8E5CF550CFB8})
  • Web Compat 1.0 (webcompat@mozilla.org)
  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • CacheViewer 0.8.6.3.1-let-fixed ({71328583-3CA7-4809-B4BA-570A85818FBB}) (Inactive)
  • RightToClick 2.9.6 ({cd617375-6743-4ee8-bac4-fbf10f35729e}) (Inactive)
  • Weather Forecast Plus 0.3.1 (jid1-aqwHRwQpv3JUMs@jetpack) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4600
  • adapterDescription2:
  • adapterDeviceID: 0x0412
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 78461462
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • crashGuards: []
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.21976
  • driverDate: 6-14-2013
  • driverDate2:
  • driverVersion: 9.18.10.3215
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'disabled', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'disabled', u'message': u'Disabled by pref', u'type': u'user'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct2D', u'log': [{u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'unavailable', u'message': u'D3D11 compositing is disabled', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}], u'name': u'D3D11_HW_ANGLE'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 2
  • supportsHardwareH264: No; Hardware video decoding disabled or blacklisted
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4600 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: Yes

Question owner

I just noticed something, strangely, or not, there is a similar highlight text in the address bar of this page.

Hm....

I just noticed something, strangely, or not, there is a similar highlight text in the address bar of this page. Hm....
FredMcD
  • Top 10 Contributor
4269 solutions 59862 answers

Helpful Reply

springheel said

I would hate to have to do a clean reinstall of Firefox entirely

If you decide to do this;

Let’s do a full clean re-install; Download Firefox For All languages And Systems {web link} Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Mac: Open the "Applications" folder.
https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory.

Do Not remove the profiles folder.

Look for, and rename any Mozilla or Firefox program folders by adding .old to them. Do not rename the Mozilla Thunderbird folder if there is one.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. If all goes well, remove the OLD folders when you are done.


If there is a problem, start your Computer in safe mode and try again.

Starting The Computer In Safe Mode;
Free Online Encyclopedia

''springheel [[#question-1146077|said]]'' <blockquote> I would hate to have to do a clean reinstall of Firefox entirely </blockquote> If you decide to do this; Let’s do a full clean re-install; '''[http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems]''' {web link} Save the file. Then '''Close Firefox.''' Using your file browser, open the '''Programs Folder''' on your computer. '''Windows:''' C:\Program Files C:\Program Files (x86) '''Mac:''' Open the "Applications" folder.<br>https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac '''Linux:''' Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install [https://support.mozilla.org/en-US/kb/install-firefox-linux Firefox on Linux]. If you downloaded and installed the binary package from the [http://www.mozilla.org/firefox#desktop Firefox download page,] simply remove the folder Firefox in your home directory. '''Do Not''' remove the profiles folder. Look for, and rename any '''Mozilla''' or '''Firefox''' program folders by adding '''.old''' to them. Do not rename the '''Mozilla Thunderbird''' folder if there is one. After rebooting the computer, run a registry scanner if you have one. Then run the installer. If all goes well, remove the OLD folders when you are done. --------- If there is a problem, start your '''Computer''' in safe mode and try again. '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''
FredMcD
  • Top 10 Contributor
4269 solutions 59862 answers

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?


Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? --------------- Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' websites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''

Question owner

Thanks for the information, Fred. I have tried Mozilla in safe mode and the problem still exists.

I've also done a clean install before, but if I remember correctly, you do need to delete the Profiles folder or you risk corrupting the new installation. All the same, thanks for a very detailed method. I will be saving that for future reference.

Nevertheless, I am reluctant to do a fresh install The site views fine in IE, and I have had conflicts before with Wordpress and Mozilla. The only real change in the past couple of days is that WP updated their new desktop ap.

When they first released it this summer, I could not access the Reader until I installed the ap. I didn't give it much thought at the time, though I thought it was strange, and I never tried to access the Reader in my other browsers.

This is especially frustrating, because of the glitch, I cannot actually access a proper forum on WP. I get the same blank page for there normal support.

https://en.support.wordpress.com/

I had posted a query there not but a month or so ago that the theme on a particular blog wasn't showing properly. I would like to believe this is the case except I have the same experience on two other WP blogs,

This makes me want to blame WP. The fact that I can view the site normally in IE makes me want to blame Mozilla.

In hindsight, since I should be able to view the support page properly in IE, I should use my other browser to make a post in the proper support forum.

Thank you for your response.

Thanks for the information, Fred. I have tried Mozilla in safe mode and the problem still exists. I've also done a clean install before, but if I remember correctly, you do need to delete the Profiles folder or you risk corrupting the new installation. All the same, thanks for a very detailed method. I will be saving that for future reference. Nevertheless, I am reluctant to do a fresh install The site views fine in IE, and I have had conflicts before with Wordpress and Mozilla. The only real change in the past couple of days is that WP updated their new desktop ap. When they first released it this summer, I could not access the Reader until I installed the ap. I didn't give it much thought at the time, though I thought it was strange, and I never tried to access the Reader in my other browsers. This is especially frustrating, because of the glitch, I cannot actually access a proper forum on WP. I get the same blank page for there normal support. https://en.support.wordpress.com/ I had posted a query there not but a month or so ago that the theme on a particular blog wasn't showing properly. I would like to believe this is the case except I have the same experience on two other WP blogs, This makes me want to blame WP. The fact that I can view the site normally in IE makes me want to blame Mozilla. In hindsight, since I should be able to view the support page properly in IE, I should use my other browser to make a post in the proper support forum. Thank you for your response.
FredMcD
  • Top 10 Contributor
4269 solutions 59862 answers

springheel said

Thanks for the information, Fred. I have tried Mozilla in safe mode and the problem still exists.

What about the Computer in Safe Mode?


Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.

''springheel [[#answer-933894|said]]'' <blockquote> Thanks for the information, Fred. I have tried Mozilla in safe mode and the problem still exists. </blockquote> What about the '''Computer''' in Safe Mode? --------------- '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Safe Mode]''' is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.

Question owner

Actually, I just did.

I had forgotten how huge & blocky safe mode looks. Unfortunately, I am still getting the same view

I did use IE and made another post on what I feel is WP's proper support forum, or at least it's the one where they responded to the glitch in my theme a month or so back.

I also linked it back to this forum.

We'll see how they respond.

Again, thank you.

Actually, I just did. I had forgotten how huge & blocky safe mode looks. Unfortunately, I am still getting the same view I did use IE and made another post on what I feel is WP's proper support forum, or at least it's the one where they responded to the glitch in my theme a month or so back. I also linked it back to this forum. We'll see how they respond. Again, thank you.

Question owner

I want to thank you again for all the detailed information; I have saved it to an email.

I was curious, since I had no luck going into safe mode with my pc, is it worth trying a Refresh of the Mozilla browser?

I say that before I take the time to do a complete re-install, and yet I am not certain that some of the blame is with WP.

I tried uninstalling their ap, with no success.

When i look at the highlighted site in the address bar, I notice that It's pretty much stating that I am on a secure page.

That I am--logged in?

I have that same thing on the wp press page that I--can't--view.

For some reason or another I think that is pertinent. Even though I am logged into the site, and can in fact visit the page, that is apparently secured, it won't let me load the information.

If that makes any sense.

Just a thought. I can't seem to get a response from WP support. Unfortunately I can't upload a screenshot to their forum. I would have to post it to a blog, on a page, I cannot access.

I want to thank you again for all the detailed information; I have saved it to an email. I was curious, since I had no luck going into safe mode with my pc, is it worth trying a Refresh of the Mozilla browser? I say that before I take the time to do a complete re-install, and yet I am not certain that some of the blame is with WP. I tried uninstalling their ap, with no success. When i look at the highlighted site in the address bar, I notice that It's pretty much stating that I am on a secure page. That I am--logged in? I have that same thing on the wp press page that I--can't--view. For some reason or another I think that is pertinent. Even though I am logged into the site, and can in fact visit the page, that is apparently secured, it won't let me load the information. If that makes any sense. Just a thought. I can't seem to get a response from WP support. Unfortunately I can't upload a screenshot to their forum. I would have to post it to a blog, on a page, I cannot access.
FredMcD
  • Top 10 Contributor
4269 solutions 59862 answers

springheel said

since I had no luck going into safe mode with my pc,

Is there a problem getting the computer to start in Safe Mode?

Starting The Computer In Safe Mode; Free Online Encyclopedia http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode

is it worth trying a Refresh of the Mozilla browser?

Let's try this first. Use these links to create a new profile. Use this new profile as is. Is the problem still there?

http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder

https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible


Type about:profiles<enter> in the address bar.


Refresh Firefox {web link} is a LAST RESORT ! !

Refresh Firefox - reset add-ons and settings

If you're having problems with Firefox, refreshing it can help. The refresh feature fixes many issues by restoring Firefox to its default state while saving your essential information like bookmarks, passwords, and open tabs.

''springheel [[#answer-934021|said]]'' <blockquote> since I had no luck going into safe mode with my pc, </blockquote> Is there a problem getting the computer to start in Safe Mode? Starting The Computer In Safe Mode; Free Online Encyclopedia http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode <blockquote> is it worth trying a Refresh of the Mozilla browser? </blockquote> Let's try this first. Use these links to create a new profile. Use this new profile '''as is.''' Is the problem still there? '''http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder''' '''https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles''' '''https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible''' Type '''about:profiles'''<enter> in the address bar. -------------------- '''[https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings Refresh Firefox]''' {web link} is a '''LAST RESORT ! !''' Refresh Firefox - reset add-ons and settings If you're having problems with Firefox, refreshing it can help. The refresh feature fixes many issues by restoring Firefox to its default state while saving your essential information like bookmarks, passwords, and open tabs.

Question owner

I should clarify, when I say I had no luck, I meant I had no luck in getting a normal view of the page while my computer was in Safe mode. Anymore than I did while the browser was in Safe mode.

I've been using Firefox since Netscape. I've learned to save my bookmarks, and even my search engines, in a folder other than the profile folder. I am a fanatic about backing up.

Consequently, I get a new machine, I plug in my expansion drive and I'm up and running in minutes except for installing a couple of programs. Reinstalling the entire browser is merely a pain I would avoid if i could because I am visually handicapped and I have to make some tweaks here and there with add ons.

I think what I'm afraid of, is that if I do re-install it, that I will still have the same problem. as I've had conflicts in the past with Mozilla and WP.

Still, I favor Firefox, because I truly feel it is the most handicap assailable browser out there even if I have to make a few tweaks.

I will work on this new profile thing tomorrow and give it my best shot. i will let you know how it works.

Thank you again for all the information.

All of your posts have been helpful. They simply haven't solved my problem. I can't help but think some of the problem lies with WP because the issue coincided with their ap update.

I should clarify, when I say I had no luck, I meant I had no luck in getting a normal view of the page while my computer was in Safe mode. Anymore than I did while the browser was in Safe mode. I've been using Firefox since Netscape. I've learned to save my bookmarks, and even my search engines, in a folder other than the profile folder. I am a fanatic about backing up. Consequently, I get a new machine, I plug in my expansion drive and I'm up and running in minutes except for installing a couple of programs. Reinstalling the entire browser is merely a pain I would avoid if i could because I am visually handicapped and I have to make some tweaks here and there with add ons. I think what I'm afraid of, is that if I do re-install it, that I will still have the same problem. as I've had conflicts in the past with Mozilla and WP. Still, I favor Firefox, because I truly feel it is the most handicap assailable browser out there even if I have to make a few tweaks. I will work on this new profile thing tomorrow and give it my best shot. i will let you know how it works. Thank you again for all the information. All of your posts have been helpful. They simply haven't solved my problem. I can't help but think some of the problem lies with WP because the issue coincided with their ap update.
FredMcD
  • Top 10 Contributor
4269 solutions 59862 answers

I called for more help.

I called for more help.

Question owner

You're doing fine. Trust me.

I needed to learn more about this profile thing anyway.

I know the path. I have the ap data folder unbidden. This is how I went in and backed up all my search engines and saved them to my documents.

I had a guy at Apple tell me I couldn't save my iPhone back up and I told him yes you can. It's virtually the same path except in an Apple folder and I have all my phone backups saved to my documents as well.

I suppose logically, it would work, if the configuration of the browser hasn't been compromise, and I haven't been poking around in there so much.

I love this stuff, this is how we learn. :)

You're doing fine. Trust me. I needed to learn more about this profile thing anyway. I know the path. I have the ap data folder unbidden. This is how I went in and backed up all my search engines and saved them to my documents. I had a guy at Apple tell me I couldn't save my iPhone back up and I told him yes you can. It's virtually the same path except in an Apple folder and I have all my phone backups saved to my documents as well. I suppose logically, it would work, if the configuration of the browser hasn't been compromise, and I haven't been poking around in there so much. I love this stuff, this is how we learn. :)
FredMcD
  • Top 10 Contributor
4269 solutions 59862 answers

These add-ons can be a great help by backing up and restoring Firefox

FEBE (Firefox Environment Backup Extension) {web link} FEBE allows you to quickly and easily backup your Firefox extensions, history, passwords, and more. In fact, it goes beyond just backing up -- It will actually rebuild your saved files individually into installable .xpi files. It will also make backups of files that you choose.

OPIE {web link} Import/Export extension preferences

These add-ons can be a great help by backing up and restoring Firefox '''[https://addons.mozilla.org/en-US/firefox/addon/febe/ FEBE (Firefox Environment Backup Extension)]''' {web link} FEBE allows you to quickly and easily backup your Firefox extensions, history, passwords, and more. In fact, it goes beyond just backing up -- It will actually rebuild your saved files individually into installable .xpi files. It will also make backups of files that you choose. '''[https://addons.mozilla.org/en-US/firefox/addon/opie/ OPIE]''' {web link} Import/Export extension preferences

Question owner

Trying to catch up here. Got a late start. Read this reply to me on the WP support forum:

https://en.forums.wordpress.com/topic/mozilla-vs-wordpress?replies=2#post-2786672

I haven't really read it completely but his remark about the Java seemed to resonate with me. so i went to abiyt:config and the java command was missing. I then went into my plug ins and sure enough, it would seem that my java was off or corrupt or something so I went to the site and reinstalled it, even though WP is the only site that I have noticed any problems with, assuming that the problem is still pertinent to Mozilla.

After re-installing the java and confirming that it was up-to-date, was well & good in my plug-ins and showing in the about;:donfig page, i dumped the cache and rebooted the browser.

It didn't solve the problem. It still views the page incorrectly.

I may be more confused now than I was before. I actually thought I had found and fixed the issue.

Trying to catch up here. Got a late start. Read this reply to me on the WP support forum: https://en.forums.wordpress.com/topic/mozilla-vs-wordpress?replies=2#post-2786672 I haven't really read it completely but his remark about the Java seemed to resonate with me. so i went to abiyt:config and the java command was missing. I then went into my plug ins and sure enough, it would seem that my java was off or corrupt or something so I went to the site and reinstalled it, even though WP is the only site that I have noticed any problems with, assuming that the problem is still pertinent to Mozilla. After re-installing the java and confirming that it was up-to-date, was well & good in my plug-ins and showing in the about;:donfig page, i dumped the cache and rebooted the browser. It didn't solve the problem. It still views the page incorrectly. I may be more confused now than I was before. I actually thought I had found and fixed the issue.

Question owner

I see what is happening, literally.

It is the Java, and it is Mozilla. This is the message in my plug-ins concerning the Java:

'Java Deployment Toolkit 8.0.1110.14 is known to be vulnerable. Use with caution."

The browser is blocking my use of the latest version of Java. Or at least that's what it appears to be doing. Although I haven't noticed a problem with any other site.


At any rate, I cannot get it to activate at all, even in the plug-ins. The "always activate" command is grayed out.

This is the only problem I have with Mozilla, sometimes the browser is a bit too paranoid. For example, I cannot use my Adobe program as an add on in the browser anymore because for some reason or another, it won't let me use it with a 64 bit machine, and yet I have used it for nearly five years without an y incident with a 64 bit machine that suddenly, one day, Mozilla decides that I can.'t.

I don't know quite what to do. My Java has always been up to date, and it's been a while since I have updated it, at least until this morning when I made sure I had the current version--and Mozilla up and one day suddenly decides to block it.

Does Mozilla to use and out of date version?

This is so random I don't get it, but I do need to fix it.

I see what is happening, literally. It is the Java, and it is Mozilla. This is the message in my plug-ins concerning the Java: 'Java Deployment Toolkit 8.0.1110.14 is known to be vulnerable. Use with caution." The browser is blocking my use of the latest version of Java. Or at least that's what it appears to be doing. Although I haven't noticed a problem with any other site. At any rate, I cannot get it to activate at all, even in the plug-ins. The "always activate" command is grayed out. This is the only problem I have with Mozilla, sometimes the browser is a bit too paranoid. For example, I cannot use my Adobe program as an add on in the browser anymore because for some reason or another, it won't let me use it with a 64 bit machine, and yet I have used it for nearly five years without an y incident with a 64 bit machine that suddenly, one day, Mozilla decides that I can.'t. I don't know quite what to do. My Java has always been up to date, and it's been a while since I have updated it, at least until this morning when I made sure I had the current version--and Mozilla up and one day suddenly decides to block it. Does Mozilla to use and out of date version? This is so random I don't get it, but I do need to fix it.
jscher2000
  • Top 10 Contributor
8792 solutions 71899 answers

A couple comments:

Java Plugins

Most WordPress sites do not use any Java plugins. If a site wants to use Java, you should see a plugin notification icon in the address bar, to the left of the URL. It typically looks like a small, dark gray Lego block. When the page wants to use a blocked plugin, the icon turns red to alert you to the concern.

JavaScript

JavaScript is a language interpreted directly by Firefox, used on most modern websites. It's unlikely Firefox's on/off switch for JavaScript is turned off if you haven't had half the sites you visit tell you about it.

Stats page - Login redirect

When I try loading the URL in your screenshot (not 100% sure what the ending is), I end up on a login page here: https://wordpress.com/wp-login.php?redirect_to=https%3A%2F%2Fwordpress.com%2Fstats%2Fthevaleofsoulmaking.wordpress.com

I don't have a Wordpress.com account, so can't see what comes next.

Do you get the login page, or do you have Firefox log you in automatically there?

The URL indicates that after the login it will redirect back to the requested page. Make sure you aren't blocking redirects:

Windows: "3-bar" menu button (or Tools menu) > Options Mac: "3-bar" menu button (or Firefox menu) > Preferences Linux: "3-bar" menu button (or Edit menu) > Preferences

In the left column, click Advanced. On the right side, with the "General" mini-tab active, uncheck the box for "Warn me when websites try to redirect or reload the page" if it is checked.

(This is an accessibility feature intended for users of screen reading software and not a general-purpose tool of value to most users.)

A couple comments: '''Java Plugins''' Most WordPress sites do not use any Java plugins. If a site wants to use Java, you should see a plugin notification icon in the address bar, to the left of the URL. It typically looks like a small, dark gray Lego block. When the page wants to use a blocked plugin, the icon turns red to alert you to the concern. '''JavaScript''' JavaScript is a language interpreted directly by Firefox, used on most modern websites. It's unlikely Firefox's on/off switch for JavaScript is turned off if you haven't had half the sites you visit tell you about it. '''Stats page - Login redirect''' When I try loading the URL in your screenshot (not 100% sure what the ending is), I end up on a login page here: https://wordpress.com/wp-login.php?redirect_to=https%3A%2F%2Fwordpress.com%2Fstats%2Fthevaleofsoulmaking.wordpress.com ''I don't have a Wordpress.com account, so can't see what comes next.'' Do you get the login page, or do you have Firefox log you in automatically there? The URL indicates that after the login it will redirect back to the requested page. Make sure you aren't blocking redirects: Windows: "3-bar" menu button (or Tools menu) > Options Mac: "3-bar" menu button (or Firefox menu) > Preferences Linux: "3-bar" menu button (or Edit menu) > Preferences In the left column, click Advanced. On the right side, with the "General" mini-tab active, uncheck the box for "Warn me when websites try to redirect or reload the page" if it is checked. (This is an accessibility feature intended for users of screen reading software and not a general-purpose tool of value to most users.)
jscher2000
  • Top 10 Contributor
8792 solutions 71899 answers

Helpful Reply

By the way, the other thread suggested clearing cookies. You don't have to clear cookies for all sites. Instead:

While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually.

Then try reloading the page. Does that help?

By the way, the other thread suggested clearing cookies. You don't have to clear cookies for all sites. Instead: While viewing a page on the site, try either: * right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies" * (menu bar) Tools > Page Info > Security > "View Cookies" * click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually. Then try reloading the page. Does that help?
jscher2000
  • Top 10 Contributor
8792 solutions 71899 answers

springheel said

I cannot use my Adobe program as an add on in the browser anymore because for some reason or another, it won't let me use it with a 64 bit machine, and yet I have used it for nearly five years without an y incident with a 64 bit machine that suddenly, one day, Mozilla decides that I can.'t.

Your plugins list (next to your post: Question Details > More System Details) shows two version of the Adobe Acrobat plugin, one of which is much more out of date. Firefox may be using (or not using) the older plugin instead of the newer one.

Try uninstalling Adobe Reader X. If you have a paid version of Acrobat, or if you can't remove Adobe Reader X, you can try to manually delete the plugin from where Firefox is finding it. More details on that if needed.

''springheel [[#answer-934184|said]]'' <blockquote> I cannot use my Adobe program as an add on in the browser anymore because for some reason or another, it won't let me use it with a 64 bit machine, and yet I have used it for nearly five years without an y incident with a 64 bit machine that suddenly, one day, Mozilla decides that I can.'t. </blockquote> Your plugins list (next to your post: Question Details > More System Details) shows two version of the Adobe Acrobat plugin, one of which is much more out of date. Firefox may be using (or not using) the older plugin instead of the newer one. Try uninstalling Adobe Reader X. If you have a paid version of Acrobat, or if you can't remove Adobe Reader X, you can try to manually delete the plugin from where Firefox is finding it. More details on that if needed.

Question owner

I understand that, and yet if you read WP response, they are telling me my java isn't running and even though it shows enabled in about:cofig, there is still the warning message on the plug in.

Look atmy screenshot. Do you see a grayed/red block" to the left of the address?

I don't, and I am aware of this toggle and have noticed it  on sites before of which I have had to 'allow."

But there is no toggle.

All I have is the error message on the plug in itself and a bunch of grayed-out options.

WP may or may not use the plug in but their support is telling me the page does and right now, all things considered, it's the only error or reasonable explanation as to why the page won't load properly.

You're correct, though, normally that toggle is present in the address bar, in fact, it was the very first thing I looked for, and yet it isn't there. What is there is that Mozilla has flagged the plug in as vulnerable,

I understand that, and yet if you read WP response, they are telling me my java isn't running and even though it shows enabled in about:cofig, there is still the warning message on the plug in. Look atmy screenshot. Do you see a grayed/red block" to the left of the address? I don't, and I am aware of this toggle and have noticed it on sites before of which I have had to 'allow." But there is no toggle. All I have is the error message on the plug in itself and a bunch of grayed-out options. WP may or may not use the plug in but their support is telling me the page does and right now, all things considered, it's the only error or reasonable explanation as to why the page won't load properly. You're correct, though, normally that toggle is present in the address bar, in fact, it was the very first thing I looked for, and yet it isn't there. What is there is that Mozilla has flagged the plug in as vulnerable,
jscher2000
  • Top 10 Contributor
8792 solutions 71899 answers

springheel said

I understand that, and yet if you read WP response, they are telling me my java isn't running and even though it shows enabled in about:cofig, there is still the warning message on the plug in.

Please stop right there. What preference in about:config is related to the Java plugins? The Java plugins are NOT used to interpret JavaScript. Very important to keep those distinct in your mind.

Look atmy screenshot. Do you see a grayed/red block" to the left of the address?

Nope! So Firefox is not waiting for you to activate any plugins requested by that page.

WP may or may not use the plug in but their support is telling me the page does and right now, all things considered, it's the only error or reasonable explanation as to why the page won't load properly.

No, he said JavaScript NOT Java.

''springheel [[#answer-934203|said]]'' <blockquote> I understand that, and yet if you read WP response, they are telling me my java isn't running and even though it shows enabled in about:cofig, there is still the warning message on the plug in.</blockquote> Please stop right there. What preference in about:config is related to the '''Java plugins'''? The Java plugins are NOT used to interpret JavaScript. Very important to keep those distinct in your mind. <blockquote>Look atmy screenshot. Do you see a grayed/red block" to the left of the address?</blockquote> Nope! So Firefox is not waiting for you to activate any plugins requested by that page. <blockquote>WP may or may not use the plug in but their support is telling me the page does and right now, all things considered, it's the only error or reasonable explanation as to why the page won't load properly.</blockquote> No, he said '''JavaScript''' NOT Java.

Question owner

I figured that was true about the cookies, but I cleared them all the same.

Okay, for some unknown reason--the pages are loading properly now, regardless that the plug-in is still flagged.

Perhaps I don't entirely understand how Java works, or what I am actually looking at in my plug ins. Nevertheless, I did exactly what WP support told me to, right down to the letter--and the page still wouldn't load properly.

However, after replying to their last response, and the last couple of responses on Mozilla support--the pages are loading correctly, and yet I have no real ideas as to what I have done.

Except gripe.

Frankly, I'm not completely unsure this all hasn't been an issue or a conflict with WP itself. I do know, that has happened before and I don't believe it simply fixed itself.

We'll see how long it lasts.

I want to thank everybody for all the information. I have saved it all for future reference and as I said--we'll see how long this 'fix' lasts. I really don't believe I did anything and I really don't believe it simply fixed itself, but for now--the page views properly.

There are days I hate technology.

)
I figured that was true about the cookies, but I cleared them all the same. Okay, for some unknown reason--the pages are loading properly now, regardless that the plug-in is still flagged. Perhaps I don't entirely understand how Java works, or what I am actually looking at in my plug ins. Nevertheless, I did exactly what WP support told me to, right down to the letter--and the page still wouldn't load properly. However, after replying to their last response, and the last couple of responses on Mozilla support--the pages are loading correctly, and yet I have no real ideas as to what I have done. Except gripe. Frankly, I'm not completely unsure this all hasn't been an issue or a conflict with WP itself. I do know, that has happened before and I don't believe it simply fixed itself. We'll see how long it lasts. I want to thank everybody for all the information. I have saved it all for future reference and as I said--we'll see how long this 'fix' lasts. I really don't believe I did anything and I really don't believe it simply fixed itself, but for now--the page views properly. There are days I hate technology. ;)