Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The default language in address bar is English. Please add an option for "disable the default language to English"

  • 6 replies
  • 3 have this problem
  • 398 views
  • Last reply by jscher2000

more options

The default language in address bar is English.

So, when I need to search for Chinese characters, it will by default only allows me to input English, even my input method is for Chinese already, it will just switch it to input English only.

It is annoying. Please add an option for "disable the default language to English" or just use the input method that the user is using as the language for search at address bar.

config: Windows 7 64bit, Firefox 47.0.1

Chosen solution

Hi,

The people who answer questions here, for the most part, are other Firefox users volunteering their time (like me), not Mozilla employees or Firefox developers.

If you want to leave feedback for Firefox developers, you can go to the Firefox Help menu and select Submit Feedback... or use this link. Your feedback gets collected at http://input.mozilla.org/, where a team of people read it and gather data about the most common issues.


Security Issue: Update your Flash Player Note: Windows users should download the active_x for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the active_x.

Flash Player Version: 23.0.0. 205 Flash Player (Linux) Version 11.2. 202.643

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download.

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download.


See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

Read this answer in context 👍 0

All Replies (6)

more options

Chosen Solution

Hi,

The people who answer questions here, for the most part, are other Firefox users volunteering their time (like me), not Mozilla employees or Firefox developers.

If you want to leave feedback for Firefox developers, you can go to the Firefox Help menu and select Submit Feedback... or use this link. Your feedback gets collected at http://input.mozilla.org/, where a team of people read it and gather data about the most common issues.


Security Issue: Update your Flash Player Note: Windows users should download the active_x for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the active_x.

Flash Player Version: 23.0.0. 205 Flash Player (Linux) Version 11.2. 202.643

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download.

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download.


See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

Thanks for advice, will submit feedback instead.

more options

Glad to help. Safe Surfing.

more options

Just to clarify:

Is the problem specific to the address bar, or does it also affect the search bar(s)?

When I search around for this, I don't see a really clear indication of what's going on, but a Windows 10 user posted this on Google's support forum in September:

It's consistent within Chrome, Firefox and Edge that the language IME does not launch on the address bar. However within Edge and Firefox, The Chinese input launch in the search field just fine. Chrome will not work.
Windows Chinese Input does not work in Chrome 53 - Google Product Forums

Is that your experience on Windows 7 as well (with IE instead of Edge)?

more options

I am using Windows 7 64bit, Firefox 47.0.1

I am referring to the address bar, not the search bar, because I always use the address bar for searching directly.

It used to work in previous version of Firefox, not sure which version. By now, with this new version of Firefox, it is forcing to input English only in the address bar.

On the other hand, I am not sure whether this is caused by Windows Update because it is updating every month.

more options

TimTTH said

It used to work in previous version of Firefox, not sure which version. By now, with this new version of Firefox, it is forcing to input English only in the address bar.

If you want to experiment, you can test an older version using a "portable" build of Firefox. It installs into a folder and doesn't interfere with your main installation.

http://sourceforge.net/projects/portableapps/files/Mozilla%20Firefox%2C%20Portable%20Ed./

The layout hides the full file names, so it's hard to see the version numbers. You can widen the table using the Web Console to run this line of script:

document.getElementById("files").style.width="auto";

To open the Web Console in the lower part of the tab, you can use either:

  • Ctrl+Shift+k
  • "3-bar" menu button > Developer > Web Console
  • (menu bar) Tools > Web Developer > Web Console

Then in the line at the bottom, paste the script and press Enter to run it.