Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Error code 0xc0000142 unable to start, unable to reinstall, why?

  • 22 replies
  • 4 have this problem
  • Last reply by guigs

more options

I couldn't connect to the internet. Received an error code 0xc0000142 "The application was unable to start correctly." After several tries I shut the computer down and rebooted. Same response. Firefox had been working fine earlier. Internet Explorer was working so I uninstalled Firefox and reinstalled. When installation reached about 75% completion the same error code window popped up. My only options were "search for a fix" or "close program". I clicked "close the program" and installation resumed and appeared to be complete, but it's not working. Tried this several times. Once when the window popped up I had the option of seeing the details. They read: "App crash Maintenanceservice.exe version time stamp 57dc3758. I installed the Revo Uninstaller. I used that tool to uninstall Firefox and then reinstalled. No go. Security Essentionals updated & scanned. Firewall is set to allow Firefox to penetrate. Malwarebytes scan found nothing malicious. I installed MS Safety Scanner and it found nothing. I've had problems with Adobe Flashplayer in the past so I uninstalled that. Ditto for Javascript so I disabled it. Any suggestions?

All Replies (2)

more options

guigs: Thanks for your suggestion. I don't have any AVG programs on my computer. I'm using Security Essentials, MS Firewall and Malwarebytes.

I'm currently having no problems installing and running other software. Firefox 49, however, will not run.

more options

Looks like the error is that the application is not digitally signed. If its possible that Firefox was not downloaded from an official source, the application could be flagged, but after a reinstall it should update the flag that stops unsigned dlls in windows mentioned: here

Instead of doing the hacky way, please after the clean reinstall that John99 mentioned, try booking the computer in Windows Safe Mode with network support. here's how

  1. 1
  2. 2