X
Tap here to go to the mobile version of the site.

Support Forum

What happened to the FF fourm for support? Why can't I auto log into my site anymore?

Posted

2 sites I commonly use will no longer allow me to auto fill the user name and pw. There used to be an option in security.log in that was exceptions. Those 2 site used to have to be noted there in order for auto fill to work. That option is no longer active

2 sites I commonly use will no longer allow me to auto fill the user name and pw. There used to be an option in security.log in that was exceptions. Those 2 site used to have to be noted there in order for auto fill to work. That option is no longer active

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.17.20050
  • Garmin Communicator Plug-In 4.2.0.0
  • GEPlugin
  • Google Update
  • Next Generation Java Plug-in 11.91.2 for Mozilla browsers
  • Shockwave Flash 22.0 r0
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

More Information

jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

I'm not sure what you mean here:

There used to be an option in security.log in that was exceptions. Those 2 site used to have to be noted there in order for auto fill to work.

On the Options page, Security panel, across from the "Remember logins for sites" checkbox there is an Exceptions button. Did your exceptions disappear? If you are attempting to re-create those, make sure to use a full path (i.e., https://support.mozilla.org).

I'm not sure what you mean here: <blockquote> There used to be an option in security.log in that was exceptions. Those 2 site used to have to be noted there in order for auto fill to work.</blockquote> On the Options page, Security panel, across from the "Remember logins for sites" checkbox there is an Exceptions button. Did your exceptions disappear? If you are attempting to re-create those, make sure to use a full path (i.e., [https://support.mozilla.org]).

Question owner

Yes the Exception box is there but it is no longer enabled. When it used to be enabled and I hit it the 2 sites in question would show on the next page. I had asked this same question several times before on the forum and finally figured out how to deal with it but the forum and that history has also gone. It used to be every time I used a cleaner I would have to go in and reinstate most auto fill functions. I can accept that having cleared cookies and do still do on many sites but AirForums.com and Geocaching.com I cannot use auto fill.

Yes the Exception box is there but it is no longer enabled. When it used to be enabled and I hit it the 2 sites in question would show on the next page. I had asked this same question several times before on the forum and finally figured out how to deal with it but the forum and that history has also gone. It used to be every time I used a cleaner I would have to go in and reinstate most auto fill functions. I can accept that having cleared cookies and do still do on many sites but AirForums.com and Geocaching.com I cannot use auto fill.
jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

The button should be enabled when you check the box for "Remember logins for sites". Does it help to uncheck and check it a few times?

Some password manager add-ons may disable the built-in feature to avoid a conflict. Not sure whether that might be an issue for you.

Regarding clearing cookies, that should not affect either saved logins or your site-specific settings. However, if you are using either "Clear Recent History" or "Clear history when Firefox closes", make sure to adjust the Details/Settings not to delete Site Preferences.

The button should be enabled when you check the box for "Remember logins for sites". Does it help to uncheck and check it a few times? Some password manager add-ons may disable the built-in feature to avoid a conflict. Not sure whether that might be an issue for you. Regarding clearing cookies, that should not affect either saved logins or your site-specific settings. However, if you are using either "Clear Recent History" or "Clear history when Firefox closes", make sure to adjust the Details/Settings not to delete Site Preferences.

Question owner

I will have to reopen this is a week.

Clicking repeatedly on any of the not enabled has no effect.

I will have to reopen this is a week. Clicking repeatedly on any of the not enabled has no effect.
jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

HowieE said

Clicking repeatedly on any of the not enabled has no effect.

I may not have been clear: I meant to uncheck and re-check the checkbox on the left of that line which controls whether the Firefox Password Manager is enabled or not. Is that checkbox disabled, too?

''HowieE [[#answer-909596|said]]'' <blockquote> Clicking repeatedly on any of the not enabled has no effect. </blockquote> I may not have been clear: I meant to uncheck and re-check the checkbox on the left of that line which controls whether the Firefox Password Manager is enabled or not. Is that checkbox disabled, too?

Question owner

Sorry for the interruption but vacation came first.

We may have to start over. I can no longer auto log into some sites. After many postings on this subject i had found a way to correct this on FF Forum. That Forum seams to be gone and what I remember on how to fix the problem is not available now.

If you have access to my old posts you may find the solution.

In Security Remember, Exceptions, and Change password manager are not enabled. Thus I can not get to what I used to use to correct this issue.

Sorry for the interruption but vacation came first. We may have to start over. I can no longer auto log into some sites. After many postings on this subject i had found a way to correct this on FF Forum. That Forum seams to be gone and what I remember on how to fix the problem is not available now. If you have access to my old posts you may find the solution. In Security Remember, Exceptions, and Change password manager are not enabled. Thus I can not get to what I used to use to correct this issue.
John99 971 solutions 13138 answers

One of your prior post an this subject is

That thread is not now closed and archived but you will be able to view it (for now at least - no guarantees it will be available in a few weeks time). It appears you resolved the issue that time by using the Firefox Reset, that is now referred to as the Firefox Refresh

It is however a bit of a sledgehammer and nut method, and will remove any Firefox Extensions you have installed, so if you do have add-ons it may help to ensure you bookmark the home or support pages of those add-ons.

One of your prior post an this subject is * [/questions/1009118 How to get FF to auto insert user name and password to open a site] That thread is <s>not</s> no'''w '''closed and archived but you will be able to view it (for now at least - no guarantees it will be available in a few weeks time). It appears you resolved the issue that time by using the Firefox Reset, that is now referred to as the Firefox Refresh * See [[Refresh Firefox - reset add-ons and settings]] It is however a bit of a sledgehammer and nut method, and will remove any Firefox Extensions you have installed, so if you do have add-ons it may help to ensure you bookmark the home or support pages of those add-ons.

Modified by John99

Question owner

Thanks John but I have no idea as how to deal with what you mentioned in the 2nd. paragraph. if you have more detail please advise

Thanks John but I have no idea as how to deal with what you mentioned in the 2nd. paragraph. if you have more detail please advise
John99 971 solutions 13138 answers

Following the suggestions of Jscher2000 would be best. However for a quick fix try the Firefox Refresh option

That article does itself contain a clickable button that will Reset Firefox if you open the article in Firefox,

Following the suggestions of Jscher2000 would be best. However for a quick fix try the Firefox Refresh option * See [[Refresh Firefox - reset add-ons and settings]] <== Clickable link That article does itself contain a clickable button that will Reset Firefox if you open the article in Firefox,

Question owner

Thanks Guys I lost everything. FF home page, all my bookmarks, all my tab settings.

I am dead in the water.

Thanks Guys I lost everything. FF home page, all my bookmarks, all my tab settings. I am dead in the water.
jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

Hi HowieE, Firefox's Refresh feature is supposed to preserve your bookmarks but it's normal to lose the other settings, as described in that article you were referred to.

Were you used to accessing your bookmarks on Firefox's Bookmarks Toolbar or Bookmarks menu on the menu bar? To turn different bars on and off, you can use one of these methods to show the toolbar list and select the desired bars there:

To turn on the Menu Bar, Bookmarks Toolbar, or other bars, click it on the list. Can you find your bookmarks?


If you need to "undo" the Refresh, unfortunately there's no one-click option for that, but it can be done through a sequence of steps. See this post for example: https://support.mozilla.org/questions/1128917#answer-892013

Hi HowieE, Firefox's Refresh feature is supposed to preserve your bookmarks but it's normal to lose the other settings, as described in that article you were referred to. Were you used to accessing your bookmarks on Firefox's Bookmarks Toolbar or Bookmarks menu on the menu bar? To turn different bars on and off, you can use one of these methods to show the toolbar list and select the desired bars there: * right-click a blank spot on the tab bar (or the "+" button) * tap the Alt key to activate the classic menu bar > View > Toolbars * in Customize mode > Show/Hide Toolbars (see: [[Customize Firefox controls, buttons and toolbars]]) To turn on the Menu Bar, Bookmarks Toolbar, or other bars, click it on the list. Can you find your bookmarks? ---- If you need to "undo" the Refresh, unfortunately there's no one-click option for that, but it can be done through a sequence of steps. See this post for example: https://support.mozilla.org/questions/1128917#answer-892013

Question owner

i got the tool bars and contents back. I now have to figure out how to reset the privacy settings i had on.

Back to my original question. Is there a way to say auto fill for the 2 sites I use the most. In Login remember login sites, exceptions, and change password are no enabled. Many of my other site do auto fill but some i have lost all togeather but that I think wa fron the sites end.

i got the tool bars and contents back. I now have to figure out how to reset the privacy settings i had on. Back to my original question. Is there a way to say auto fill for the 2 sites I use the most. In Login remember login sites, exceptions, and change password are no enabled. Many of my other site do auto fill but some i have lost all togeather but that I think wa fron the sites end.
jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

Do you mean: is there a way to stop Firefox from asking to save logins for NEW sites and have it log you in just on sites you have already saved? I do not know if that is possible.

Do you mean: is there a way to stop Firefox from asking to save logins for NEW sites and have it log you in just on sites you have already saved? I do not know if that is possible.

Question owner

I want auto fill to work as I open a site. There are 2 sites that this no longer works on. It is a problem with the way FF saves, or in this case does not save the UM and PW for those sites.

The problem is that in privacy, login is not enabled now ant thus will not save the information. I have always had to reload those two site every time I run a cleaner and now can do that with the functions not enabled.

I want auto fill to work as I open a site. There are 2 sites that this no longer works on. It is a problem with the way FF saves, or in this case does not save the UM and PW for those sites. The problem is that in privacy, login is not enabled now ant thus will not save the information. I have always had to reload those two site every time I run a cleaner and now can do that with the functions not enabled.
jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

Let's set aside the problem of using a cleaner that may be damaging your Firefox settings. It's easy to stop doing that if it makes things worse.

At this point, you're saying that the checkbox for "Remember logins for sites" does not work, it can't be checked? I'm attaching a screen shot to make sure we are talking about the same checkbox.

Could you check here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste signon and pause while the list is filtered

(3) If the signon.rememberSignons preference is bolded and "user set" to false, double-click it to restore the default value of true -- this is what the checkbox controls

Does that work? If the status is "Locked" that would point toward a different problem.

Let's set aside the problem of using a cleaner that may be damaging your Firefox settings. It's easy to stop doing that if it makes things worse. At this point, you're saying that the checkbox for "Remember logins for sites" does not work, it can't be checked? I'm attaching a screen shot to make sure we are talking about the same checkbox. Could you check here: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''signon''' and pause while the list is filtered (3) If the '''signon.rememberSignons''' preference is bolded and "user set" to false, double-click it to restore the default value of true -- this is what the checkbox controls Does that work? If the status is "Locked" that would point toward a different problem.

Question owner

This is what I found when I followed your instructions.

signon.rememberSignons;true

This was bold.

signon.importedFromSqlite;true but the status was User Set

I did not change anything

You may want to sign into http://www.airforums.com/ or https://www.geocaching.com/account/login?returnUrl=https%3a%2f%2fwww.geocaching.com/my/default.aspx

and see if you can use auto fill to that site

This is what I found when I followed your instructions. signon.rememberSignons;true This was bold. signon.importedFromSqlite;true but the status was '''User Set''' I did not change anything You may want to sign into http://www.airforums.com/ or https://www.geocaching.com/account/login?returnUrl=https%3a%2f%2fwww.geocaching.com/my/default.aspx and see if you can use auto fill to that site

Modified by HowieE

jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

The signon.importedFromSqlite preference is set when Firefox migrates old logins from an earlier format (so it only does it once). That shouldn't be a problem.

Maybe the problem is that the Options page isn't working correctly, since the preference itself is fine.

Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

The signon.importedFromSqlite preference is set when Firefox migrates old logins from an earlier format (so it only does it once). That shouldn't be a problem. Maybe the problem is that the Options page isn't working correctly, since the preference itself is fine. Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?

Question owner

that had no effect. Did not remember UN and PW and in security the login was still not enabled.

By the way sign in in FF dies not use auto fill either

that had no effect. Did not remember UN and PW and in security the login was still not enabled. By the way sign in in FF dies not use auto fill either
jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

I don't use the password manager for website logins, so I'm definitely running out of ideas on why it has stopped working for you.

I'm assuming it doesn't work on ANY sites, and not just on those two. Is that correct?

Are you working with your original settings, or is this "post-Refresh"?

I don't use the password manager for website logins, so I'm definitely running out of ideas on why it has stopped working for you. I'm assuming it doesn't work on ANY sites, and not just on those two. Is that correct? Are you working with your original settings, or is this "post-Refresh"?

Question owner

It works for more than 20 sites.

Thanks for your help but don' feel obligated to go further.

Fire Fox has not improved over time. Years ago it worked very well bt each so called improvement makes it more like Verizon site than a Google site.

It works for more than 20 sites. Thanks for your help but don' feel obligated to go further. Fire Fox has not improved over time. Years ago it worked very well bt each so called improvement makes it more like Verizon site than a Google site.