X
Tap here to go to the mobile version of the site.

Support Forum

why does each single left-click on a saved html document open two duplicate copies?

Posted

Any time I left-click on a saved Firefox html document to open it, I get not one --- but TWO --- tabs leading to identical copies of the document. I have tried off and on for months to find a way to stop this, with no success. Anyone who can tell me what is going on here, what causes it, and how to stop it, will have my eternal gratitude. Thanks a million, in advance.

Any time I left-click on a saved Firefox html document to open it, I get not one --- but TWO --- tabs leading to identical copies of the document. I have tried off and on for months to find a way to stop this, with no success. Anyone who can tell me what is going on here, what causes it, and how to stop it, will have my eternal gratitude. Thanks a million, in advance.

Additional System Details

Installed Plug-ins

  • Amazon MP3 Downloader Plugin 1.0.17
  • Foxit Reader Plug-In For Firefox and Netscape
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Musicnotes Viewer plugin 1.19.0 For more information visit www.musicnotes.com
  • ScorchPlugin
  • Shockwave Flash 22.0 r0
  • VLC media player Web Plugin
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:47.0) Gecko/20100101 Firefox/47.0

More Information

Question owner

John99,

Thanks for continuing to try to help me.

And I appreciate your effort to reassure me that the changes in question would be relatively minor, and reversible. But if you will forgive me, I am just super-cautious when dealing with issues on my computer, and I will be less afraid to try making those changes once I know that I have a good validated backup from which to restore my system if I should break something.

John99, Thanks for continuing to try to help me. And I appreciate your effort to reassure me that the changes in question would be relatively minor, and reversible. But if you will forgive me, I am just super-cautious when dealing with issues on my computer, and I will be less afraid to try making those changes once I know that I have a good validated backup from which to restore my system if I should break something.
John99 971 solutions 13138 answers

Very sensible. Windows is not designed to be easy to fix. It's a pity more people don't realise the importance of proper backups.

Very sensible. Windows is not designed to be easy to fix. It's a pity more people don't realise the importance of proper backups.

Question owner

Many thanks for your kind words of support!

Many thanks for your kind words of support!

Question owner

John99 and JScher2000 ??? Are you still there ???

I was finally able to do the disk image early this morning. Shortly after it completed, I went to Control Panel > Folder Options > File Types > HTML --- and left-clicked Restore. I then tried three ways of opening an HTML file, with the following results:

1. Two left-clicks ---> opened two identical copies/tabs of the file 2. One right-click > Open ---> opened two identical copies/tabs of the file 3. One right-click > Open With > Firefox ---> opened a single copy of the file

I believe these are exactly the same results that I got BEFORE clicking on the Restore button.

Neither the Change button nor the Advanced button led me to any useful results --- so far as I could see.

So I am still --- or again --- stumped.

With diminishing hopes, I now --- or again --- yield to (one or both of) you . . . . . . . .

John99 and JScher2000 ??? Are you still there ??? I was finally able to do the disk image early this morning. Shortly after it completed, I went to Control Panel > Folder Options > File Types > HTML --- and left-clicked Restore. I then tried three ways of opening an HTML file, with the following results: 1. Two left-clicks ---> opened two identical copies/tabs of the file 2. One right-click > Open ---> opened two identical copies/tabs of the file 3. One right-click > Open With > Firefox ---> opened a single copy of the file I believe these are exactly the same results that I got BEFORE clicking on the Restore button. Neither the Change button nor the Advanced button led me to any useful results --- so far as I could see. So I am still --- or again --- stumped. With diminishing hopes, I now --- or again --- yield to (one or both of) you . . . . . . . .
jscher2000
  • Top 10 Contributor
8794 solutions 71943 answers

gh777 said

Neither the Change button nor the Advanced button led me to any useful results --- so far as I could see.

You have an advanced button now? That is progress. So if you click Advanced, there should be a new box with certain predefined actions, such as open, edit, etc. If you highlight open and click Edit, then a box should display with a main command line and a checkbox for "Use DDE".

If that box is checked, uncheck it and save the change and test again.

If that box was not checked, copy the command line and paste it into a reply so we can check on whether it is sensible.

''gh777 [[#answer-904898|said]]'' <blockquote> Neither the Change button nor the Advanced button led me to any useful results --- so far as I could see.</blockquote> You have an advanced button now? That is progress. So if you click Advanced, there should be a new box with certain predefined actions, such as open, edit, etc. If you highlight open and click Edit, then a box should display with a main command line and a checkbox for "Use DDE". If that box is checked, uncheck it and save the change and test again. If that box was not checked, copy the command line and paste it into a reply so we can check on whether it is sensible.
bartjunk64 2 solutions 7 answers

Take a look into the Windows registry. As long as you do not edit (change a value) something, this cannot hurt you.

Open Windows Startmenu and type "regedit" (without the quotes), then press Enter.

In regedit navigate (in the left panel) to: Computer\HKEY_CURRENT_USER\Software\Classes\.html In the right panel it should say something like: (default) REG_SZ FirefoxHTML

Report here what it says.

Now navigate to: Computer\HKEY_CURRENT_USER\Software\Classes\FirefoxHTML\shell\open\command In the right panel it should say something like: (default) REG_SZ "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -osint -url "%1"

Report here what it says.

Bart

Take a look into the Windows registry. As long as you do not edit (change a value) something, this cannot hurt you. Open Windows Startmenu and type "regedit" (without the quotes), then press Enter. In regedit navigate (in the left panel) to: Computer\HKEY_CURRENT_USER\Software\Classes\.html In the right panel it should say something like: (default) REG_SZ FirefoxHTML Report here what it says. Now navigate to: Computer\HKEY_CURRENT_USER\Software\Classes\FirefoxHTML\shell\open\command In the right panel it should say something like: (default) REG_SZ "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -osint -url "%1" Report here what it says. Bart

Question owner

To JScher2000: First, thank you for sticking with me!

The DDE box was checked. I unchecked it, saved, okayed twice, then tested. Test results were identical to those I posted 7/30/16, 1:57 PM:

If there is no other Firefox window open, then 1. a left double-click --- opens two instances of the document 2. a right click > Open --- opens two instances of the document 3. a right click > Open with > Firefox --- opens one instance of the doc.

If one other Firefox window is already open, then 4. a left double-click --- opens one instance of the doc 5. a right click > Open --- opens one instance of the doc 6. a right click > Open with > Firefox --- opens one instance of the doc

The command line was this: "C:\Program Files\Mozilla Firefox\firefox.exe" -osint -url "%1"


To bartjunk64: Thank you for trying to help!

1. In Computer\HKEY_CURRENT_USER\Software\Classes\.html the right panel says: (Default) --- REG_SZ --- htmlfile

2. In Computer\HKEY_CURRENT_USER\Software\Classes\FirefoxHTML\shell\open\command, the right panel says:

"C:\Program Files\Mozilla Firefox\firefox.exe" -osint -url "%1" (There is no (x86) after Program Files)

To JScher2000: First, thank you for sticking with me! The DDE box was checked. I unchecked it, saved, okayed twice, then tested. Test results were identical to those I posted 7/30/16, 1:57 PM: '''If there is no other Firefox window open, then''' 1. a left double-click --- opens two instances of the document 2. a right click > Open --- opens two instances of the document 3. a right click > Open with > Firefox --- opens one instance of the doc. '''If one other Firefox window is already open, then''' 4. a left double-click --- opens one instance of the doc 5. a right click > Open --- opens one instance of the doc 6. a right click > Open with > Firefox --- opens one instance of the doc The command line was this: "C:\Program Files\Mozilla Firefox\firefox.exe" -osint -url "%1" ------------------- To bartjunk64: Thank you for trying to help! 1. In Computer\HKEY_CURRENT_USER\Software\Classes\.html the right panel says: (Default) --- REG_SZ --- htmlfile 2. In Computer\HKEY_CURRENT_USER\Software\Classes\FirefoxHTML\shell\open\command, the right panel says: "C:\Program Files\Mozilla Firefox\firefox.exe" -osint -url "%1" (There is no (x86) after Program Files)
John99 971 solutions 13138 answers

No one else is answering at the moment, and I do not know the solution, but at least my post will bump the question so someone more knowledgeable may continue with this.

I have an old XP somewhere but not looking at it right now so I am unsure of facts here. I am guessing no x86 could well be ok especially on a 32 bit computer.

No one else is answering at the moment, and I do not know the solution, but at least my post will bump the question so someone more knowledgeable may continue with this. I have an old XP somewhere but not looking at it right now so I am unsure of facts here. I am guessing no x86 could well be ok especially on a 32 bit computer.
the-edmeister
  • Top 25 Contributor
  • Moderator
5411 solutions 40308 answers

gh777,

Have you considered opening those HTML files from within Firefox?

{ Ctrl + O } from the keyboard or File > Open File... - and then navigate to the folder where that HTML file is located.

I have been doing that for years with almost very program that I have installed on Windows 7 and before that WinXP, W2K, & Win98. Firefox, LibreOffice / OpenOffice. GIMP, and others. Started doing it in that manner back in the days of Win98 due to "competing" Registry entries made by various programs I had installed that were a bit too similar and many "snagged" a file type they weren't go at displaying or working with. And it helps when a Zip-build of the program is used (which typically doesn't provide registry entries) for programs where Zip-builds are available; saves time fiddling with Windows and setting file-type relationships.

gh777, Have you considered opening those HTML files from within Firefox? '''{ Ctrl + O }''' from the keyboard or '''File > Open File...''' - and then navigate to the folder where that HTML file is located. I have been doing that for years with almost very program that I have installed on Windows 7 and before that WinXP, W2K, & Win98. Firefox, LibreOffice / OpenOffice. GIMP, and others. Started doing it in that manner back in the days of Win98 due to "competing" Registry entries made by various programs I had installed that were a bit too similar and many "snagged" a file type they weren't go at displaying or working with. And it helps when a Zip-build of the program is used ''(which typically doesn't provide registry entries)'' for programs where Zip-builds are available; saves time fiddling with Windows and setting file-type relationships.

Question owner

John99 --- Many thanks for your continuing kindness and willingness to help!

the-edmeister --- Thank you for trying to help me. As a general rule, the html files that I want to open are in a Downloads (Current Year) folder that is usually minimized to my taskbar. When I want to open one of those files,

Step 1 is to restore the Downloads 2016 folder, Step 2 is to locate the file I want. Step 3 has been to left double-click the file name --- but as I've documented above, it is that action which opens not one but two copies of the document.

As a result of the discussions here, I have learned that I can ALWAYS get just one copy of a document if I right-click the document's name, select Open With, and then select Firefox --- and perhaps I will adopt that procedure for the future. But I find it easier and more expedient to simply left double-click the file name --- which is why I came here in hopes of learning how to have only one instance of a document open when I left double-click.

John99 --- Many thanks for your continuing kindness and willingness to help! the-edmeister --- Thank you for trying to help me. As a general rule, the html files that I want to open are in a Downloads (Current Year) folder that is usually minimized to my taskbar. When I want to open one of those files, Step 1 is to restore the Downloads 2016 folder, Step 2 is to locate the file I want. Step 3 has been to left double-click the file name --- but as I've documented above, it is that action which opens not one but two copies of the document. As a result of the discussions here, I have learned that I can ALWAYS get just one copy of a document if I right-click the document's name, select Open With, and then select Firefox --- and perhaps I will adopt that procedure for the future. But I find it easier and more expedient to simply left double-click the file name --- which is why I came here in hopes of learning how to have only one instance of a document open when I left double-click.

Modified by gh777