X
Tap here to go to the mobile version of the site.

Support Forum

Latest version of Firefox won't allow screen size to be changed

Posted

Hello, Version 47.0 of Firefox has just been installed on my PC and I find that it is impossible to change the magification on the screen. It seems to be permanently set on 100% and neither the minus or plus buttons do anything.

Hello, Version 47.0 of Firefox has just been installed on my PC and I find that it is impossible to change the magification on the screen. It seems to be permanently set on 100% and neither the minus or plus buttons do anything.

Chosen solution

I had this problem also. Start in SafeMode and magnification worked. Fiddled with enabling and disabling.

Problem was NoSquint add-on. I think the magnification went native in 47.0 and NoSquint does the same thing but co-existence did not work. Back to Camp David I guess.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.16.20045
  • GEPlugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.91.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • LastPass Plugin
  • Picasa plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 21.0 r0
  • 5.1.41212.0
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

More Information

FredMcD
  • Top 10 Contributor
4269 solutions 59841 answers

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

Make sure you do not run Firefox in Full Screen mode (press F11 or Fn + F11 to toggle; Mac: Command+Shift+F).

When you are in Full Screen mode, hover the mouse to the top of the screen to make the Navigation Toolbar and Tab bar appear. You can use one of these to leave Full Screen mode:

  • press the F11 key
  • click the Maximize button at the right end of the Tab bar
  • click the Full Screen button in the "3-bar" Firefox menu button drop-down list
  • right-click empty space on a toolbar and click "Exit Full Screen Mode"

Try to rename/remove the xulstore.json file in the Firefox profile folder.

You can use this button to go to the current Firefox profile folder:

Make sure you do not run Firefox in Full Screen mode (press F11 or Fn + F11 to toggle; Mac: Command+Shift+F). *https://support.mozilla.org/kb/how-to-use-full-screen When you are in Full Screen mode, hover the mouse to the top of the screen to make the Navigation Toolbar and Tab bar appear. You can use one of these to leave Full Screen mode: *press the F11 key *click the Maximize button at the right end of the Tab bar *click the Full Screen button in the "3-bar" Firefox menu button drop-down list *right-click empty space on a toolbar and click "Exit Full Screen Mode" ---- Try to rename/remove the <b>xulstore.json</b> file in the Firefox profile folder. You can use this button to go to the current Firefox profile folder: *Help > Troubleshooting Information > Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox

Helpful Reply

Thanks Fred, The zoom controls work OK in safe mode, but still don't work in normal mode. I see some others have said they have the same problem. It would appear to me that it is tied up to some change in the latest version of Firefox? Barry

Thanks Fred, The zoom controls work OK in safe mode, but still don't work in normal mode. I see some others have said they have the same problem. It would appear to me that it is tied up to some change in the latest version of Firefox? Barry

Question owner

Hi cor-el I renamed xulstore.json ( Just deleted the name and re-input it). Why did you suggest removing it? I was a bit dicky about doing that. I am not a computer wiz and wasn't sure of the consequences of removing it. Still unable to zoom. Barry

Hi cor-el I renamed xulstore.json ( Just deleted the name and re-input it). Why did you suggest removing it? I was a bit dicky about doing that. I am not a computer wiz and wasn't sure of the consequences of removing it. Still unable to zoom. Barry
Scribe 732 solutions 3484 answers

Hi, since it works in Safe Mode, disable any theme or add-ons you have - Add-ons Manager (Ctrl+Shift+A) > Appearance/Extensions, then if it's OK, re-enable them one by one until you find the culprit.

More: Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems.

Hi, since it works in Safe Mode, disable any theme or add-ons you have - Add-ons Manager (Ctrl+Shift+A) > Appearance/Extensions, then if it's OK, re-enable them one by one until you find the culprit. More: [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]].

Helpful Reply

Hi scribe, I clicked "solved" by accident. I disabled every extension and plugin on my PC and it made no difference. Prior to version 47.0 of Firefox the zoom function worked fine. Immediately Firefox 47.0 autoloaded onto my PC the problem was there. I am still at a loss. Barry

Hi scribe, I clicked "solved" by accident. I disabled every extension and plugin on my PC and it made no difference. Prior to version 47.0 of Firefox the zoom function worked fine. Immediately Firefox 47.0 autoloaded onto my PC the problem was there. I am still at a loss. Barry
FredMcD
  • Top 10 Contributor
4269 solutions 59841 answers

Type about:preferences#advanced<Enter> in the address bar. Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Appearance. Then select Default.

Now restart Firefox.

Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Appearance.''' Then select '''Default.''' Now restart Firefox.

Question owner

Hi FredMcD,

Nothings changed.

When I entered the text you specified above it didn't take me to a list of files, it just took me to a normal page with search results, with links to messages.

However, I just went to Tools > Add-ons on my PC and selected Appearances and found that Default was already showing.

Which raises the question. Is there a specific reason to give me that search path to follow when I can just get to the same place by selecting Tools?

Regards, Barry

Hi FredMcD, Nothings changed. When I entered the text you specified above it didn't take me to a list of files, it just took me to a normal page with search results, with links to messages. However, I just went to Tools > Add-ons on my PC and selected Appearances and found that Default was already showing. Which raises the question. Is there a specific reason to give me that search path to follow when I can just get to the same place by selecting Tools? Regards, Barry
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

If you still have the localstore.rdf file from older Firefox versions then remove this file as well.

If you still have the localstore.rdf file from older Firefox versions then remove this file as well.

Question owner

Thanks cor-el, but I don't have that file on my PC.

Barry

Thanks cor-el, but I don't have that file on my PC. Barry
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

Do a clean reinstall of the current Firefox release and delete the Firefox program folder before installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows Registry and settings in security software.

  • Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your personal data like bookmarks is stored in the Firefox profile folder, so you won't lose personal data when you uninstall and reinstall or update Firefox, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.

If you keep having problems then create a new profile to test if your current profile is causing the problem.


Do a clean reinstall of the current Firefox release and delete the Firefox program folder before installing a fresh copy of the current Firefox release. *Download the Firefox installer and save the file to the desktop<br>*https://www.mozilla.org/en-US/firefox/all/ If possible uninstall your current Firefox version to cleanup the Windows Registry and settings in security software. *Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions. Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer. *(32 bit Windows) "C:\Program Files\Mozilla Firefox\" *(64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\" *It is important to delete the Firefox program folder to remove all the files and make sure there are no problems with files that were leftover after uninstalling. *http://kb.mozillazine.org/Uninstalling_Firefox Your personal data like bookmarks is stored in the Firefox profile folder, so you won't lose personal data when you uninstall and reinstall or update Firefox, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data. If you keep having problems then create a new profile to test if your current profile is causing the problem. ---- *http://kb.mozillazine.org/Profile_folder_-_Firefox *http://kb.mozillazine.org/Profile_backup *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Clean_reinstall

Question owner

Hi cor-el.

I need some guidance. Comes of being a user rather than a computer boffin. If I uninstall Firefox how do I prevent the profile folder going with it? I looked at the Firefox files on C drive and couldn'd find any folder labelled profiles, so need to know how to prevent that file going with the rest.

Regards, Barry

Hi cor-el. I need some guidance. Comes of being a user rather than a computer boffin. If I uninstall Firefox how do I prevent the profile folder going with it? I looked at the Firefox files on C drive and couldn'd find any folder labelled profiles, so need to know how to prevent that file going with the rest. Regards, Barry
FredMcD
  • Top 10 Contributor
4269 solutions 59841 answers

Firefox comes in two or more folders on all computers. They are;

Maintenance: (Programs Folder) <Windows Only> Firefox itself: (Programs Folder) And one folder in the profile of each user on the computer.

If you remove the Firefox folder, the user folders would not be affected.

Firefox comes in two or more folders on all computers. They are; Maintenance: (Programs Folder) <Windows Only> Firefox itself: (Programs Folder) And one folder in the profile of each user on the computer. If you remove the Firefox folder, the user folders would not be affected.
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

In Firefox 47 you can find information about profiles on the about:profiles page. You can open "about:" pages via the location/address bar

  • "about:" is a protocol to access special pages

You can use this button to go to the current Firefox profile folder:

In Firefox 47 you can find information about profiles on the about:profiles page. You can open "<b>about:</b>" pages via the location/address bar *"about:" is a protocol to access special pages You can use this button to go to the current Firefox profile folder: *Help > Troubleshooting Information > Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox

Question owner

Hi cor-el, sorry about the delay in replying to your last attempt to help me. I had to make a rush trip out of town to help someone.

I uninstalled Firefox, and then downloaded a new version using the link you gave me, and then reinstalled it. However, nothing changed. Still won't zoom.

I have just about given up, and am resigned to accepting the small print that my home page shows at 100%. Are you sure the problem doesn't lie in the 47.0 update. It appeared immediately after it updated my PC.

Barry

Hi cor-el, sorry about the delay in replying to your last attempt to help me. I had to make a rush trip out of town to help someone. I uninstalled Firefox, and then downloaded a new version using the link you gave me, and then reinstalled it. However, nothing changed. Still won't zoom. I have just about given up, and am resigned to accepting the small print that my home page shows at 100%. Are you sure the problem doesn't lie in the 47.0 update. It appeared immediately after it updated my PC. Barry
Richard Marks 1 solutions 4 answers

Chosen Solution

I had this problem also. Start in SafeMode and magnification worked. Fiddled with enabling and disabling.

Problem was NoSquint add-on. I think the magnification went native in 47.0 and NoSquint does the same thing but co-existence did not work. Back to Camp David I guess.

I had this problem also. Start in SafeMode and magnification worked. Fiddled with enabling and disabling. Problem was NoSquint add-on. I think the magnification went native in 47.0 and NoSquint does the same thing but co-existence did not work. Back to Camp David I guess.

Modified by Richard Marks

Question owner

Thanks remarks. Problem fixed. I thought I had removed that without seeing any improvement, but I couldn't have restarted Firefox.

I'll have to remember you in my will.

Regards, Barry

Thanks remarks. Problem fixed. I thought I had removed that without seeing any improvement, but I couldn't have restarted Firefox. I'll have to remember you in my will. Regards, Barry

Question owner

Hi again remarks.

Even though I can now zoom again there has been a change in how the zoom works.

Before, once the page had been set to a certain percentage magnification it stayed there for ever. You could shut the PC down and any time in the future when you turned it on and opened Firefox it was still at the percentage you initially set.

Now, you only have to change a page and Firefox reverts to 100%, and stays at 100%, and if you have the magnification set at anything other than 100% and turn Firefox off, when you turn it on again it is back to 100%.

Probably a small change in the program is responsible for that, and most likely we will have to put up with it. Or maybe it was No Squint that actually maintained the zoom setting for ever?

Barry

Hi again remarks. Even though I can now zoom again there has been a change in how the zoom works. Before, once the page had been set to a certain percentage magnification it stayed there for ever. You could shut the PC down and any time in the future when you turned it on and opened Firefox it was still at the percentage you initially set. Now, you only have to change a page and Firefox reverts to 100%, and stays at 100%, and if you have the magnification set at anything other than 100% and turn Firefox off, when you turn it on again it is back to 100%. Probably a small change in the program is responsible for that, and most likely we will have to put up with it. Or maybe it was No Squint that actually maintained the zoom setting for ever? Barry
Richard Marks 1 solutions 4 answers

Yes, NoSquint saved the settings. Now some idiot screwed it up. That's what happens with collaborative software I guess. I hope this gets fixed because now FireFox is harder to use.

Yes, NoSquint saved the settings. Now some idiot screwed it up. That's what happens with collaborative software I guess. I hope this gets fixed because now FireFox is harder to use.

Question owner

For anyone that has had the same trouble as me with No Squint stuffing up zoom on Firefox version 47.0, I went searching and found No Squint Plus. Google it. It does everything and more than No Squint, and 47.0 is compatible with it. Barry

For anyone that has had the same trouble as me with No Squint stuffing up zoom on Firefox version 47.0, I went searching and found No Squint Plus. Google it. It does everything and more than No Squint, and 47.0 is compatible with it. Barry