Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"This browser does not support video playback." Video playback Error on Twitter: Windows 10

  • 11 replies
  • 457 have this problem
  • 58437 views
  • Last reply by 1artworkz

more options

I swapped from chrome to firefox and I get this error when trying to play video's on twitter.

Running windows 10 x64.

Chosen solution

and there it is, the 'disconnect' add on is the culprit. It's all sorted. Thanks for your help philipp! this has been bugging me for weeks :)

Read this answer in context 👍 10

All Replies (11)

more options

hi Vulcan88, are you using a windows n version by any chance?

more options

philipp said

hi Vulcan88, are you using a windows n version by any chance?

how would i check this?

more options

you can go into your system settings app > system > info where it lists your edition of windows.

more options

I dont think sophilipp said

you can go into your system settings app > system > info where it lists your edition of windows.

i dont think so

more options

I did just install a windows 10 media pack for N and KN that i found on the microsoft website after a quick google search just to be sure, but it didnt work

more options

thanks, can you try to replicate this behaviour when you launch firefox in safe mode with addons disabled once? if not, maybe an addon is interfering here...

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

more options

Hmm looks like that's it. running in safe mod let's me play the video's fine. So it's one of my extensions/plugins that's causing problems?

more options

yes, i'd especially try to look at your video related ones (youtube hd, betterttv) and content blocking ones & disable them one by one to find out the culprit...

more options

Chosen Solution

and there it is, the 'disconnect' add on is the culprit. It's all sorted. Thanks for your help philipp! this has been bugging me for weeks :)

more options

I've got this problem, it's been bugging me for months. Not running Windows N version it is 10586.494, have started FF in safe mode, same issue. Refreshed FF (64 bit) couldn't load Google due to certificate issues, deleted some file, still can't get get twitter videos to load.

Recreated a brand new FF profile, still same issue, issue also exists in MS EDGE. Plugins all up to date. Keep getting message, Browser does not support video playback. The strange thing is, it works on my laptop which has the exact same setup (FF 64-bit, Win 10 version, same plugins etc).

Advice please

more options

firefox video play back in twitter "This browser does not support video playback." I had this problem with Windows 8.1 so maybe this won't work with 10 but it might be worth a try. Using about:config see that media.mediasource.enabled Value is true.