Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I make DownThemAll work with the newer version of Firefox?

  • 5 replies
  • 6 have this problem
  • 11068 views
  • Last reply by James

more options

I am not able to use the DownThemAll extension with Firefox since I updated it. What can I do to make it work again?

Modified by ShaneWatson33

Chosen solution

ShaneWatson33 said

I am not able to use the DownThemAll extension with Firefox since I updated it. What can I do to make it work again?

What version of the DownThemAll Extension do you have as the author did a recent update for this extension on April 14 which is listed as works with 41.0 - 47.*.

https://addons.mozilla.org/firefox/addon/downthemall/versions/ https://addons.mozilla.org/firefox/addon/downthemall/

I notice you appear to be Testing Beta channel builds of Firefox 46.0b# (current is 46.0b11) and extension authors may only support current Release at most.

Read this answer in context 👍 0

All Replies (5)

more options

Hi

Add-ons for Firefox are developed by a large community of third party developers. I recommend you contact the developer of the add-on in question which should be able to support and/or fix the software the have produced.

I hope this helps, but if not, please come back here and we can look into a different solution for you.

more options

Chosen Solution

ShaneWatson33 said

I am not able to use the DownThemAll extension with Firefox since I updated it. What can I do to make it work again?

What version of the DownThemAll Extension do you have as the author did a recent update for this extension on April 14 which is listed as works with 41.0 - 47.*.

https://addons.mozilla.org/firefox/addon/downthemall/versions/ https://addons.mozilla.org/firefox/addon/downthemall/

I notice you appear to be Testing Beta channel builds of Firefox 46.0b# (current is 46.0b11) and extension authors may only support current Release at most.

Modified by James

more options

I fixed it! I just had to reinstall DownThemAll. I guess it was some other problem I was unaware of. Anyway, thanks for the reply!

more options

I had the same problem with firefox 43.0.1 and dTa 2.0.19. The only solution I found is to install the old version of dTa (2.0.18.1-signed.1-let-fixed from https://addons.mozilla.org/uk/firefox/addon/downthemall/versions/ ), turn off auto-update in addons' settings (and turn off checking the addons compatibility if dTa doesn't work with your version of firefox - by setting extensions.checkCompatibility.<firefox-version>=false in about:config, for example extensions.checkCompatibility.43.0=false)

more options

Firefox 43.0.1 is a old Release version as the current is Firefox 46.0.1

Only reason why you may have 43.0.1 is because you are using either Windows XP or Vista. You can do a update in Firefox to 46.0.1.

https://support.mozilla.org/en-US/kb/get-latest-version-firefox-windows-xp-vista